aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-connectivity/farsight/libnice_0.0.6.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-connectivity/farsight/libnice_0.0.6.bb')
-rw-r--r--meta/recipes-connectivity/farsight/libnice_0.0.6.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/farsight/libnice_0.0.6.bb b/meta/recipes-connectivity/farsight/libnice_0.0.6.bb
new file mode 100644
index 0000000000..809b691af7
--- /dev/null
+++ b/meta/recipes-connectivity/farsight/libnice_0.0.6.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "Libnice is an implementation of the IETF's draft Interactice Connectivity Establishment standard (ICE)."
+HOMEPAGE = "http://nice.freedesktop.org/wiki/"
+SRC_URI = "http://nice.freedesktop.org/releases/libnice-${PV}.tar.gz"
+
+LICENSE = "LGPL/MPL"
+DEPENDS = "glib-2.0 gstreamer"
+
+inherit autotools
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+FILES_${PN} += "${libdir}/gstreamer-0.10/*.so"
+FILES_${PN}-dev += "${libdir}/gstreamer-0.10/*a"
+FILES_${PN}-dbg += "${libdir}/gstreamer-0.10/.debug"
+
+do_compile_append() {
+ for i in $(find ${S} -name "*.pc") ; do
+ sed -i -e s:${STAGING_DIR_TARGET}::g \
+ -e s:/${TARGET_SYS}::g \
+ $i
+ done
+}
+
+