aboutsummaryrefslogtreecommitdiffstats
path: root/meta/recipes-bsp/hostap/hostap-conf_1.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta/recipes-bsp/hostap/hostap-conf_1.0.bb')
-rw-r--r--meta/recipes-bsp/hostap/hostap-conf_1.0.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta/recipes-bsp/hostap/hostap-conf_1.0.bb b/meta/recipes-bsp/hostap/hostap-conf_1.0.bb
new file mode 100644
index 0000000000..ce069662c7
--- /dev/null
+++ b/meta/recipes-bsp/hostap/hostap-conf_1.0.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "PCMCIA-cs configuration files for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
+SECTION = "kernel/modules"
+PRIORITY = "optional"
+LICENSE = "GPL"
+RDEPENDS = "update-modules"
+PACKAGE_ARCH = "all"
+PR = "r10"
+
+SRC_URI = "file://hostap_cs.modalias"
+
+do_compile() {
+}
+
+do_install() {
+ install -d ${D}${sysconfdir}/modutils
+
+ install -m 0644 ${WORKDIR}/hostap_cs.modalias ${D}${sysconfdir}/modutils/hostap_cs.conf
+}
+
+pkg_postinst () {
+ if [ -n "$D" ]; then
+ exit 1
+ fi
+ update-modules || true
+}
+
+pkg_postrm () {
+ update-modules || true
+}