aboutsummaryrefslogtreecommitdiffstats
path: root/meta/packages/mozilla
diff options
context:
space:
mode:
Diffstat (limited to 'meta/packages/mozilla')
-rw-r--r--meta/packages/mozilla/files/eabi-fix.patch66
-rw-r--r--meta/packages/mozilla/files/eabi-fix2.patch56
-rw-r--r--meta/packages/mozilla/files/eabi-fix3.patch15
-rw-r--r--meta/packages/mozilla/files/minimo.desktop9
-rw-r--r--meta/packages/mozilla/files/minimo.pngbin4323 -> 0 bytes
-rw-r--r--meta/packages/mozilla/minimo/bug-322806.diff13
-rw-r--r--meta/packages/mozilla/minimo/minimo4
-rw-r--r--meta/packages/mozilla/minimo/minimo.patch356
-rw-r--r--meta/packages/mozilla/minimo/minimo.pngbin4323 -> 0 bytes
-rw-r--r--meta/packages/mozilla/minimo/mozconfig36
-rw-r--r--meta/packages/mozilla/minimo_cvs.bb153
11 files changed, 0 insertions, 708 deletions
diff --git a/meta/packages/mozilla/files/eabi-fix.patch b/meta/packages/mozilla/files/eabi-fix.patch
deleted file mode 100644
index fd3bb88683..0000000000
--- a/meta/packages/mozilla/files/eabi-fix.patch
+++ /dev/null
@@ -1,66 +0,0 @@
-http://lists.debian.org/debian-arm/2007/05/msg00039.html
-
-From: Lennert Buytenhek <buytenh@wantstofly.org>
-
-Hi,
-
-The reason that building nss (i.e., firefox) would segfault on ARM EABI
-systems is an assumption about the layout of the jmp_buf structure in
-the nspr library (which nss depends on) that does hold on old-ABI but
-no longer holds on EABI. The attached patch fixes this assumption,
-and fixes the shlibsign segfault during the building of nss (it also
-fixes a floating point byte order assumption.)
-
-Looks sane?
-
-It's of course a stupid idea to depend on a particular layout of the
-jmp_buf structure in application programs, but oh well. People write
-ugly buggy code, film at 11.
-
-
---- mozilla/nsprpub/pr/src/misc/prdtoa.c.orig 2007-05-06 02:39:00.000000000 +0200
-+++ mozilla/nsprpub/pr/src/misc/prdtoa.c 2007-05-06 02:39:22.000000000 +0200
-@@ -59,8 +59,8 @@
- /* FIXME: deal with freelist and p5s. */
- }
-
--#if defined(__arm) || defined(__arm__) || defined(__arm26__) \
-- || defined(__arm32__)
-+#if (defined(__arm) || defined(__arm__) || defined(__arm26__) \
-+ || defined(__arm32__)) && !defined(__ARM_EABI__) && !defined(__ARMEB__)
- #define IEEE_ARM
- #elif defined(IS_LITTLE_ENDIAN)
- #define IEEE_8087
---- mozilla/nsprpub/pr/include/md/_linux.h.orig 2007-05-06 02:39:45.000000000 +0200
-+++ mozilla/nsprpub/pr/include/md/_linux.h 2007-05-06 02:40:57.000000000 +0200
-@@ -346,7 +346,7 @@
- #error "Linux/MIPS pre-glibc2 not supported yet"
- #endif /* defined(__GLIBC__) && __GLIBC__ >= 2 */
-
--#elif defined(__arm__)
-+#elif defined(__arm__) && !defined(__ARM_EABI__)
- /* ARM/Linux */
- #if defined(__GLIBC__) && __GLIBC__ >= 2
- #define _MD_GET_SP(_t) (_t)->md.context[0].__jmpbuf[20]
-@@ -358,6 +358,18 @@
- #error "ARM/Linux pre-glibc2 not supported yet"
- #endif /* defined(__GLIBC__) && __GLIBC__ >= 2 */
-
-+#elif defined(__arm__) && defined(__ARM_EABI__)
-+/* ARM/Linux */
-+#if defined(__GLIBC__) && __GLIBC__ >= 2
-+#define _MD_GET_SP(_t) (_t)->md.context[0].__jmpbuf[8]
-+#define _MD_SET_FP(_t, val) ((_t)->md.context[0].__jmpbuf[7] = (val))
-+#define _MD_GET_SP_PTR(_t) &(_MD_GET_SP(_t))
-+#define _MD_GET_FP_PTR(_t) (&(_t)->md.context[0].__jmpbuf[7])
-+#define _MD_SP_TYPE __ptr_t
-+#else
-+#error "ARM/Linux pre-glibc2 not supported yet"
-+#endif /* defined(__GLIBC__) && __GLIBC__ >= 2 */
-+
- #else
-
- #error "Unknown CPU architecture"
-
-
-
diff --git a/meta/packages/mozilla/files/eabi-fix2.patch b/meta/packages/mozilla/files/eabi-fix2.patch
deleted file mode 100644
index 5f64e7f796..0000000000
--- a/meta/packages/mozilla/files/eabi-fix2.patch
+++ /dev/null
@@ -1,56 +0,0 @@
-https://bugzilla.mozilla.org/show_bug.cgi?id=369722
-
-Index: js/src/jsnum.h
-===================================================================
-RCS file: /cvsroot/mozilla/js/src/jsnum.h,v
-retrieving revision 3.27
-diff -p -u -8 -r3.27 jsnum.h
---- mozilla/js/src/jsnum.h 21 Dec 2006 01:00:32 -0000 3.27
-+++ mozilla/js/src/jsnum.h 8 Feb 2007 12:13:01 -0000
-@@ -52,23 +52,24 @@ JS_BEGIN_EXTERN_C
-
- /*
- * Stefan Hanske <sh990154@mail.uni-greifswald.de> reports:
- * ARM is a little endian architecture but 64 bit double words are stored
- * differently: the 32 bit words are in little endian byte order, the two words
- * are stored in big endian`s way.
- */
-
--#if defined(__arm) || defined(__arm32__) || defined(__arm26__) || defined(__arm__)
--#define CPU_IS_ARM
-+#if !defined(__ARM_EABI__) && \
-+ (defined(__arm) || defined(__arm32__) || defined(__arm26__) || defined(__arm__))
-+#define IEEE_ARM
- #endif
-
- typedef union jsdpun {
- struct {
--#if defined(IS_LITTLE_ENDIAN) && !defined(CPU_IS_ARM)
-+#if defined(IS_LITTLE_ENDIAN) && !defined(IEEE_ARM)
- uint32 lo, hi;
- #else
- uint32 hi, lo;
- #endif
- } s;
- jsdouble d;
- } jsdpun;
-
-@@ -87,17 +88,17 @@ typedef union jsdpun {
-
- #else /* not or old GNUC */
-
- /*
- * We don't know of any non-gcc compilers that perform alias optimization,
- * so this code should work.
- */
-
--#if defined(IS_LITTLE_ENDIAN) && !defined(CPU_IS_ARM)
-+#if defined(IS_LITTLE_ENDIAN) && !defined(IEEE_ARM)
- #define JSDOUBLE_HI32(x) (((uint32 *)&(x))[1])
- #define JSDOUBLE_LO32(x) (((uint32 *)&(x))[0])
- #else
- #define JSDOUBLE_HI32(x) (((uint32 *)&(x))[0])
- #define JSDOUBLE_LO32(x) (((uint32 *)&(x))[1])
- #endif
-
- #define JSDOUBLE_SET_HI32(x, y) (JSDOUBLE_HI32(x)=(y))
diff --git a/meta/packages/mozilla/files/eabi-fix3.patch b/meta/packages/mozilla/files/eabi-fix3.patch
deleted file mode 100644
index 8bf8c2f4da..0000000000
--- a/meta/packages/mozilla/files/eabi-fix3.patch
+++ /dev/null
@@ -1,15 +0,0 @@
-From: Marcin Juszkiewicz <openembedded@hrw.one.pl>
-
-Index: mozilla/extensions/transformiix/source/base/Double.cpp
-===================================================================
---- mozilla.orig/extensions/transformiix/source/base/Double.cpp 2007-05-09 11:21:34.000000000 +0200
-+++ mozilla/extensions/transformiix/source/base/Double.cpp 2007-05-09 11:23:59.000000000 +0200
-@@ -71,7 +71,7 @@
- * are stored in big endian`s way.
- */
-
--#if defined(__arm) || defined(__arm32__) || defined(_arm26__) || defined(__arm__)
-+#if !defined(__ARM_EABI__) && defined(__arm) || defined(__arm32__) || defined(_arm26__) || defined(__arm__)
- #define CPU_IS_ARM
- #endif
-
diff --git a/meta/packages/mozilla/files/minimo.desktop b/meta/packages/mozilla/files/minimo.desktop
deleted file mode 100644
index 5ef0f2075a..0000000000
--- a/meta/packages/mozilla/files/minimo.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=Minimo
-Comment=Minimo web browser
-Exec=minimo http://www.mozilla.org/projects/minimo/home.html
-Terminal=0
-Type=Application
-Icon=minimo.png
-Categories=Application;Network;
-StartupNotify=True
diff --git a/meta/packages/mozilla/files/minimo.png b/meta/packages/mozilla/files/minimo.png
deleted file mode 100644
index f8b2e2192b..0000000000
--- a/meta/packages/mozilla/files/minimo.png
+++ /dev/null
Binary files differ
diff --git a/meta/packages/mozilla/minimo/bug-322806.diff b/meta/packages/mozilla/minimo/bug-322806.diff
deleted file mode 100644
index e001e3fc67..0000000000
--- a/meta/packages/mozilla/minimo/bug-322806.diff
+++ /dev/null
@@ -1,13 +0,0 @@
-See https://bugzilla.mozilla.org/show_bug.cgi?id=322806 and http://bugs.openembedded.org/show_bug.cgi?id=1600
-
---- /tmp/xptcinvoke_arm.cpp 2006-12-10 20:02:57.000000000 +0100
-+++ mozilla/xpcom/reflect/xptcall/src/md/unix/xptcinvoke_arm.cpp 2006-12-10 20:03:54.592227000 +0100
-@@ -212,7 +212,7 @@
- "add sp, sp, r4 \n\t" /* restore stack pointer */
- "mov %0, r0 \n\t" /* the result... */
- : "=r" (result)
-- : "r" (&my_params)
-+ : "r" (&my_params), "m" (my_params)
- : "r0", "r1", "r2", "r3", "r4", "ip", "lr", "sp"
- );
-
diff --git a/meta/packages/mozilla/minimo/minimo b/meta/packages/mozilla/minimo/minimo
deleted file mode 100644
index d130173adf..0000000000
--- a/meta/packages/mozilla/minimo/minimo
+++ /dev/null
@@ -1,4 +0,0 @@
-#!/bin/sh
-export MOZILLA_FIVE_HOME=/usr/lib/mozilla-minimo
-export LD_LIBRARY_PATH=${MOZILLA_FIVE_HOME}
-exec ${MOZILLA_FIVE_HOME}/minimo "$@"
diff --git a/meta/packages/mozilla/minimo/minimo.patch b/meta/packages/mozilla/minimo/minimo.patch
deleted file mode 100644
index 8894ee7f45..0000000000
--- a/meta/packages/mozilla/minimo/minimo.patch
+++ /dev/null
@@ -1,356 +0,0 @@
-Index: mozilla/content/html/content/src/nsFormSubmission.cpp
-===================================================================
---- mozilla.orig/content/html/content/src/nsFormSubmission.cpp 2005-07-13 18:55:59.000000000 +0200
-+++ mozilla/content/html/content/src/nsFormSubmission.cpp 2007-05-10 12:11:20.000000000 +0200
-@@ -1315,11 +1315,6 @@
- nsresult rv = NS_OK;
-
- nsCAutoString charset(aCharset);
-- // canonical name is passed so that we just have to check against
-- // *our* canonical names listed in charsetaliases.properties
-- if (charset.EqualsLiteral("ISO-8859-1")) {
-- charset.AssignLiteral("windows-1252");
-- }
-
- // use UTF-8 for UTF-16* and UTF-32* (per WHATWG and existing practice of
- // MS IE/Opera).
-Index: mozilla/embedding/base/Makefile.in
-===================================================================
---- mozilla.orig/embedding/base/Makefile.in 2006-02-14 06:28:31.000000000 +0100
-+++ mozilla/embedding/base/Makefile.in 2007-05-10 12:11:20.000000000 +0200
-@@ -43,6 +43,7 @@
-
- MODULE = embed_base
- LIBRARY_NAME = embed_base_s
-+EXPORT_LIBRARY = 1
- XPIDL_MODULE = embed_base
-
- include $(DEPTH)/config/autoconf.mk
-Index: mozilla/js/src/Makefile.in
-===================================================================
---- mozilla.orig/js/src/Makefile.in 2006-07-28 00:56:20.000000000 +0200
-+++ mozilla/js/src/Makefile.in 2007-05-10 12:11:21.000000000 +0200
-@@ -46,6 +46,7 @@
-
- MODULE = js
- LIBRARY_NAME = mozjs
-+EXPORT_LIBRARY = 1
- LIB_IS_C_ONLY = 1
- GRE_MODULE = 1
-
-Index: mozilla/minimo/Makefile.in
-===================================================================
---- mozilla.orig/minimo/Makefile.in 2006-07-24 21:40:53.000000000 +0200
-+++ mozilla/minimo/Makefile.in 2007-05-10 12:13:46.000000000 +0200
-@@ -41,6 +41,6 @@
-
- include $(DEPTH)/config/autoconf.mk
-
--DIRS = config components chrome locales customization base extensions
-+DIRS = config chrome locales customization base extensions
-
- include $(topsrcdir)/config/rules.mk
-Index: mozilla/minimo/base/Makefile.in
-===================================================================
---- mozilla.orig/minimo/base/Makefile.in 2006-08-09 17:42:26.000000000 +0200
-+++ mozilla/minimo/base/Makefile.in 2007-05-10 12:11:21.000000000 +0200
-@@ -96,7 +96,6 @@
-
- # this should move into the toolkit!
- LOCAL_INCLUDES = -I$(srcdir) -I$(topsrcdir)/xpfe/browser/src/
--CPPSRCS += nsBrowserStatusFilter.cpp nsBrowserInstance.cpp
-
- ifdef WINCE
- RCINCLUDE = wince/SplashScreen.rc
-@@ -143,10 +142,6 @@
- endif
-
-
--FINAL_LINK_COMPS=$(topsrcdir)/minimo/base/$(FINAL_PLATFORM)/minimo-link-comps
--FINAL_LINK_COMP_NAMES=$(topsrcdir)/minimo/base/$(FINAL_PLATFORM)/minimo-link-names
--FINAL_LINK_LIBS=$(topsrcdir)/minimo/base/$(FINAL_PLATFORM)/minimo-link-libs
--
- include $(topsrcdir)/config/static-config.mk
-
- EXTRA_DEPS += $(STATIC_EXTRA_DEPS)
-@@ -180,14 +175,11 @@
- # (same as in mozilla/js/src/Makefile.in)
- ifdef WINCE
- LDFLAGS += -OPT:NOICF
-+else
-+# Hack to work around libxpcom_core.a / libunicharutil_s.a link order problem.
-+LDFLAGS += -u NS_StringGetData_P -u NS_StringGetMutableData_P
- endif
-
--export::
-- $(NSINSTALL) $(topsrcdir)/xpfe/browser/src/nsBrowserStatusFilter.cpp .
-- $(NSINSTALL) $(topsrcdir)/xpfe/browser/src/nsBrowserInstance.cpp .
--
--
--GARBAGE += nsBrowserStatusFilter.cpp nsBrowserInstance.cpp
-
- ifdef WINCE
- package::
-Index: mozilla/minimo/base/Minimo.cpp
-===================================================================
---- mozilla.orig/minimo/base/Minimo.cpp 2006-10-27 22:30:36.000000000 +0200
-+++ mozilla/minimo/base/Minimo.cpp 2007-05-10 12:13:21.000000000 +0200
-@@ -813,6 +813,8 @@
- #ifdef MOZ_WIDGET_GTK2
- gtk_set_locale();
- gtk_init(&argc, &argv);
-+ gtk_widget_set_default_visual(gdk_rgb_get_visual());
-+ gtk_widget_set_default_colormap(gdk_rgb_get_cmap());
- #endif
-
- #ifdef HACKY_PRE_LOAD_LIBRARY
-Index: mozilla/minimo/base/SplashScreen.cpp
-===================================================================
---- mozilla.orig/minimo/base/SplashScreen.cpp 2006-08-21 21:00:24.000000000 +0200
-+++ mozilla/minimo/base/SplashScreen.cpp 2007-05-10 12:11:22.000000000 +0200
-@@ -202,9 +202,24 @@
- void KillSplashScreen() {}
- void GetScreenSize(unsigned long* x, unsigned long* y)
- {
-+#ifdef MOZ_WIDGET_GTK2
-+ GdkDisplay* display = gdk_display_get_default();
-+ if (display != NULL)
-+ {
-+ GdkScreen *screen;
-+ screen = gdk_display_get_default_screen(display);
-+ *x = gdk_screen_get_width(screen);
-+ *y = gdk_screen_get_height(screen);
-+ }
-+ else
-+ {
-+#endif
- // we need to figure this out.
- *x = 240;
- *y = 320;
-+#ifdef MOZ_WIDGET_GTK2
-+ }
-+#endif
- }
-
-
-Index: mozilla/minimo/config/linux_package.sh
-===================================================================
---- mozilla.orig/minimo/config/linux_package.sh 2006-06-30 18:35:19.000000000 +0200
-+++ mozilla/minimo/config/linux_package.sh 2007-05-10 12:11:22.000000000 +0200
-@@ -29,9 +29,7 @@
- cp -pRL bin/libnssckbi.so minimo
- cp -pRL bin/libsmime3.so minimo
- cp -pRL bin/libsoftokn3.so minimo
--cp -pRL bin/libsoftokn3.chk minimo
- cp -pRL bin/libfreebl3.so minimo
--cp -pRL bin/libfreebl3.chk minimo
- cp -pRL bin/libssl3.so minimo
-
- mkdir -p minimo/chrome
-@@ -62,8 +60,6 @@
- cp -pRL bin/components/nsHelperAppDlg.js minimo/components
- cp -pRL bin/components/nsProgressDialog.js minimo/components
-
--cp -pRL bin/extensions/spatial-navigation@extensions.mozilla.org/components/* minimo/components
--
- mkdir -p minimo/greprefs
- cp -pRL bin/greprefs/* minimo/greprefs
-
-@@ -80,7 +76,7 @@
-
- echo Linking XPT files.
-
--bin/xpt_link minimo/components/all.xpt bin/components/*.xpt
-+host/bin/host_xpt_link minimo/components/all.xpt bin/components/*.xpt
-
- echo Chewing on chrome
-
-Index: mozilla/profile/dirserviceprovider/src/Makefile.in
-===================================================================
---- mozilla.orig/profile/dirserviceprovider/src/Makefile.in 2005-04-06 05:35:21.000000000 +0200
-+++ mozilla/profile/dirserviceprovider/src/Makefile.in 2007-05-10 12:11:23.000000000 +0200
-@@ -44,6 +44,7 @@
-
- MODULE = profdirserviceprovider
- LIBRARY_NAME = profdirserviceprovider_s
-+EXPORT_LIBRARY = 1
- MOZILLA_INTERNAL_API = 1
-
- REQUIRES = xpcom \
-Index: mozilla/security/coreconf/Linux.mk
-===================================================================
---- mozilla.orig/security/coreconf/Linux.mk 2006-02-03 23:26:36.000000000 +0100
-+++ mozilla/security/coreconf/Linux.mk 2007-05-10 12:11:23.000000000 +0200
-@@ -117,6 +117,10 @@
- OS_REL_CFLAGS = -DLINUX1_2 -D_XOPEN_SOURCE
- CPU_ARCH = mips
- else
-+ifeq ($(OS_TEST),arm)
-+ OS_REL_CFLAGS = -DLINUX1_2 -D_XOPEN_SOURCE
-+ CPU_ARCH = arm
-+else
- OS_REL_CFLAGS = -DLINUX1_2 -Di386 -D_XOPEN_SOURCE
- CPU_ARCH = x86
- endif
-@@ -133,6 +137,7 @@
- endif
- endif
- endif
-+endif
-
-
- LIBC_TAG = _glibc
-Index: mozilla/security/coreconf/arch.mk
-===================================================================
---- mozilla.orig/security/coreconf/arch.mk 2006-02-03 23:26:36.000000000 +0100
-+++ mozilla/security/coreconf/arch.mk 2007-05-10 12:11:24.000000000 +0200
-@@ -60,18 +60,14 @@
- 64BIT_TAG=
- endif
-
--OS_ARCH := $(subst /,_,$(shell uname -s))
-+OS_ARCH := Linux
-
- #
- # Attempt to differentiate between sparc and x86 Solaris
- #
-
--OS_TEST := $(shell uname -m)
--ifeq ($(OS_TEST),i86pc)
-- OS_RELEASE := $(shell uname -r)_$(OS_TEST)
--else
-- OS_RELEASE := $(shell uname -r)
--endif
-+OS_TEST := arm
-+OS_RELEASE := 2.6
-
- #
- # Force the IRIX64 machines to use IRIX.
-Index: mozilla/toolkit/components/build/Makefile.in
-===================================================================
---- mozilla.orig/toolkit/components/build/Makefile.in 2006-07-13 22:08:29.000000000 +0200
-+++ mozilla/toolkit/components/build/Makefile.in 2007-05-10 12:11:27.000000000 +0200
-@@ -112,7 +112,6 @@
- $(NULL)
-
- SHARED_LIBRARY_LIBS = \
-- ../startup/src/$(LIB_PREFIX)appstartup_s.$(LIB_SUFFIX) \
- $(NULL)
-
- ifdef MOZ_XPINSTALL
-Index: mozilla/toolkit/components/startup/src/Makefile.in
-===================================================================
---- mozilla.orig/toolkit/components/startup/src/Makefile.in 2005-07-27 22:42:44.000000000 +0200
-+++ mozilla/toolkit/components/startup/src/Makefile.in 2007-05-10 12:11:27.000000000 +0200
-@@ -43,6 +43,7 @@
-
- MODULE = toolkitcomps
- LIBRARY_NAME = appstartup_s
-+EXPORT_LIBRARY = 1
- FORCE_STATIC_LIB = 1
- LIBXUL_LIBRARY = 1
-
-Index: mozilla/toolkit/xre/Makefile.in
-===================================================================
---- mozilla.orig/toolkit/xre/Makefile.in 2007-02-06 08:13:20.000000000 +0100
-+++ mozilla/toolkit/xre/Makefile.in 2007-05-10 12:11:27.000000000 +0200
-@@ -45,7 +45,6 @@
-
- MODULE = xulapp
- LIBRARY_NAME = xulapp_s
--EXPORT_LIBRARY = 1
- LIBXUL_LIBRARY = 1
-
- REQUIRES = \
-@@ -180,14 +179,6 @@
-
- include $(topsrcdir)/config/rules.mk
-
--ifdef BUILD_STATIC_LIBS
--export::
-- @$(PERL) -I$(MOZILLA_DIR)/config $(MOZILLA_DIR)/config/build-list.pl $(FINAL_LINK_COMP_NAMES) Apprunner
--# embedding/browser/gtk/src/Makefile.in sucks! we need to add an empty line to
--# FINAL_LINK_COMPS to keep the two lists in sync :-(
-- @$(PERL) -I$(MOZILLA_DIR)/config $(MOZILLA_DIR)/config/build-list.pl $(FINAL_LINK_COMPS) ""
--endif
--
- LOCAL_INCLUDES += \
- -I$(srcdir) \
- -I$(topsrcdir)/xpfe/bootstrap \
-Index: mozilla/xpcom/build/Makefile.in
-===================================================================
---- mozilla.orig/xpcom/build/Makefile.in 2006-01-29 17:51:02.000000000 +0100
-+++ mozilla/xpcom/build/Makefile.in 2007-05-10 12:11:27.000000000 +0200
-@@ -61,7 +61,7 @@
- endif
-
- # Do not set EXPORT_LIBRARY as we do not want xpcom in the static libs list
--#EXPORT_LIBRARY = 1
-+EXPORT_LIBRARY = 1
- GRE_MODULE = 1
- MOZILLA_INTERNAL_API = 1
-
-Index: mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp
-===================================================================
---- mozilla.orig/xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp 2004-04-18 16:18:18.000000000 +0200
-+++ mozilla/xpcom/reflect/xptcall/src/md/unix/xptcstubs_arm.cpp 2007-05-10 12:11:27.000000000 +0200
-@@ -45,9 +45,9 @@
- #endif
-
- /* Specify explicitly a symbol for this function, don't try to guess the c++ mangled symbol. */
--static nsresult PrepareAndDispatch(nsXPTCStubBase* self, uint32 methodIndex, PRUint32* args) asm("_PrepareAndDispatch");
-+nsresult PrepareAndDispatch(nsXPTCStubBase* self, uint32 methodIndex, PRUint32* args) asm("_PrepareAndDispatch");
-
--static nsresult
-+nsresult
- PrepareAndDispatch(nsXPTCStubBase* self, uint32 methodIndex, PRUint32* args)
- {
- #define PARAM_BUFFER_COUNT 16
-Index: mozilla/xpfe/browser/src/Makefile.in
-===================================================================
---- mozilla.orig/xpfe/browser/src/Makefile.in 2005-03-18 22:23:45.000000000 +0100
-+++ mozilla/xpfe/browser/src/Makefile.in 2007-05-10 12:11:27.000000000 +0200
-@@ -44,6 +44,7 @@
-
- MODULE = browser
- LIBRARY_NAME = mozbrwsr_s
-+EXPORT_LIBRARY = 1
- FORCE_STATIC_LIB = 1
- LIBXUL_LIBRARY = 1
- MODULE_NAME = nsBrowserModule
-Index: mozilla/xpfe/components/build/Makefile.in
-===================================================================
---- mozilla.orig/xpfe/components/build/Makefile.in 2005-09-27 02:15:25.000000000 +0200
-+++ mozilla/xpfe/components/build/Makefile.in 2007-05-10 12:11:27.000000000 +0200
-@@ -44,7 +44,6 @@
-
- MODULE = appcomps
- LIBRARY_NAME = appcomps
--EXPORT_LIBRARY = 1
- IS_COMPONENT = 1
- MODULE_NAME = application
- LIBXUL_LIBRARY = 1
-Index: mozilla/xpfe/components/filepicker/src/Makefile.in
-===================================================================
---- mozilla.orig/xpfe/components/filepicker/src/Makefile.in 2006-05-22 18:29:32.000000000 +0200
-+++ mozilla/xpfe/components/filepicker/src/Makefile.in 2007-05-10 12:11:27.000000000 +0200
-@@ -47,7 +47,6 @@
- MODULE = filepicker
- LIBRARY_NAME = fileview
- SHORT_LIBNAME = fileview
--EXPORT_LIBRARY = 1
- IS_COMPONENT = 1
- MODULE_NAME = nsFileViewModule
- MOZILLA_INTERNAL_API = 1
-Index: mozilla/xpfe/components/find/src/Makefile.in
-===================================================================
---- mozilla.orig/xpfe/components/find/src/Makefile.in 2005-03-18 22:23:46.000000000 +0100
-+++ mozilla/xpfe/components/find/src/Makefile.in 2007-05-10 12:11:27.000000000 +0200
-@@ -45,7 +45,6 @@
- MODULE = appcomps
- XPIDL_MODULE = mozfind
- LIBRARY_NAME = mozfind
--EXPORT_LIBRARY = 1
- IS_COMPONENT = 1
- MODULE_NAME = nsFindComponent
- LIBXUL_LIBRARY = 1
diff --git a/meta/packages/mozilla/minimo/minimo.png b/meta/packages/mozilla/minimo/minimo.png
deleted file mode 100644
index f8b2e2192b..0000000000
--- a/meta/packages/mozilla/minimo/minimo.png
+++ /dev/null
Binary files differ
diff --git a/meta/packages/mozilla/minimo/mozconfig b/meta/packages/mozilla/minimo/mozconfig
deleted file mode 100644
index 393981e9fa..0000000000
--- a/meta/packages/mozilla/minimo/mozconfig
+++ /dev/null
@@ -1,36 +0,0 @@
-# mozilla/configure: Features and packages:
-
-ac_add_options --enable-application=minimo
-ac_add_options --enable-default-toolkit=gtk2
-ac_add_options --disable-freetype2
-ac_add_options --enable-xft
-ac_add_options --disable-postscript
-ac_add_options --disable-xprint
-ac_add_options --disable-gnomevfs
-ac_add_options --disable-gnomeui
-ac_add_options --disable-jsd
-ac_add_options --disable-plugins
-ac_add_options --disable-view-source
-ac_add_options --disable-accessibility
-ac_add_options --disable-xpinstall
-ac_add_options --enable-single-profile
-ac_add_options --disable-jsloader
-ac_add_options --disable-printing
-ac_add_options --enable-native-uconv
-ac_add_options --enable-plaintext-editor-only
-ac_add_options --disable-xpcom-obsolete
-ac_add_options --disable-pref-extensions
-ac_add_options --disable-extensions
-ac_add_options --enable-image-decoders=png,gif,jpeg
-ac_add_options --disable-mathml
-ac_add_options --disable-installer
-ac_add_options --disable-updater
-ac_add_options --disable-tests
-ac_add_options --enable-optimize=-Os
-ac_add_options --disable-logging
-ac_add_options --enable-strip
-ac_add_options --enable-elf-dynstr-gc
-ac_add_options --disable-shared
-ac_add_options --enable-static
-ac_add_options --disable-profilesharing
-ac_add_options --disable-profilelocking
diff --git a/meta/packages/mozilla/minimo_cvs.bb b/meta/packages/mozilla/minimo_cvs.bb
deleted file mode 100644
index 5eec96d143..0000000000
--- a/meta/packages/mozilla/minimo_cvs.bb
+++ /dev/null
@@ -1,153 +0,0 @@
-DESCRIPTION = "A minimal version of the Mozilla web browser for mobile devices"
-SECTION = "x11/network"
-LICENSE = "MPL/GPL/LGPL"
-HOMEPAGE = "http://www.mozilla.org/projects/minimo/"
-PRIORITY = "optional"
-
-DEPENDS = "libxrender xt xft fontconfig freetype libidl dbus-glib pango atk gtk+ libidl-native"
-
-CVSSVR = "cvs-mirror.mozilla.org"
-BRTAG = "MOZILLA_1_8_BRANCH"
-MOZDATE = "20070510"
-
-PV = "0.02+cvs${MOZDATE}"
-PR = "r3"
-
-SRC_URI = "cvs://anonymous@${CVSSVR}/cvsroot;module=mozilla;tag=${BRTAG};date=${MOZDATE} \
- file://minimo.patch;patch=1 \
- file://bug-322806.diff;patch=1 \
- file://mozconfig \
- file://minimo \
- file://eabi-fix.patch;patch=1 \
- file://eabi-fix2.patch;patch=1 \
- file://eabi-fix3.patch;patch=1 \
- file://minimo.desktop \
- file://minimo.png"
-
-inherit autotools
-
-S = "${WORKDIR}/mozilla"
-
-export MOZCONFIG = "${WORKDIR}/mozconfig"
-
-export CROSS_COMPILE="1"
-export ac_cv_prog_HOST_CC="${BUILD_CC}"
-export ac_cv_prog_HOST_CFLAGS="${BUILD_CFLAGS}"
-export ac_cv_prog_HOST_CXX="${BUILD_CXX}"
-export ac_cv_prog_HOST_CXXFLAGS="${BUILD_CXXFLAGS}"
-export HOST_LIBIDL_CONFIG = "${STAGING_BINDIR_NATIVE}/libIDL-config-2"
-
-mozdir="${libdir}/mozilla-minimo"
-
-EXTRA_OECONF += "--build=${BUILD_SYS} --host=${BUILD_SYS} --target=${TARGET_SYS} "
-
-do_configure() {
- cd ${S}
- oe_runmake -f client.mk CONFIGURE_ARGS="${EXTRA_OECONF}" configure
- sed -i s:${TARGET_PREFIX}strip:echo:g config/autoconf.mk
-}
-
-do_compile() {
- cd ${S}
- oe_runmake -f client.mk build
-}
-
-do_install() {
- cd ${WORKDIR}
-
- install -d ${D}${bindir}
- install -m 0755 minimo ${D}${bindir}
-
- install -d ${D}${datadir}/applications
- install -m 0644 minimo.desktop ${D}${datadir}/applications
-
- install -d ${D}/${datadir}/pixmaps
- install -m 0644 minimo.png ${D}${datadir}/pixmaps
-
- cd ${S}
-
- ./minimo/config/linux_package.sh ${S} ${S}/minimo/config
-
- cd dist/minimo
-
- install -d ${D}${mozdir}
- install -m 0755 minimo ${D}${mozdir}
- install -m 0755 libfreebl3.so ${D}${mozdir}
- install -m 0755 libnspr4.so ${D}${mozdir}
- install -m 0755 libnss3.so ${D}${mozdir}
- install -m 0755 libnssckbi.so ${D}${mozdir}
- install -m 0755 libplc4.so ${D}${mozdir}
- install -m 0755 libplds4.so ${D}${mozdir}
- install -m 0755 libsmime3.so ${D}${mozdir}
- install -m 0755 libsoftokn3.so ${D}${mozdir}
- install -m 0755 libssl3.so ${D}${mozdir}
-
- install -d ${D}${mozdir}/chrome
- install -m 0644 chrome/classic.jar ${D}${mozdir}/chrome
- install -m 0644 chrome/classic.manifest ${D}${mozdir}/chrome
- install -m 0644 chrome/en-US.jar ${D}${mozdir}/chrome
- install -m 0644 chrome/en-US.manifest ${D}${mozdir}/chrome
- install -m 0644 chrome/minimo-skin-vga.jar ${D}${mozdir}/chrome
- install -m 0644 chrome/minimo-skin-vga.manifest ${D}${mozdir}/chrome
- install -m 0644 chrome/minimo-skin.jar ${D}${mozdir}/chrome
- install -m 0644 chrome/minimo-skin.manifest ${D}${mozdir}/chrome
- install -m 0644 chrome/minimo.jar ${D}${mozdir}/chrome
- install -m 0644 chrome/minimo.manifest ${D}${mozdir}/chrome
- install -m 0644 chrome/pippki.jar ${D}${mozdir}/chrome
- install -m 0644 chrome/pippki.manifest ${D}${mozdir}/chrome
- install -m 0644 chrome/toolkit.jar ${D}${mozdir}/chrome
- install -m 0644 chrome/toolkit.manifest ${D}${mozdir}/chrome
-
- install -d ${D}${mozdir}/components
- install -m 0644 components/all.xpt ${D}${mozdir}/components
- install -m 0644 components/nsHelperAppDlg.js ${D}${mozdir}/components
- install -m 0644 components/nsProgressDialog.js ${D}${mozdir}/components
-
- install -d ${D}${mozdir}/greprefs
- install -m 0644 greprefs/all.js ${D}${mozdir}/greprefs
- install -m 0644 greprefs/security-prefs.js ${D}${mozdir}/greprefs
-
- install -d ${D}${mozdir}/res
- install -m 0644 res/forms.css ${D}${mozdir}/res
- install -m 0644 res/html.css ${D}${mozdir}/res
- install -m 0644 res/quirk.css ${D}${mozdir}/res
- install -m 0644 res/ua.css ${D}${mozdir}/res
- install -m 0644 res/arrow.gif ${D}${mozdir}/res
- install -m 0644 res/arrowd.gif ${D}${mozdir}/res
- install -m 0644 res/broken-image.gif ${D}${mozdir}/res
- install -m 0644 res/loading-image.gif ${D}${mozdir}/res
- install -m 0644 res/charsetData.properties ${D}${mozdir}/res
- install -m 0644 res/charsetalias.properties ${D}${mozdir}/res
- install -m 0644 res/langGroups.properties ${D}${mozdir}/res
- install -m 0644 res/language.properties ${D}${mozdir}/res
- install -m 0644 res/unixcharset.properties ${D}${mozdir}/res
-
- install -d ${D}${mozdir}/res/dtd
- install -m 0644 res/dtd/xhtml11.dtd ${D}${mozdir}/res/dtd
-
- install -d ${D}${mozdir}/res/entityTables
- install -m 0644 res/entityTables/html40Latin1.properties ${D}${mozdir}/res/entityTables
- install -m 0644 res/entityTables/html40Special.properties ${D}${mozdir}/res/entityTables
- install -m 0644 res/entityTables/html40Symbols.properties ${D}${mozdir}/res/entityTables
- install -m 0644 res/entityTables/htmlEntityVersions.properties ${D}${mozdir}/res/entityTables
- install -m 0644 res/entityTables/transliterate.properties ${D}${mozdir}/res/entityTables
-
- install -d ${D}${mozdir}/res/fonts
- install -m 0644 res/fonts/fontEncoding.properties ${D}${mozdir}/res/fonts
- install -m 0644 res/fonts/pangoFontEncoding.properties ${D}${mozdir}/res/fonts
-
- install -d ${D}${mozdir}/res/html
- install -m 0644 res/html/gopher-audio.gif ${D}${mozdir}/res/html
- install -m 0644 res/html/gopher-binary.gif ${D}${mozdir}/res/html
- install -m 0644 res/html/gopher-find.gif ${D}${mozdir}/res/html
- install -m 0644 res/html/gopher-image.gif ${D}${mozdir}/res/html
- install -m 0644 res/html/gopher-menu.gif ${D}${mozdir}/res/html
- install -m 0644 res/html/gopher-movie.gif ${D}${mozdir}/res/html
- install -m 0644 res/html/gopher-sound.gif ${D}${mozdir}/res/html
- install -m 0644 res/html/gopher-telnet.gif ${D}${mozdir}/res/html
- install -m 0644 res/html/gopher-text.gif ${D}${mozdir}/res/html
- install -m 0644 res/html/gopher-unknown.gif ${D}${mozdir}/res/html
-}
-
-FILES_${PN}-dbg += "${libdir}/mozilla-minimo/.debug*"
-FILES_${PN} += "${mozdir}"