summaryrefslogtreecommitdiffstats
path: root/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb')
-rw-r--r--meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb5
1 files changed, 4 insertions, 1 deletions
diff --git a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
index b140b0ac8e..a2fb212a68 100644
--- a/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
+++ b/meta-skeleton/recipes-kernel/hello-mod/hello-mod_0.1.bb
@@ -1,5 +1,6 @@
SUMMARY = "Example of how to build an external Linux kernel module"
-LICENSE = "GPLv2"
+DESCRIPTION = "${SUMMARY}"
+LICENSE = "GPL-2.0-only"
LIC_FILES_CHKSUM = "file://COPYING;md5=12f884d2ae1ff87c09e5b7ccc2c4ca7e"
inherit module
@@ -13,3 +14,5 @@ S = "${WORKDIR}"
# The inherit of module.bbclass will automatically name module packages with
# "kernel-module-" prefix as required by the oe-core build environment.
+
+RPROVIDES:${PN} += "kernel-module-hello"