aboutsummaryrefslogtreecommitdiffstats
path: root/meta-extras/packages/smart/smart_1.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-extras/packages/smart/smart_1.1.bb')
-rw-r--r--meta-extras/packages/smart/smart_1.1.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/meta-extras/packages/smart/smart_1.1.bb b/meta-extras/packages/smart/smart_1.1.bb
new file mode 100644
index 0000000000..8f89eb3e00
--- /dev/null
+++ b/meta-extras/packages/smart/smart_1.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Next generation package handling tool."
+HOMEPAGE = "http://labix.org/smart/"
+LICENSE = "GPL v2+"
+DEPENDS = "zlib python desktop-file-utils-native python-pygtk rpm"
+
+SRC_URI = "http://labix.org/download/smart/smart-1.1.tar.bz2"
+
+S = "${WORKDIR}/smart-${PV}"
+
+inherit distutils
+
+FILES_${PN} += "/usr/share/lib/${PYTHON_DIR}/site-packages/smart/interfaces/images/*.png \
+ /usr/share/lib/${PYTHON_DIR/site-packages/smart/backends/"
+
+FILES_${PN}-doc += "/usr/share/share/man/man8/smart.8"
+
+FILES_${PN}-locale += "/usr/share/share/locale/es_ES/LC_MESSAGES/smart.mo \
+ /usr/share/share/locale/it/LC_MESSAGES/smart.mo \
+ /usr/share/share/locale/de/LC_MESSAGES/smart.mo \
+ /usr/share/share/locale/ru/LC_MESSAGES/smart.mo \
+ /usr/share/share/locale/sv/LC_MESSAGES/smart.mo \
+ /usr/share/share/locale/fr/LC_MESSAGES/smart.mo \
+ /usr/share/share/locale/hu/LC_MESSAGES/smart.mo \
+ /usr/share/share/locale/zh_TW/LC_MESSAGES/smart.mo \
+ /usr/share/share/locale/pt_BR/LC_MESSAGES/smart.mo \
+ /usr/share/share/locale/zh_CN/LC_MESSAGES/smart.mo"
+
+FILES_${PN}-dbg += "/usr/lib/${PYTHON_DIR}/site-packages/smart/backends/rpm/.debug \
+ /usr/lib/${PYTHON_DIR}/site-packages/smart/backends/deb/.debug \" \ No newline at end of file