summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-kernel/kexec/kexec-tools/0001-arm64-Set-fno-PIC-along-with-mcmodel-large.patch33
-rw-r--r--meta/recipes-kernel/kexec/kexec-tools_2.0.16.bb1
2 files changed, 34 insertions, 0 deletions
diff --git a/meta/recipes-kernel/kexec/kexec-tools/0001-arm64-Set-fno-PIC-along-with-mcmodel-large.patch b/meta/recipes-kernel/kexec/kexec-tools/0001-arm64-Set-fno-PIC-along-with-mcmodel-large.patch
new file mode 100644
index 0000000000..786fc0ce41
--- /dev/null
+++ b/meta/recipes-kernel/kexec/kexec-tools/0001-arm64-Set-fno-PIC-along-with-mcmodel-large.patch
@@ -0,0 +1,33 @@
+From a12dfe9be05f9dee96c7637a20c01e05711c563c Mon Sep 17 00:00:00 2001
+From: David Michael <david.michael@coreos.com>
+Date: Sun, 7 Jan 11:26:57 2018 -0500
+Subject: [PATCH] arm64: Set -fno-PIC along with -mcmodel=large
+
+As seen in GCC's gcc/config/aarch64/aarch64.c, -fPIC with large
+code model is unsupported. This fixes the "sorry, unimplemented"
+errors when building with compilers defaulting to -fPIC.
+
+Upstream-Status: Backport
+
+Signed-off-by: Simon Horman <horms@verge.net.au>
+Signed-off-by: David Michael <david.michael@coreos.com>
+Signed-off-by: Mingli Yu <Mingli.Yu@windriver.com>
+---
+ purgatory/arch/arm64/Makefile | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/purgatory/arch/arm64/Makefile b/purgatory/arch/arm64/Makefile
+index 636abea..80068ca 100644
+--- a/purgatory/arch/arm64/Makefile
++++ b/purgatory/arch/arm64/Makefile
+@@ -1,6 +1,7 @@
+
+ arm64_PURGATORY_EXTRA_CFLAGS = \
+ -mcmodel=large \
++ -fno-PIC \
+ -fno-stack-protector \
+ -fno-asynchronous-unwind-tables \
+ -Wundef \
+--
+2.7.4
+
diff --git a/meta/recipes-kernel/kexec/kexec-tools_2.0.16.bb b/meta/recipes-kernel/kexec/kexec-tools_2.0.16.bb
index ebb4832684..bd87b371c2 100644
--- a/meta/recipes-kernel/kexec/kexec-tools_2.0.16.bb
+++ b/meta/recipes-kernel/kexec/kexec-tools_2.0.16.bb
@@ -20,6 +20,7 @@ SRC_URI = "${KERNELORG_MIRROR}/linux/utils/kernel/kexec/kexec-tools-${PV}.tar.gz
file://0010-kexec-ARM-Fix-add_buffer_phys_virt-align-issue.patch \
file://kexec-x32.patch \
file://0001-Disable-PIE-during-link.patch \
+ file://0001-arm64-Set-fno-PIC-along-with-mcmodel-large.patch \
"
SRC_URI[md5sum] = "5198968de79b5ded96f97f3c2ea9637b"