summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta-hob/conf/layer.conf6
-rw-r--r--meta-skeleton/conf/layer.conf5
2 files changed, 11 insertions, 0 deletions
diff --git a/meta-hob/conf/layer.conf b/meta-hob/conf/layer.conf
index 5f5eb8218c..ea977e2cc3 100644
--- a/meta-hob/conf/layer.conf
+++ b/meta-hob/conf/layer.conf
@@ -7,3 +7,9 @@ BBFILES := "${BBFILES} ${LAYERDIR}/recipes-*/*/*.bb"
BBFILE_COLLECTIONS += "hob"
BBFILE_PATTERN_hob := "^${LAYERDIR}/"
BBFILE_PRIORITY_hob = "1"
+
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_hob = "1"
+
+LAYERDEPENDS_hob = "core"
diff --git a/meta-skeleton/conf/layer.conf b/meta-skeleton/conf/layer.conf
index edb31dd89a..4cf476711d 100644
--- a/meta-skeleton/conf/layer.conf
+++ b/meta-skeleton/conf/layer.conf
@@ -8,3 +8,8 @@ BBFILE_COLLECTIONS += "skeleton"
BBFILE_PATTERN_skeleton := "^${LAYERDIR}/"
BBFILE_PRIORITY_skeleton = "1"
+# This should only be incremented on significant changes that will
+# cause compatibility issues with other layers
+LAYERVERSION_skeleton = "1"
+
+LAYERDEPENDS_skeleton = "core"