summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--[-rwxr-xr-x]meta/recipes-sato/matchbox-keyboard/files/80matchboxkeyboard.sh (renamed from meta/recipes-sato/matchbox-keyboard/files/80matchboxkeyboard.shbg)4
-rw-r--r--meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb4
2 files changed, 3 insertions, 5 deletions
diff --git a/meta/recipes-sato/matchbox-keyboard/files/80matchboxkeyboard.shbg b/meta/recipes-sato/matchbox-keyboard/files/80matchboxkeyboard.sh
index 43c5d3ed6a..6cf188b2d0 100755..100644
--- a/meta/recipes-sato/matchbox-keyboard/files/80matchboxkeyboard.shbg
+++ b/meta/recipes-sato/matchbox-keyboard/files/80matchboxkeyboard.sh
@@ -13,11 +13,9 @@ elif [ "$DISPLAY_CAN_ROTATE" = "1" ]; then
CMD="matchbox-keyboard -d -o portrait"
fi
fi
-
if [ "$CMD" ]; then
# Delay to make sure the window manager is active
# by waiting for the desktop to say its finished loading
- dbus-wait org.matchbox_project.desktop Loaded
- exec $CMD
+ dbus-wait org.matchbox_project.desktop Loaded && $CMD &
fi
diff --git a/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
index 00a75af60e..7a99a9c46a 100644
--- a/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
+++ b/meta/recipes-sato/matchbox-keyboard/matchbox-keyboard_git.bb
@@ -16,7 +16,7 @@ PR = "r4"
SRC_URI = "git://git.yoctoproject.org/${BPN};branch=matchbox-keyboard-0-1 \
file://single-instance.patch \
- file://80matchboxkeyboard.shbg"
+ file://80matchboxkeyboard.sh"
S = "${WORKDIR}/git"
@@ -41,7 +41,7 @@ FILES_${PN}-applet = "${libdir}/matchbox-panel/*.so"
do_install_append () {
install -d ${D}/${sysconfdir}/X11/Xsession.d/
- install -m 755 ${WORKDIR}/80matchboxkeyboard.shbg ${D}/${sysconfdir}/X11/Xsession.d/
+ install -m 755 ${WORKDIR}/80matchboxkeyboard.sh ${D}/${sysconfdir}/X11/Xsession.d/
rm -f ${D}${libdir}/gtk-2.0/*/immodules/*.la
rm -f ${D}${libdir}/matchbox-panel/*.la