aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-core/meta/wic-tools.bb4
1 files changed, 4 insertions, 0 deletions
diff --git a/meta/recipes-core/meta/wic-tools.bb b/meta/recipes-core/meta/wic-tools.bb
index 1d9ea9c0e9..bd4319a803 100644
--- a/meta/recipes-core/meta/wic-tools.bb
+++ b/meta/recipes-core/meta/wic-tools.bb
@@ -9,6 +9,10 @@ DEPENDS_append_x86-64 = " syslinux grub-efi systemd-boot"
INHIBIT_DEFAULT_DEPS = "1"
inherit nopackages
+# The sysroot of wic-tools is needed for wic, but if rm_work is enabled, it will
+# be removed before wic has a chance to use it, hence the exclusion below.
+RM_WORK_EXCLUDE += "${PN}"
+
python do_build_sysroot () {
bb.build.exec_func("extend_recipe_sysroot", d)