aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/ruby/ruby/CVE-2017-9227.patch24
-rw-r--r--meta/recipes-devtools/ruby/ruby_2.2.5.bb1
2 files changed, 25 insertions, 0 deletions
diff --git a/meta/recipes-devtools/ruby/ruby/CVE-2017-9227.patch b/meta/recipes-devtools/ruby/ruby/CVE-2017-9227.patch
new file mode 100644
index 0000000000..f6eaefb7fd
--- /dev/null
+++ b/meta/recipes-devtools/ruby/ruby/CVE-2017-9227.patch
@@ -0,0 +1,24 @@
+commit 9690d3ab1f9bcd2db8cbe1fe3ee4a5da606b8814
+Author: K.Kosako <kosako@sofnec.co.jp>
+Date: Tue May 23 16:15:35 2017 +0900
+
+ fix #58 : access to invalid address by reg->dmin value
+
+Upstream-Status: backport
+
+CVE: CVE-2017-9227
+Signed-off-by: Thiruvadi Rajaraman <trajaraman@mvista.com>
+
+Index: ruby-2.2.5/regexec.c
+===================================================================
+--- ruby-2.2.5.orig/regexec.c 2014-09-15 21:48:41.000000000 +0530
++++ ruby-2.2.5/regexec.c 2017-08-30 12:18:04.054828426 +0530
+@@ -3678,6 +3678,8 @@
+ }
+ else {
+ UChar *q = p + reg->dmin;
++
++ if (q >= end) return 0; /* fail */
+ while (p < q) p += enclen(reg->enc, p, end);
+ }
+ }
diff --git a/meta/recipes-devtools/ruby/ruby_2.2.5.bb b/meta/recipes-devtools/ruby/ruby_2.2.5.bb
index 35882d18e6..e29eb9c9b4 100644
--- a/meta/recipes-devtools/ruby/ruby_2.2.5.bb
+++ b/meta/recipes-devtools/ruby/ruby_2.2.5.bb
@@ -5,6 +5,7 @@ SRC_URI[sha256sum] = "30c4b31697a4ca4ea0c8db8ad30cf45e6690a0f09687e5d483c933c03c
SRC_URI += "file://prevent-gc.patch \
file://CVE-2016-7798.patch \
+ file://CVE-2017-9227.patch \
"
# it's unknown to configure script, but then passed to extconf.rb