aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-connectivity/connman/connman/ethernet_default.patch22
-rw-r--r--meta/recipes-connectivity/connman/connman_0.78.bb3
2 files changed, 24 insertions, 1 deletions
diff --git a/meta/recipes-connectivity/connman/connman/ethernet_default.patch b/meta/recipes-connectivity/connman/connman/ethernet_default.patch
new file mode 100644
index 0000000000..d0c05d72ff
--- /dev/null
+++ b/meta/recipes-connectivity/connman/connman/ethernet_default.patch
@@ -0,0 +1,22 @@
+Default to enabling the ethernet interface. If we don't do this, connman
+will shut down all the networking when it starts without any configuration
+which is usualy not what the users expects. This is particularly
+problematic with our qemu images and runtime testing using qemu.
+
+Upstream Status: Inappropriate [Configuration]
+
+RP 2011/12/12
+
+Index: git/src/storage.c
+===================================================================
+--- git.orig/src/storage.c 2011-12-12 16:14:10.892316565 +0000
++++ git/src/storage.c 2011-12-12 16:14:13.788316431 +0000
+@@ -367,7 +367,7 @@
+ "Enable", FALSE);
+
+ g_key_file_set_boolean(keyfile, "Wired",
+- "Enable", FALSE);
++ "Enable", TRUE);
+
+ g_key_file_set_boolean(keyfile, "3G",
+ "Enable", FALSE);
diff --git a/meta/recipes-connectivity/connman/connman_0.78.bb b/meta/recipes-connectivity/connman/connman_0.78.bb
index 378bd9d647..f36f6707c7 100644
--- a/meta/recipes-connectivity/connman/connman_0.78.bb
+++ b/meta/recipes-connectivity/connman/connman_0.78.bb
@@ -1,10 +1,11 @@
require connman.inc
-PR = "r3"
+PR = "r4"
# 0.78 tag
SRCREV = "02f5d5fe2d7c71514a6387ba2b772b42d8e8d297"
SRC_URI = "git://git.kernel.org/pub/scm/network/connman/connman.git \
file://add_xuser_dbus_permission.patch \
+ file://ethernet_default.patch \
file://connman"
S = "${WORKDIR}/git"