aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-extended/which/which_2.18.bb18
1 files changed, 5 insertions, 13 deletions
diff --git a/meta/recipes-extended/which/which_2.18.bb b/meta/recipes-extended/which/which_2.18.bb
index b177949788..7eeb320a75 100644
--- a/meta/recipes-extended/which/which_2.18.bb
+++ b/meta/recipes-extended/which/which_2.18.bb
@@ -8,14 +8,14 @@ BUGTRACKER = "n/a"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
-PR = "r0"
+PR = "r1"
SRC_URI = "http://www.xs4all.nl/~carlo17/which/which-${PV}.tar.gz \
file://fix_name_conflict_group_member.patch"
DEPENDS = "cwautomacros-native"
-inherit autotools
+inherit autotools update-alternatives
do_configure_prepend() {
OLD="@ACLOCAL_CWFLAGS@"
@@ -26,15 +26,7 @@ do_install_append() {
mv ${D}/${bindir}/which ${D}/${bindir}/which.${PN}
}
-pkg_postinst_${PN}() {
- if [ "${PN}" = "${BPN}" ] ; then
- update-alternatives --install ${bindir}/which which which.${PN} 100
- fi
-}
-
-pkg_prerm_${PN}() {
- if [ "${PN}" = "${BPN}" ] ; then
- update-alternatives --remove which which.${PN}
- fi
-}
+ALTERNATIVE_NAME = "which"
+ALTERNATIVE_PATH = "which.${PN}"
+ALTERNATIVE_PRIORITY = "100"