aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-devtools/git/git.inc12
-rw-r--r--meta/recipes-extended/findutils/findutils.inc2
-rw-r--r--meta/recipes-extended/tar/tar.inc4
3 files changed, 14 insertions, 4 deletions
diff --git a/meta/recipes-devtools/git/git.inc b/meta/recipes-devtools/git/git.inc
index 9829eec6ec..183a93cde6 100644
--- a/meta/recipes-devtools/git/git.inc
+++ b/meta/recipes-devtools/git/git.inc
@@ -31,8 +31,8 @@ do_install () {
# ${libdir} is not applicable here, perl-native files are always
# installed to /usr/lib on both 32/64 bits targets.
- rm -rf ${D}/usr/lib/perl-native
- rmdir ${D}/usr/lib || true
+ rm -rf ${D}${exec_prefix}/lib/perl-native
+ rmdir ${D}${exec_prefix}/lib || true
}
do_install_append_class-native() {
@@ -41,6 +41,12 @@ do_install_append_class-native() {
GIT_TEMPLATE_DIR=${STAGING_DATADIR_NATIVE}/git-core/templates
}
+do_install_append_class-nativesdk() {
+ create_wrapper ${D}/${bindir}/git \
+ GIT_EXEC_PATH=${libexecdir}/git-core \
+ GIT_TEMPLATE_DIR=${STAGING_DATADIR_NATIVE}/git-core/templates
+}
+
FILES_${PN} += "${datadir}/git-core ${libxecdir}/git-core/"
FILES_${PN}-dbg += "${libexecdir}/git-core/.debug"
@@ -78,4 +84,4 @@ PACKAGES =+ "gitweb"
FILES_gitweb = "${datadir}/gitweb/"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-extended/findutils/findutils.inc b/meta/recipes-extended/findutils/findutils.inc
index 9306786832..81e6785f63 100644
--- a/meta/recipes-extended/findutils/findutils.inc
+++ b/meta/recipes-extended/findutils/findutils.inc
@@ -21,4 +21,4 @@ ALTERNATIVE_PRIORITY = "100"
# see diffutils.mk in buildroot)
EXTRA_OECONF_libc-uclibc = "--without-included-regex"
-BBCLASSEXTEND = "native"
+BBCLASSEXTEND = "native nativesdk"
diff --git a/meta/recipes-extended/tar/tar.inc b/meta/recipes-extended/tar/tar.inc
index f49c7de4a5..abeb8c19ff 100644
--- a/meta/recipes-extended/tar/tar.inc
+++ b/meta/recipes-extended/tar/tar.inc
@@ -33,6 +33,10 @@ ALTERNATIVE_PRIORITY = "100"
ALTERNATIVE_${PN} = "tar"
ALTERNATIVE_${PN}-rmt = "rmt"
+ALTERNATIVE_${PN}_class-nativesdk = ""
+ALTERNATIVE_${PN}-rmt_class-nativesdk = ""
ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
ALTERNATIVE_LINK_NAME[rmt] = "${base_sbindir}/rmt"
+
+BBCLASSEXTEND = "nativesdk"