aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-graphics/xorg-app/xmodmap/gnu-source.patch60
-rw-r--r--meta/recipes-graphics/xorg-app/xmodmap_1.0.7.bb2
2 files changed, 62 insertions, 0 deletions
diff --git a/meta/recipes-graphics/xorg-app/xmodmap/gnu-source.patch b/meta/recipes-graphics/xorg-app/xmodmap/gnu-source.patch
new file mode 100644
index 0000000000..84bd973764
--- /dev/null
+++ b/meta/recipes-graphics/xorg-app/xmodmap/gnu-source.patch
@@ -0,0 +1,60 @@
+Upstream-Status: Backport
+Signed-off-by: Ross Burton <ross.burton@intel.com>
+
+From 42f99a7a7b836f6f9704a7b1747eb722c93446ec Mon Sep 17 00:00:00 2001
+From: Alan Coopersmith <alan.coopersmith@oracle.com>
+Date: Mon, 23 Apr 2012 14:28:39 +0000
+Subject: include config.h before stdio.h & other system headers
+
+Ensures definitions like _GNU_SOURCE are visible when needed.
+
+Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
+Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net>
+---
+diff --git a/exec.c b/exec.c
+index dbcb669..419b10e 100644
+--- a/exec.c
++++ b/exec.c
+@@ -54,6 +54,10 @@ from The Open Group.
+ * original xmodmap, written by David Rosenthal, of Sun Microsystems.
+ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include <X11/Xos.h>
+ #include <X11/Xlib.h>
+ #include <stdio.h>
+diff --git a/pf.c b/pf.c
+index 0eb0f55..3f0c3f4 100644
+--- a/pf.c
++++ b/pf.c
+@@ -26,6 +26,10 @@ from The Open Group.
+
+ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include <X11/Xos.h>
+ #include <X11/Xlib.h>
+ #include <stdio.h>
+diff --git a/xmodmap.c b/xmodmap.c
+index 58a8e70..0f89629 100644
+--- a/xmodmap.c
++++ b/xmodmap.c
+@@ -26,6 +26,10 @@ from The Open Group.
+
+ */
+
++#ifdef HAVE_CONFIG_H
++# include "config.h"
++#endif
++
+ #include <X11/Xos.h>
+ #include <X11/Xlib.h>
+ #include <stdio.h>
+--
+cgit v0.9.0.2-2-gbebe \ No newline at end of file
diff --git a/meta/recipes-graphics/xorg-app/xmodmap_1.0.7.bb b/meta/recipes-graphics/xorg-app/xmodmap_1.0.7.bb
index fab1b167e6..573eecbe58 100644
--- a/meta/recipes-graphics/xorg-app/xmodmap_1.0.7.bb
+++ b/meta/recipes-graphics/xorg-app/xmodmap_1.0.7.bb
@@ -14,5 +14,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=eef098b27f09d0ac39268df0cc2c00b5"
PR = "${INC_PR}.0"
PE = "1"
+SRC_URI += "file://gnu-source.patch"
+
SRC_URI[md5sum] = "d9b65f6881afe0d6d9863b30e1081bde"
SRC_URI[sha256sum] = "ef22ede9c4a3c720da539292c6911515a8408e618e0dec6aa2196ee2153de4b5"