aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-connectivity/openssl/openssl-1.0.1e/openssl-fix-CVE-2014-3567.patch32
-rw-r--r--meta/recipes-connectivity/openssl/openssl_1.0.1e.bb1
2 files changed, 33 insertions, 0 deletions
diff --git a/meta/recipes-connectivity/openssl/openssl-1.0.1e/openssl-fix-CVE-2014-3567.patch b/meta/recipes-connectivity/openssl/openssl-1.0.1e/openssl-fix-CVE-2014-3567.patch
new file mode 100644
index 0000000000..61f821b54d
--- /dev/null
+++ b/meta/recipes-connectivity/openssl/openssl-1.0.1e/openssl-fix-CVE-2014-3567.patch
@@ -0,0 +1,32 @@
+From 748270554824d2a51d1718f52a8d3ab34116bbfb Mon Sep 17 00:00:00 2001
+From: "Dr. Stephen Henson" <steve@openssl.org>
+Date: Wed, 15 Oct 2014 01:53:55 +0100
+Subject: [PATCH] Fix for session tickets memory leak.
+
+CVE-2014-3567
+
+Reviewed-by: Rich Salz <rsalz@openssl.org>
+Reviewed-by: Matt Caswell <matt@openssl.org>
+Signed-off-by: Catalin Popeanga <catalin.popeanga@enea.com>
+---
+ ssl/t1_lib.c | 3 +++
+ 1 file changed, 3 insertions(+)
+
+diff --git a/ssl/t1_lib.c b/ssl/t1_lib.c
+index 879467c..77fe232 100644
+--- a/ssl/t1_lib.c
++++ b/ssl/t1_lib.c
+@@ -3380,7 +3380,10 @@ static int tls_decrypt_ticket(SSL *s, const unsigned char *etick, int eticklen,
+ HMAC_Final(&hctx, tick_hmac, NULL);
+ HMAC_CTX_cleanup(&hctx);
+ if (CRYPTO_memcmp(tick_hmac, etick + eticklen, mlen))
++ {
++ EVP_CIPHER_CTX_cleanup(&ctx);
+ return 2;
++ }
+ /* Attempt to decrypt session data */
+ /* Move p after IV to start of encrypted ticket, update length */
+ p = etick + 16 + EVP_CIPHER_CTX_iv_length(&ctx);
+--
+1.7.9.5
+
diff --git a/meta/recipes-connectivity/openssl/openssl_1.0.1e.bb b/meta/recipes-connectivity/openssl/openssl_1.0.1e.bb
index 82828226fa..6af4ee9503 100644
--- a/meta/recipes-connectivity/openssl/openssl_1.0.1e.bb
+++ b/meta/recipes-connectivity/openssl/openssl_1.0.1e.bb
@@ -46,6 +46,7 @@ SRC_URI += "file://configure-targets.patch \
file://openssl-CVE-2010-5298.patch \
file://openssl-fix-CVE-2014-3566.patch \
file://openssl-fix-CVE-2014-3513.patch \
+ file://openssl-fix-CVE-2014-3567.patch \
"
SRC_URI[md5sum] = "66bf6f10f060d561929de96f9dfe5b8c"