aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--meta/recipes-bsp/u-boot/u-boot.inc16
-rw-r--r--meta/recipes-bsp/u-boot/u-boot_2011.03.bb2
-rw-r--r--meta/recipes-bsp/u-boot/u-boot_2011.06.bb2
3 files changed, 13 insertions, 7 deletions
diff --git a/meta/recipes-bsp/u-boot/u-boot.inc b/meta/recipes-bsp/u-boot/u-boot.inc
index e627e978c8..3086814ea3 100644
--- a/meta/recipes-bsp/u-boot/u-boot.inc
+++ b/meta/recipes-bsp/u-boot/u-boot.inc
@@ -48,6 +48,11 @@ do_install () {
install ${S}/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY}
+ if [ -e ${WORKDIR}/fw_env.config ] ; then
+ install -d ${D}${sysconfdir}
+ install -m 644 ${WORKDIR}/fw_env.config ${D}${sysconfdir}/fw_env.config
+ fi
+
if [ "x${SPL_BINARY}" != "x" ]
then
install ${S}/${SPL_BINARY} ${D}/boot/${SPL_IMAGE}
@@ -55,15 +60,16 @@ do_install () {
fi
}
-FILES_${PN} = "/boot"
+FILES_${PN} = "/boot ${sysconfdir}"
do_deploy () {
install -d ${DEPLOYDIR}
- install ${S}/${UBOOT_BINARY} ${DEPLOYDIR}/${UBOOT_IMAGE}
+ install ${S}/${UBOOT_BINARY} ${DEPLOYDIR}/${UBOOT_IMAGE}
- cd ${DEPLOYDIR}
- rm -f ${UBOOT_SYMLINK}
- ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK}
+ cd ${DEPLOYDIR}
+ rm -f ${UBOOT_BINARY} ${UBOOT_SYMLINK}
+ ln -sf ${UBOOT_IMAGE} ${UBOOT_SYMLINK}
+ ln -sf ${UBOOT_IMAGE} ${UBOOT_BINARY}
if [ "x${SPL_BINARY}" != "x" ]
then
diff --git a/meta/recipes-bsp/u-boot/u-boot_2011.03.bb b/meta/recipes-bsp/u-boot/u-boot_2011.03.bb
index 5d79e1a0ab..fa328d1a43 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2011.03.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2011.03.bb
@@ -17,7 +17,7 @@ FILESDIR = "${@os.path.dirname(d.getVar('FILE',1))}/u-boot-git/${MACHINE}"
SRCREV = "19b54a701811220221fc4d5089a2bb18892018ca"
PV = "v2011.03+git${SRCPV}"
-PR = "r7"
+PR = "r8"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"
diff --git a/meta/recipes-bsp/u-boot/u-boot_2011.06.bb b/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
index 43f2c0661b..93b79238b0 100644
--- a/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
+++ b/meta/recipes-bsp/u-boot/u-boot_2011.06.bb
@@ -17,7 +17,7 @@ FILESDIR = "${@os.path.dirname(d.getVar('FILE',1))}/u-boot-git/${MACHINE}"
SRCREV = "b1af6f532e0d348b153d5c148369229d24af361a"
PV = "v2011.06+git${SRCPV}"
-PR = "r2"
+PR = "r3"
SRC_URI = "git://git.denx.de/u-boot.git;branch=master;protocol=git"