summaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-04-27 10:53:20 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-04-27 15:05:40 +0100
commit3332d68ef7b2a300ce8dcf5021497d98e5b17baa (patch)
treeceebfda7a81e1aa78fdde418fd038b35d4dbbe4a /scripts
parentd2d352f7b747a97a54df9d20eb1455d166aa1ee3 (diff)
downloadopenembedded-core-3332d68ef7b2a300ce8dcf5021497d98e5b17baa.tar.gz
devtool: update-recipe: handle unversioned bbappends
Use the proper bbappend file name, don't just assume it will have a version suffix (because it won't if the original recipe doesn't). Fixes [YOCTO #7651]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts')
-rw-r--r--scripts/lib/devtool/standard.py14
1 files changed, 7 insertions, 7 deletions
diff --git a/scripts/lib/devtool/standard.py b/scripts/lib/devtool/standard.py
index d561e40115..a64211211b 100644
--- a/scripts/lib/devtool/standard.py
+++ b/scripts/lib/devtool/standard.py
@@ -434,12 +434,6 @@ def update_recipe(args, config, basepath, workspace):
logger.error("no recipe named %s in your workspace" % args.recipename)
return -1
- # Get initial revision from bbappend
- appends = glob.glob(os.path.join(config.workspace_path, 'appends', '%s_*.bbappend' % args.recipename))
- if not appends:
- logger.error('unable to find workspace bbappend for recipe %s' % args.recipename)
- return -1
-
tinfoil = setup_tinfoil()
import bb
from oe.patch import GitApplyTree
@@ -450,6 +444,12 @@ def update_recipe(args, config, basepath, workspace):
return -1
recipefile = rd.getVar('FILE', True)
+ # Get initial revision from bbappend
+ append = os.path.join(config.workspace_path, 'appends', '%s.bbappend' % os.path.splitext(os.path.basename(recipefile))[0])
+ if not os.path.exists(append):
+ logger.error('unable to find workspace bbappend for recipe %s' % args.recipename)
+ return -1
+
orig_src_uri = rd.getVar('SRC_URI', False) or ''
if args.mode == 'auto':
if 'git://' in orig_src_uri:
@@ -520,7 +520,7 @@ def update_recipe(args, config, basepath, workspace):
initial_rev = args.initial_rev
else:
initial_rev = None
- with open(appends[0], 'r') as f:
+ with open(append, 'r') as f:
for line in f:
if line.startswith('# initial_rev:'):
initial_rev = line.split(':')[-1].strip()