aboutsummaryrefslogtreecommitdiffstats
path: root/scripts
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2015-04-27 10:53:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-06-28 09:41:59 +0100
commit0b9e8817fc8ba375a1045a66d04b3fd2b498427b (patch)
treebf669bd64087769ec0e1275d97763967dbadab25 /scripts
parent36df1bb9bb3c92d096118b74fdf11a243be3f7d5 (diff)
downloadopenembedded-core-0b9e8817fc8ba375a1045a66d04b3fd2b498427b.tar.gz
devtool: add: use correct bbappend file name with -V option
We weren't adding the version into the bbappend file name when -V was specified which meant that building or resetting failed. Also adjust one of the tests so that we're testing devtool add both with and without this option. Fixes [YOCTO #7647]. (From OE-Core master rev: bdbeff0cd342e31053d7203d78fc5dda611052b1) Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'scripts')
-rw-r--r--scripts/lib/devtool/standard.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/scripts/lib/devtool/standard.py b/scripts/lib/devtool/standard.py
index faf5c92176..893226578a 100644
--- a/scripts/lib/devtool/standard.py
+++ b/scripts/lib/devtool/standard.py
@@ -73,7 +73,7 @@ def add(args, config, basepath, workspace):
(stdout, _) = bb.process.run('git rev-parse HEAD', cwd=srctree)
initial_rev = stdout.rstrip()
- appendfile = os.path.join(appendpath, '%s.bbappend' % args.recipename)
+ appendfile = os.path.join(appendpath, '%s.bbappend' % bp)
with open(appendfile, 'w') as f:
f.write('inherit externalsrc\n')
f.write('EXTERNALSRC = "%s"\n' % srctree)