summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorPatrick Ohly <patrick.ohly@intel.com>2015-08-14 18:01:41 +0200
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-08-19 17:57:47 +0100
commite6fee3ddb5600fc564243a96d6232b4ae097df32 (patch)
treec15db8383e7a6b6536a5fa6d77a7552802135260 /meta
parent3b57ca0ad44e66a1ecd39c410f63d99705c56b1e (diff)
downloadopenembedded-core-e6fee3ddb5600fc564243a96d6232b4ae097df32.tar.gz
tar-replacement-native: relocate via NATIVE_PACKAGE_PATH_SUFFIX
Building tar-replacement-native as replacement of the host's tar in the standard path was meant to be done manually by a user in preparation for the regular bitbake run. Such a usage has been superseeded by installing the pre-compiled buildutils and might have been broken on hosts which need it by the sanity check for tar >= 1.26. Therefore tar-replacement-native_1.28.bb can be removed in favor of adapting the normal tar recipe such that it installs an opt-in binary under a different path. The special do_install logic is explicitly limited to class-target, instead of making it the default and disabling it (which would be the case for class-native and class-nativesdk). Signed-off-by: Patrick Ohly <patrick.ohly@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-extended/tar/tar-replacement-native_1.28.bb6
-rw-r--r--meta/recipes-extended/tar/tar.inc11
2 files changed, 5 insertions, 12 deletions
diff --git a/meta/recipes-extended/tar/tar-replacement-native_1.28.bb b/meta/recipes-extended/tar/tar-replacement-native_1.28.bb
deleted file mode 100644
index 071ede765b..0000000000
--- a/meta/recipes-extended/tar/tar-replacement-native_1.28.bb
+++ /dev/null
@@ -1,6 +0,0 @@
-require tar_${PV}.bb
-
-inherit native
-
-BPN = "tar"
-EXTRAINSTALL = ""
diff --git a/meta/recipes-extended/tar/tar.inc b/meta/recipes-extended/tar/tar.inc
index 74169274f4..b339c43385 100644
--- a/meta/recipes-extended/tar/tar.inc
+++ b/meta/recipes-extended/tar/tar.inc
@@ -16,16 +16,12 @@ EXTRA_OECONF += "DEFAULT_RMT_DIR=${base_sbindir}"
# directory.
acpaths = "-I ./m4"
-EXTRAINSTALL = "do_install_extra"
-EXTRAINSTALL_class-nativesdk = ""
-
do_install () {
autotools_do_install
ln -s tar ${D}${bindir}/gtar
- ${EXTRAINSTALL}
}
-do_install_extra () {
+do_install_append_class-target() {
install -d ${D}${base_bindir}
mv ${D}${bindir}/tar ${D}${base_bindir}/tar
mv ${D}${bindir}/gtar ${D}${base_bindir}/gtar
@@ -48,4 +44,7 @@ ALTERNATIVE_${PN}-rmt_class-nativesdk = ""
ALTERNATIVE_LINK_NAME[tar] = "${base_bindir}/tar"
ALTERNATIVE_LINK_NAME[rmt] = "${base_sbindir}/rmt"
-BBCLASSEXTEND = "nativesdk"
+PROVIDES_append_class-native = " tar-replacement-native"
+NATIVE_PACKAGE_PATH_SUFFIX = "/${PN}"
+
+BBCLASSEXTEND = "native nativesdk"