summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-01-03 13:41:32 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-04 12:08:12 +0000
commitdc154d698b3b455a35b65935f7f04a3b4f72f8b6 (patch)
tree42a051aeacebdb24e8fe31e6938fe3f552ded5b8 /meta
parentb406998019b577eac7f758298cc2695372e03d15 (diff)
downloadopenembedded-core-dc154d698b3b455a35b65935f7f04a3b4f72f8b6.tar.gz
qt4: fix incorrect architecture for qt4 tools
Don't install the native staging versions of the qt4 tools in the bin directory; we have been doing this for a very long time but it is no longer necessary since we specify them via the QMAKE_UIC, QMAKE_MOC etc. variables. Doing so was sometimes resulting in those executables being the ones that end up being packaged (probably only sometimes due to different date/time values on the staging files and the interaction with make). Fixes [YOCTO #1856]. Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-qt/qt4/qt-4.7.4.inc4
-rw-r--r--meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb2
-rw-r--r--meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb2
3 files changed, 2 insertions, 6 deletions
diff --git a/meta/recipes-qt/qt4/qt-4.7.4.inc b/meta/recipes-qt/qt4/qt-4.7.4.inc
index 8fda9ce85a..9ddb055777 100644
--- a/meta/recipes-qt/qt4/qt-4.7.4.inc
+++ b/meta/recipes-qt/qt4/qt-4.7.4.inc
@@ -50,10 +50,6 @@ do_compile() {
fi
unset CFLAGS CXXFLAGS
- install -m 0755 ${STAGING_BINDIR_NATIVE}/rcc4 ${S}/bin/rcc
- install -m 0755 ${STAGING_BINDIR_NATIVE}/moc4 ${S}/bin/moc
- install -m 0755 ${STAGING_BINDIR_NATIVE}/uic4 ${S}/bin/uic
- install -m 0755 ${STAGING_BINDIR_NATIVE}/lrelease4 ${S}/bin/lrelease
oe_runmake ${EXTRA_ENV}
}
diff --git a/meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb b/meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb
index 1d7104c5bc..9b66d0327c 100644
--- a/meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb
+++ b/meta/recipes-qt/qt4/qt4-embedded_4.7.4.bb
@@ -1,7 +1,7 @@
require qt-${PV}.inc
require qt4-embedded.inc
-PR = "${INC_PR}.5"
+PR = "${INC_PR}.6"
QT_CONFIG_FLAGS_append_armv6 = " -no-neon "
diff --git a/meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb b/meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb
index 3263c93709..6dedf0048a 100644
--- a/meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb
+++ b/meta/recipes-qt/qt4/qt4-x11-free_4.7.4.bb
@@ -1,7 +1,7 @@
require qt4-x11-free.inc
require qt-${PV}.inc
-PR = "${INC_PR}.5"
+PR = "${INC_PR}.6"
QT_CONFIG_FLAGS_append_armv6 = " -no-neon "