summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorMark Hatle <mark.hatle@windriver.com>2012-09-29 19:19:17 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-10-02 11:15:05 +0100
commitd109c6bd163469d6281d20174e4b79cb63483cd4 (patch)
tree65729b245187f0b8acaee26e31cbf2cf8a15ba33 /meta
parentd05c5da6b972db97d3eb66b659f5641368c9ebe4 (diff)
downloadopenembedded-core-d109c6bd163469d6281d20174e4b79cb63483cd4.tar.gz
rpm: Add rpm patch to fix git_strerror issues
Remove the optimzation append from recipe and add the patch that is in the rpm cvs repo, http://www.mail-archive.com/rpm-cvs@rpm5.org/msg08907.html. The -O2 optimzation append is removed since it can limit debugging options that are provided when -O0 is used. This was tested by setting: SELECTED_OPTIMIZATION = "-O0" Signed-off-by: Morgan Little <morgan.little@windriver.com> Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-stub-out-git_strerror.patch60
-rw-r--r--meta/recipes-devtools/rpm/rpm_5.4.9.bb3
2 files changed, 62 insertions, 1 deletions
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-stub-out-git_strerror.patch b/meta/recipes-devtools/rpm/rpm/rpm-stub-out-git_strerror.patch
new file mode 100644
index 0000000000..2cfc163fe1
--- /dev/null
+++ b/meta/recipes-devtools/rpm/rpm/rpm-stub-out-git_strerror.patch
@@ -0,0 +1,60 @@
+git: fix: stud-out git_strerror when --without-git
+
+Patch taken from the cvs repo,http://www.mail-archive.com/rpm-cvs@rpm5.org/msg08907.html.
+
+Upstream-status: Backport
+
+Signed-off-by: Morgan Little <morgan.little@windriver.com>
+
+Server: rpm5.org Name: Jeff Johnson
+Root: /v/rpm/cvs Email: j...@rpm5.org
+Module: rpm Date: 07-Jun-2012 16:17:02
+Branch: rpm-5_4 Handle: 2012060714165803
+
+Modified files: (Branch: rpm-5_4)
+ rpm CHANGES
+ rpm/rpmio rpmgit.c tgit.c
+
+Log:
+ - git: fix: stub-out git_strerror when --without-git.
+
+Summary:
+ Revision Changes Path
+ 2.1.2.11 +3 -1 rpm/rpmio/rpmgit.c
+ 1.1.2.7 +0 -1 rpm/rpmio/tgit.c
+____________________________________________________________________________
+Index: rpm/rpmio/rpmgit.c
+============================================================================
+--- rpm/rpmio/rpmgit.c
++++ rpm/rpmio/rpmgit.c
+@@ -145,6 +145,9 @@
+ #endif /* defined(WITH_LIBGT2) */
+
+ /*==============================================================*/
++#if !defined(WITH_LIBGIT2)
++#define git_strerror(_rc) ""
++#endif
+
+ static int Xchkgit(/*@unused@*/ rpmgit git, const char * msg,
+ int error, int printit,
+@@ -157,7 +157,6 @@
+ int rc = error;
+
+ if (printit && rc) {
+- /* XXX git_strerror? */
+ rpmlog(RPMLOG_ERR, "%s:%s:%u: %s(%d): %s\n",
+ func, fn, ln, msg, rc, git_strerror(rc));
+ }
+Index: rpm/rpmio/tgit.c
+============================================================================
+--- rpm/rpmio/tgit.c
++++ rpm/rpmio/tgit.c
+@@ -34,7 +34,6 @@
+ int rc = error;
+
+ if (printit && rc) {
+- /* XXX git_strerror? */
+ rpmlog(RPMLOG_ERR, "%s:%s:%u: %s(%d): %s\n",
+ func, fn, ln, msg, rc, git_strerror(rc));
+ }
+
diff --git a/meta/recipes-devtools/rpm/rpm_5.4.9.bb b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
index 41943652b0..671268bb85 100644
--- a/meta/recipes-devtools/rpm/rpm_5.4.9.bb
+++ b/meta/recipes-devtools/rpm/rpm_5.4.9.bb
@@ -43,7 +43,7 @@ LICENSE = "LGPLv2.1"
LIC_FILES_CHKSUM = "file://COPYING.LIB;md5=2d5025d4aa3495befef8f17206a5b0a1"
DEPENDS = "libpcre attr acl popt ossp-uuid file bison-native"
-PR = "r50"
+PR = "r51"
# rpm2cpio is a shell script, which is part of the rpm src.rpm. It is needed
# in order to extract the distribution SRPM into a format we can extract...
@@ -78,6 +78,7 @@ SRC_URI = "http://www.rpm5.org/files/rpm/rpm-5.4/rpm-5.4.9-0.20120508.src.rpm;ex
file://dbconvert.patch \
file://rpm-uuid-include.patch \
file://makefile-am-exec-hook.patch \
+ file://rpm-stub-out-git_strerror.patch \
"
SRC_URI[md5sum] = "60d56ace884340c1b3fcac6a1d58e768"