summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorPeter Kjellerstedt <pkj@axis.com>2017-08-15 16:41:52 -0500
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-16 00:11:51 +0100
commitb2906dbebfd547a630a4eafdcbaa1ceefa5e257c (patch)
treea726b85511ca3522f5fd2f98d42e5d44c1712df1 /meta
parentd58b1d196f87128892b7b624bfb725afe01581f1 (diff)
downloadopenembedded-core-b2906dbebfd547a630a4eafdcbaa1ceefa5e257c.tar.gz
rpm: Add dependencies on bash, perl and python3-core
Also modify a Python script (pythondistdeps.py) to use Python 3. Signed-off-by: Peter Kjellerstedt <peter.kjellerstedt@axis.com> Signed-off-by: Mark Hatle <mark.hatle@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/rpm/rpm_git.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-devtools/rpm/rpm_git.bb b/meta/recipes-devtools/rpm/rpm_git.bb
index 59836d0b11..2f814c44e7 100644
--- a/meta/recipes-devtools/rpm/rpm_git.bb
+++ b/meta/recipes-devtools/rpm/rpm_git.bb
@@ -107,6 +107,9 @@ do_install_append_class-target() {
do_install_append () {
sed -i -e 's:${HOSTTOOLS_DIR}/::g' ${D}/${libdir}/rpm/macros
+
+ sed -i -e 's|/usr/bin/python|${USRBINPATH}/env ${PYTHON_PN}|' \
+ ${D}${libdir}/rpm/pythondistdeps.py
}
FILES_${PN} += "${libdir}/rpm-plugins/*.so \
@@ -121,3 +124,5 @@ FILES_python3-rpm = "${PYTHON_SITEPACKAGES_DIR}/rpm/*"
# rpm 5.x was packaging the rpm build tools separately
RPROVIDES_${PN} += "rpm-build"
+
+RDEPENDS_${PN} = "bash perl python3-core"