summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-14 14:00:21 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-08-16 00:01:45 +0100
commit92bda0024d85ae78345665cc2f9646c9881ed61b (patch)
tree3547945c91e6ef4a373cdccc17a6716407c3ca64 /meta
parent255caaad3574afec6ff5909c770eaee3f74a8155 (diff)
downloadopenembedded-core-92bda0024d85ae78345665cc2f9646c9881ed61b.tar.gz
python3-native: Avoid use of getentropy/getrandom
getentropy/random() is only available in glibc 2.25+ and uninative may relocate binaries onto systems that don't have this function. For now, force the code to the older codepaths until we can come up with a better solution for this kind of issue. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python3-native_3.5.3.bb4
1 files changed, 3 insertions, 1 deletions
diff --git a/meta/recipes-devtools/python/python3-native_3.5.3.bb b/meta/recipes-devtools/python/python3-native_3.5.3.bb
index 3467d29d4e..db0e7b9bd8 100644
--- a/meta/recipes-devtools/python/python3-native_3.5.3.bb
+++ b/meta/recipes-devtools/python/python3-native_3.5.3.bb
@@ -44,7 +44,8 @@ inherit native
require python-native-${PYTHON_MAJMIN}-manifest.inc
-EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip"
+# uninative may be used on pre glibc 2.25 systems which don't have getentropy
+EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --without-ensurepip ac_cv_func_getentropy=no"
EXTRA_OEMAKE = '\
LIBC="" \
@@ -59,6 +60,7 @@ PYTHONLSBOPTS = ""
do_configure_append() {
autoreconf --verbose --install --force --exclude=autopoint ../Python-${PV}/Modules/_ctypes/libffi
+ sed -i -e 's,#define HAVE_GETRANDOM 1,/\* #undef HAVE_GETRANDOM \*/,' ${B}/pyconfig.h
}
do_install() {