summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2015-05-15 17:42:09 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-15 17:58:40 +0100
commit84a3978653a322583d413d795567fa431ac7c952 (patch)
treef2024a19fbf55536b76d9c023dfc91810d020014 /meta
parent467eb93f5f252ab1a608397b9e97e1d6043501ef (diff)
downloadopenembedded-core-84a3978653a322583d413d795567fa431ac7c952.tar.gz
automake: simplify perl location forcing logic
Instead of letting configure find the host's perl and then use a complicated sed to replace it at install time, simply pre-seed the configure logic with the path we want to use. Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/automake/automake_1.15.bb12
1 files changed, 2 insertions, 10 deletions
diff --git a/meta/recipes-devtools/automake/automake_1.15.bb b/meta/recipes-devtools/automake/automake_1.15.bb
index d5b6e9eba4..c33dc22679 100644
--- a/meta/recipes-devtools/automake/automake_1.15.bb
+++ b/meta/recipes-devtools/automake/automake_1.15.bb
@@ -25,18 +25,10 @@ SRC_URI += " file://python-libdir.patch \
SRC_URI[md5sum] = "716946a105ca228ab545fc37a70df3a3"
SRC_URI[sha256sum] = "7946e945a96e28152ba5a6beb0625ca715c6e32ac55f2e353ef54def0c8ed924"
+CACHED_CONFIGUREVARS += "ac_cv_path_PERL=${USRBINPATH}/perl"
+
do_install_append () {
install -d ${D}${datadir}
-
- # Some distros have both /bin/perl and /usr/bin/perl, but we set perl location
- # for target as /usr/bin/perl, so fix it to /usr/bin/perl.
- for i in aclocal aclocal-${NAMEVER} automake automake-${NAMEVER}; do
- if [ -f ${D}${bindir}/$i ]; then
- sed -i -e '1s,#!.*perl,#! ${USRBINPATH}/perl,' \
- -e 's,exec .*/bin/perl \(.*\) exec .*/bin/perl \(.*\),exec ${USRBINPATH}/perl \1 exec ${USRBINPATH}/perl \2,' \
- ${D}${bindir}/$i
- fi
- done
}
BBCLASSEXTEND = "native nativesdk"