summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRobert Yang <liezhi.yang@windriver.com>2015-05-11 00:46:56 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2015-05-14 11:41:13 +0100
commit5492fb3b0d0ec4673c7d1d1c74c9500d20a9ac43 (patch)
tree2b68e582d6c29127db01d8c073b5a11bc8bd8ef6 /meta
parentee0a4412d66a2dd001defae7615f02e0617d91ed (diff)
downloadopenembedded-core-5492fb3b0d0ec4673c7d1d1c74c9500d20a9ac43.tar.gz
strace: add PACKAGECONFIG for bluez
Fixed: net.c:65:34: fatal error: bluetooth/bluetooth.h: No such file or directory # include <bluetooth/bluetooth.h> ^ compilation terminated. And use "??=" rather than "?=" for PACKAGECONFIG. Signed-off-by: Robert Yang <liezhi.yang@windriver.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/strace/strace_4.10.bb8
1 files changed, 6 insertions, 2 deletions
diff --git a/meta/recipes-devtools/strace/strace_4.10.bb b/meta/recipes-devtools/strace/strace_4.10.bb
index 07a1076bba..20b7e3d0a5 100644
--- a/meta/recipes-devtools/strace/strace_4.10.bb
+++ b/meta/recipes-devtools/strace/strace_4.10.bb
@@ -17,14 +17,18 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.xz \
SRC_URI[md5sum] = "107a5be455493861189e9b57a3a51912"
SRC_URI[sha256sum] = "e6180d866ef9e76586b96e2ece2bfeeb3aa23f5cc88153f76e9caedd65e40ee2"
-inherit autotools ptest
+inherit autotools ptest bluetooth
RDEPENDS_${PN}-ptest += "make coreutils grep gawk"
-PACKAGECONFIG_class-target ?= "libaio ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)}"
+PACKAGECONFIG_class-target ??= "\
+ libaio ${@bb.utils.contains('DISTRO_FEATURES', 'acl', 'acl', '', d)} \
+ ${@bb.utils.contains('DISTRO_FEATURES', 'bluetooth', 'bluez', '', d)} \
+"
PACKAGECONFIG[libaio] = "--enable-aio,--disable-aio,libaio"
PACKAGECONFIG[acl] = "--enable-acl,--disable-acl,acl"
PACKAGECONFIG[libunwind] = "--with-libunwind, --without-libunwind, libunwind"
+PACKAGECONFIG[bluez] = "ac_cv_header_bluetooth_bluetooth_h=yes,ac_cv_header_bluetooth_bluetooth_h=no,${BLUEZ}"
TESTDIR = "tests"