summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorBruce Ashfield <bruce.ashfield@windriver.com>2018-04-09 11:16:05 -0400
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-04-13 16:55:23 +0100
commit148fd7a5bfea5d18952355a294e6d36ca82291d2 (patch)
treef3af0c19bfcb101b57cb0279953e0bdec61d9789 /meta
parentce1cfa57d9828c0898f52e736f671ce8db534031 (diff)
downloadopenembedded-core-148fd7a5bfea5d18952355a294e6d36ca82291d2.tar.gz
linux-yocto/4.14: add elfutils, util-linux and openssl dependencies
4.15+ already has the following dependencies: DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}" DEPENDS += "openssl-native util-linux-native" Updates to 4.14 via the -stable releases have also introduced the same dependencies to 4.14's "make scripts". As such, we bring the same lines into 4.14 to restore the ability to build scripts. Signed-off-by: Bruce Ashfield <bruce.ashfield@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb3
-rw-r--r--meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb3
-rw-r--r--meta/recipes-kernel/linux/linux-yocto_4.14.bb3
3 files changed, 9 insertions, 0 deletions
diff --git a/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb b/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
index dfbde660b0..85f8542851 100644
--- a/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-rt_4.14.bb
@@ -19,6 +19,9 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;branch=${KBRANCH};name=mac
LINUX_VERSION ?= "4.14.30"
+DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
+DEPENDS += "openssl-native util-linux-native"
+
PV = "${LINUX_VERSION}+git${SRCPV}"
KMETA = "kernel-meta"
diff --git a/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb b/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
index e5941a7ea0..942579795f 100644
--- a/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto-tiny_4.14.bb
@@ -6,6 +6,9 @@ require recipes-kernel/linux/linux-yocto.inc
LINUX_VERSION ?= "4.14.30"
+DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
+DEPENDS += "openssl-native util-linux-native"
+
KMETA = "kernel-meta"
KCONF_BSP_AUDIT_LEVEL = "2"
diff --git a/meta/recipes-kernel/linux/linux-yocto_4.14.bb b/meta/recipes-kernel/linux/linux-yocto_4.14.bb
index ff54725613..bfc4de02f2 100644
--- a/meta/recipes-kernel/linux/linux-yocto_4.14.bb
+++ b/meta/recipes-kernel/linux/linux-yocto_4.14.bb
@@ -26,6 +26,9 @@ SRC_URI = "git://git.yoctoproject.org/linux-yocto.git;name=machine;branch=${KBRA
LINUX_VERSION ?= "4.14.30"
+DEPENDS += "${@bb.utils.contains('ARCH', 'x86', 'elfutils-native', '', d)}"
+DEPENDS += "openssl-native util-linux-native"
+
PV = "${LINUX_VERSION}+git${SRCPV}"
KMETA = "kernel-meta"