summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-08 21:33:53 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-10 11:35:32 +0000
commit07ded02ffd37b4fe60a6210dbf56490ea306f0b6 (patch)
treeffda460bbb93cc680cd65d44b8ae04114ab08ac1 /meta
parent6e26eaf03f2f524b78c194377ea0589e6913445d (diff)
downloadopenembedded-core-07ded02ffd37b4fe60a6210dbf56490ea306f0b6.tar.gz
Allow use of dash as /bin/sh
We've had the check for dash as /bin/sh for a long time. Dash has been around long enough now that most major issues have been identified and fixed from build perspective. This patch fixes a bashism in the openjade-native recipe. It also adjusts libtool so that the header at the script is used and not the value of $SHELL. This is because many Makefiles change $SHELL so dash can get used to execute what is otherwise configured as a bash shell script. Since we don't need to execute scripts this way on any system I'm aware of us building upon, the simplest fix is just to remove $SHELL. With these two changes the dash check can be removed and we can allow builds with dash as /bin/sh Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org> [Note: I know I need to add the description of the libtool change above into the prefix.patch]
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/sanity.bbclass3
-rw-r--r--meta/recipes-devtools/libtool/libtool/prefix.patch11
-rw-r--r--meta/recipes-devtools/openjade/openjade-native_1.3.2.bb4
3 files changed, 13 insertions, 5 deletions
diff --git a/meta/classes/sanity.bbclass b/meta/classes/sanity.bbclass
index 3f42b4f7cd..838448f33c 100644
--- a/meta/classes/sanity.bbclass
+++ b/meta/classes/sanity.bbclass
@@ -331,9 +331,6 @@ def check_sanity(e):
if not data.getVar( 'DISPLAY', e.data, True ) and data.getVar( 'IMAGETEST', e.data, True ) == 'qemu':
messages = messages + 'qemuimagetest needs a X desktop to start qemu, please set DISPLAY correctly (e.g. DISPLAY=:1.0)\n'
- if os.path.basename(os.readlink('/bin/sh')) == 'dash':
- messages = messages + "Using dash as /bin/sh causes various subtle build problems, please use bash instead (e.g. 'dpkg-reconfigure dash' on an Ubuntu system.\n"
-
omask = os.umask(022)
if omask & 0755:
messages = messages + "Please use a umask which allows a+rx and u+rwx\n"
diff --git a/meta/recipes-devtools/libtool/libtool/prefix.patch b/meta/recipes-devtools/libtool/libtool/prefix.patch
index 1b20324715..e6eca1fe02 100644
--- a/meta/recipes-devtools/libtool/libtool/prefix.patch
+++ b/meta/recipes-devtools/libtool/libtool/prefix.patch
@@ -8,6 +8,15 @@ Originally by: RP
Updated: Date: 2010/06/28
Nitin A Kamble <nitin.a.kamble@intel.com>
+It also adjusts libtool so that the header at the script is used for
+script execution and not thevalue of $SHELL. This is because many
+Makefiles change $SHELL so dash can get used to execute what is
+otherwise configured as a bash shell script. Since we don't need to
+execute scipts this way on any system I'm aware of us building upon,
+the simplest fix is just to remove $SHELL.
+
+Updated: Date: 2011/11/09
+RP
Index: libtool-2.4/libltdl/m4/libtool.m4
===================================================================
@@ -18,7 +27,7 @@ Index: libtool-2.4/libltdl/m4/libtool.m4
# Always use our own libtool.
-LIBTOOL='$(SHELL) $(top_builddir)/libtool'
-+LIBTOOL='$(SHELL) $(top_builddir)'
++LIBTOOL='$(top_builddir)'
+LIBTOOL="$LIBTOOL/${host_alias}-libtool"
AC_SUBST(LIBTOOL)dnl
diff --git a/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
index 6cc6bb5d2b..0cce46eca2 100644
--- a/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
+++ b/meta/recipes-devtools/openjade/openjade-native_1.3.2.bb
@@ -53,7 +53,9 @@ do_install() {
install -d ${D}${datadir}/sgml/openjade-${PV}
install -m 644 dsssl/catalog ${D}${datadir}/sgml/openjade-${PV}
- install -m 644 dsssl/*.{dtd,dsl,sgm} ${D}${datadir}/sgml/openjade-${PV}
+ install -m 644 dsssl/*.dtd ${D}${datadir}/sgml/openjade-${PV}
+ install -m 644 dsssl/*.dsl ${D}${datadir}/sgml/openjade-${PV}
+ install -m 644 dsssl/*.sgm ${D}${datadir}/sgml/openjade-${PV}
install -d ${datadir}/sgml/openjade-${PV}
install -m 644 dsssl/catalog ${datadir}/sgml/openjade-${PV}/catalog