summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorPaul Eggleton <paul.eggleton@linux.intel.com>2012-08-31 10:45:58 +0100
committerSaul Wold <sgw@linux.intel.com>2012-09-03 22:52:52 -0700
commit592d6e602466628d10704835a7b07d3d713f58e1 (patch)
treef79c78d93cc303bd5c24d83215ec130cd89f3509 /meta
parentdbbcc0cb9d2cbc66027c800075b94eb9b7110a00 (diff)
downloadopenembedded-core-592d6e602466628d10704835a7b07d3d713f58e1.tar.gz
packagegroup-core-console: remove
This provides one package group, packagegroup-core-apps-console, which is usually brought in by adding "apps-console-core" to IMAGE_FEATURES. Aside from the naming inconsistencies, this is a group of mostly unrelated packages, none of which are actually "apps". Handling each one: * dbus: should mostly be brought in by package runtime dependencies * avahi-daemon: if you are using packagegroup-base (as all images that inherit from core-image do) this is brought in by having "zeroconf" in DISTRO_FEATURES. * portmap: not very useful by itself; should be brought in by selecting NFS server/client through other means. * psplash (or whatever SPLASH is set to): this has been changed to be an explicit item "splash" in IMAGE_FEATURES. Since this is a fairly fundamental feature, a piece of code has been added to automatically handle this for images still using apps-console-core (and show a warning). Signed-off-by: Paul Eggleton <paul.eggleton@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/classes/core-image.bbclass10
-rw-r--r--meta/classes/image.bbclass4
-rw-r--r--meta/recipes-core/images/core-image-base.bb2
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-console.bb20
-rw-r--r--meta/recipes-core/packagegroups/packagegroup-core-sdk.bb1
-rw-r--r--meta/recipes-extended/images/core-image-basic.bb2
-rw-r--r--meta/recipes-extended/images/core-image-lsb-dev.bb2
-rw-r--r--meta/recipes-extended/images/core-image-lsb-sdk.bb2
-rw-r--r--meta/recipes-extended/images/core-image-lsb.bb2
-rw-r--r--meta/recipes-graphics/images/core-image-clutter.bb2
-rw-r--r--meta/recipes-graphics/images/core-image-x11.bb2
-rw-r--r--meta/recipes-sato/images/core-image-sato.bb2
12 files changed, 20 insertions, 31 deletions
diff --git a/meta/classes/core-image.bbclass b/meta/classes/core-image.bbclass
index 6a391d5925..2bfadb4072 100644
--- a/meta/classes/core-image.bbclass
+++ b/meta/classes/core-image.bbclass
@@ -12,7 +12,6 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
#
# Available IMAGE_FEATURES:
#
-# - apps-console-core
# - x11 - X server
# - x11-base - X server with minimal environment
# - x11-sato - OpenedHand Sato environment
@@ -25,7 +24,6 @@ LIC_FILES_CHKSUM = "file://${COREBASE}/LICENSE;md5=3f40d7994397109285ec7b81fdeb3
# - ssh-server-openssh - SSH server (openssh)
# - debug-tweaks - makes an image suitable for development
#
-PACKAGE_GROUP_apps-console-core = "packagegroup-core-apps-console"
PACKAGE_GROUP_x11 = "packagegroup-core-x11"
PACKAGE_GROUP_x11-base = "packagegroup-core-x11-base"
PACKAGE_GROUP_x11-sato = "packagegroup-core-x11-sato"
@@ -47,6 +45,14 @@ IMAGE_FEATURES_REPLACES_ssh-server-openssh = "ssh-server-dropbear"
# IMAGE_FEATURES_CONFLICTS_foo = 'bar1 bar2'
# An error exception would be raised if both image features foo and bar1(or bar2) are included
+python __anonymous() {
+ # Ensure we still have a splash screen for existing images
+ if base_contains("IMAGE_FEATURES", "apps-console-core", "1", "", d) == "1":
+ bb.warn("%s: apps-console-core in IMAGE_FEATURES is no longer supported; adding \"splash\" to enable splash screen" % d.getVar("PN", True))
+ d.appendVar("IMAGE_FEATURES", " splash")
+}
+
+
CORE_IMAGE_BASE_INSTALL = '\
packagegroup-core-boot \
packagegroup-base-extended \
diff --git a/meta/classes/image.bbclass b/meta/classes/image.bbclass
index 0f6ab381cd..2e95556011 100644
--- a/meta/classes/image.bbclass
+++ b/meta/classes/image.bbclass
@@ -39,6 +39,10 @@ def normal_groups(d):
features = set(oe.data.typed_value('IMAGE_FEATURES', d))
return features.difference(extras)
+# Define some very basic feature package groups
+SPLASH ?= "psplash"
+PACKAGE_GROUP_splash = "${SPLASH}"
+
# Wildcards specifying complementary packages to install for every package that has been explicitly
# installed into the rootfs
def complementary_globs(featurevar, d):
diff --git a/meta/recipes-core/images/core-image-base.bb b/meta/recipes-core/images/core-image-base.bb
index 30c8dd1553..8ef3376bfb 100644
--- a/meta/recipes-core/images/core-image-base.bb
+++ b/meta/recipes-core/images/core-image-base.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "A console-only image that fully supports the target device \
hardware."
-IMAGE_FEATURES += "apps-console-core"
+IMAGE_FEATURES += "splash"
LICENSE = "MIT"
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-console.bb b/meta/recipes-core/packagegroups/packagegroup-core-console.bb
deleted file mode 100644
index 0c5e7f1e25..0000000000
--- a/meta/recipes-core/packagegroups/packagegroup-core-console.bb
+++ /dev/null
@@ -1,20 +0,0 @@
-#
-# Copyright (C) 2011 Intel Corporation
-#
-
-DESCRIPTION = "Tasks for core console applications"
-LICENSE = "MIT"
-PR = "r35"
-
-inherit packagegroup
-
-PACKAGE_ARCH = "${MACHINE_ARCH}"
-
-SPLASH ?= "psplash"
-
-RDEPENDS_packagegroup-core-apps-console = "\
- avahi-daemon \
- dbus \
- portmap \
- ${SPLASH}"
-
diff --git a/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb b/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
index 8d7bbac3a5..e944ec5fe0 100644
--- a/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
+++ b/meta/recipes-core/packagegroups/packagegroup-core-sdk.bb
@@ -4,7 +4,6 @@
DESCRIPTION = "Software Development Tasks for OpenedHand Poky"
LICENSE = "MIT"
-DEPENDS = "packagegroup-core-console"
PR = "r8"
inherit packagegroup
diff --git a/meta/recipes-extended/images/core-image-basic.bb b/meta/recipes-extended/images/core-image-basic.bb
index 9aa880ec4f..06f15a8bec 100644
--- a/meta/recipes-extended/images/core-image-basic.bb
+++ b/meta/recipes-extended/images/core-image-basic.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "A foundational basic image without support for X that can be \
reasonably used for customization."
-IMAGE_FEATURES += "apps-console-core ssh-server-openssh"
+IMAGE_FEATURES += "splash ssh-server-openssh"
IMAGE_INSTALL = "\
packagegroup-core-boot \
diff --git a/meta/recipes-extended/images/core-image-lsb-dev.bb b/meta/recipes-extended/images/core-image-lsb-dev.bb
index 557259b1b6..013efb973d 100644
--- a/meta/recipes-extended/images/core-image-lsb-dev.bb
+++ b/meta/recipes-extended/images/core-image-lsb-dev.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Basic image without X support suitable for development work. It \
can be used for customization and implementations that conform to Linux \
Standard Base (LSB)."
-IMAGE_FEATURES += "apps-console-core dev-pkgs ssh-server-openssh"
+IMAGE_FEATURES += "splash dev-pkgs ssh-server-openssh"
IMAGE_INSTALL = "\
${CORE_IMAGE_BASE_INSTALL} \
diff --git a/meta/recipes-extended/images/core-image-lsb-sdk.bb b/meta/recipes-extended/images/core-image-lsb-sdk.bb
index d07f90d527..abddb767c6 100644
--- a/meta/recipes-extended/images/core-image-lsb-sdk.bb
+++ b/meta/recipes-extended/images/core-image-lsb-sdk.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Basic image without X support suitable for Linux Standard Base \
(LSB) implementations. It includes the full meta-toolchain, plus development \
headers and libraries to form a standalone SDK."
-IMAGE_FEATURES += "apps-console-core tools-sdk dev-pkgs ssh-server-openssh \
+IMAGE_FEATURES += "splash tools-sdk dev-pkgs ssh-server-openssh \
tools-debug tools-profile tools-testapps debug-tweaks"
diff --git a/meta/recipes-extended/images/core-image-lsb.bb b/meta/recipes-extended/images/core-image-lsb.bb
index 8435596da1..2c47dc6b09 100644
--- a/meta/recipes-extended/images/core-image-lsb.bb
+++ b/meta/recipes-extended/images/core-image-lsb.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "A foundational basic image without support for X that can be \
reasonably used for customization and is suitable for implementations that \
conform to Linux Standard Base (LSB)."
-IMAGE_FEATURES += "apps-console-core ssh-server-openssh"
+IMAGE_FEATURES += "splash ssh-server-openssh"
IMAGE_INSTALL = "\
${CORE_IMAGE_BASE_INSTALL} \
diff --git a/meta/recipes-graphics/images/core-image-clutter.bb b/meta/recipes-graphics/images/core-image-clutter.bb
index 496246e4f2..b0f25cf1b1 100644
--- a/meta/recipes-graphics/images/core-image-clutter.bb
+++ b/meta/recipes-graphics/images/core-image-clutter.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "An image with support for the Open GL-based toolkit Clutter, \
which enables development of rich and animated graphical user interfaces."
-IMAGE_FEATURES += "apps-console-core package-management x11-base x11-sato ssh-server-dropbear"
+IMAGE_FEATURES += "splash package-management x11-base x11-sato ssh-server-dropbear"
LICENSE = "MIT"
diff --git a/meta/recipes-graphics/images/core-image-x11.bb b/meta/recipes-graphics/images/core-image-x11.bb
index 73a707d87c..64dc053f37 100644
--- a/meta/recipes-graphics/images/core-image-x11.bb
+++ b/meta/recipes-graphics/images/core-image-x11.bb
@@ -1,6 +1,6 @@
DESCRIPTION = "A very basic X11 image with a terminal"
-IMAGE_FEATURES += "apps-console-core package-management x11-base"
+IMAGE_FEATURES += "splash package-management x11-base"
LICENSE = "MIT"
diff --git a/meta/recipes-sato/images/core-image-sato.bb b/meta/recipes-sato/images/core-image-sato.bb
index 6b6c7611bc..f52a1a5478 100644
--- a/meta/recipes-sato/images/core-image-sato.bb
+++ b/meta/recipes-sato/images/core-image-sato.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Image with Sato, a mobile environment and visual style for \
mobile devices. The image supports X11 with a Sato theme, Pimlico \
applications, and contains terminal, editor, and file manager."
-IMAGE_FEATURES += "apps-console-core package-management x11-base x11-sato ssh-server-dropbear"
+IMAGE_FEATURES += "splash package-management x11-base x11-sato ssh-server-dropbear"
LICENSE = "MIT"