summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2016-04-28 06:38:50 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2016-05-14 07:26:41 +0100
commita63798df712bf0d2362e07713c06af3b071a10b2 (patch)
treeb410aa7ce00e2e5e20a8f21dd8d8fd36dc30b756 /meta
parentcf82db2ba732031f392760e4f363e8b608e6fae3 (diff)
downloadopenembedded-core-a63798df712bf0d2362e07713c06af3b071a10b2.tar.gz
python-native: Point to expat in native sysroot and add missing dep on expat-native
This fixes inconsistency where expat dependency is then depending upon build host having it or not having it Fixes errors like WARNING: renaming "pyexpat" since importing it failed: build/lib.linux-x86_64-2.7/pyexpat.so: undefined symbol: XML_SetCommentHandler also reported here https://dev.openwrt.org/ticket/20087 This work due to the fact that we use -isystem pointing to native sysroot so the search order of native includedir is moved after buildhosts system includdirs. Moment we replace it with -I, build falls apart This also fixes the error Caught exception: <type 'exceptions.ImportError'> ImportError('No module named _elementtree',) where gobject-introspection-native fails to find _elementtree which is only compiled if expat is available Signed-off-by: Khem Raj <raj.khem@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/python/python-native_2.7.11.bb4
1 files changed, 2 insertions, 2 deletions
diff --git a/meta/recipes-devtools/python/python-native_2.7.11.bb b/meta/recipes-devtools/python/python-native_2.7.11.bb
index 4c204a4f0f..abb69fcd20 100644
--- a/meta/recipes-devtools/python/python-native_2.7.11.bb
+++ b/meta/recipes-devtools/python/python-native_2.7.11.bb
@@ -1,7 +1,7 @@
require python.inc
EXTRANATIVEPATH += "bzip2-native"
-DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native"
+DEPENDS = "openssl-native bzip2-replacement-native zlib-native readline-native sqlite3-native expat-native"
PR = "${INC_PR}.1"
SRC_URI += "\
@@ -27,7 +27,7 @@ inherit native
RPROVIDES += "python-distutils-native python-compression-native python-textutils-native python-codecs-native python-core-native python-unittest-native"
-EXTRA_OECONF_append = " --bindir=${bindir}/${PN}"
+EXTRA_OECONF_append = " --bindir=${bindir}/${PN} --with-system-expat=${STAGING_DIR_HOST}"
EXTRA_OEMAKE = '\
BUILD_SYS="" \