aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2017-09-25 16:36:08 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-04 17:14:27 +0000
commitcf4abc5eebdb5f88fefe3fb633bfdc1d2a94f9e3 (patch)
treecfdf73360f01fe287057eeb436f9bf935c7c0b8e /meta
parent25460ccdebaa6ff29ec051a0489a51b19c34e79c (diff)
downloadopenembedded-core-cf4abc5eebdb5f88fefe3fb633bfdc1d2a94f9e3.tar.gz
grub_2.02.bb: improve reproducibility
Remove several build host references from modinfo.sh files. Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> Signed-off-by: Armin Kuster <akuster@mvista.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-bsp/grub/grub_2.02.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub_2.02.bb b/meta/recipes-bsp/grub/grub_2.02.bb
index 57c6559365..b8055e7537 100644
--- a/meta/recipes-bsp/grub/grub_2.02.bb
+++ b/meta/recipes-bsp/grub/grub_2.02.bb
@@ -8,6 +8,13 @@ FILES_grub-editenv = "${bindir}/grub-editenv"
do_install_append () {
install -d ${D}${sysconfdir}/grub.d
+ # Remove build host references...
+ find "${D}" -name modinfo.sh -type f -exec \
+ sed -i \
+ -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
+ -e 's|${DEBUG_PREFIX_MAP}||g' \
+ -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
+ {} +
}
INSANE_SKIP_${PN} = "arch"