aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorAlejandro Hernandez <alejandro.hernandez@linux.intel.com>2017-09-15 11:22:44 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-21 09:23:59 +0100
commit2a4c65636821be48a8e585491bec40b5048be25d (patch)
treed055a64c9cd6034bcd2ffd4a3814a72a077b6849 /meta
parentdb1fc2ec360eb5dad1363634458ec4b56e7bbb9d (diff)
downloadopenembedded-core-2a4c65636821be48a8e585491bec40b5048be25d.tar.gz
core-image-tiny-initramfs: initramfs recipes should not generate an actual image file
core-image-tiny-initramfs was used to generate a wic image, which was conceptually wrong since initrafms recipes should only generate the boot artifacts that can later be used by another recipe to generate an image using the tool of their choice. Signed-off-by: Alejandro Hernandez <alejandro.hernandez@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/images/core-image-tiny-initramfs.bb7
1 files changed, 3 insertions, 4 deletions
diff --git a/meta/recipes-core/images/core-image-tiny-initramfs.bb b/meta/recipes-core/images/core-image-tiny-initramfs.bb
index 184727ddf7..a8893d1e53 100644
--- a/meta/recipes-core/images/core-image-tiny-initramfs.bb
+++ b/meta/recipes-core/images/core-image-tiny-initramfs.bb
@@ -1,10 +1,9 @@
# Simple initramfs image artifact generation for tiny images.
DESCRIPTION = "Tiny image capable of booting a device. The kernel includes \
the Minimal RAM-based Initial Root Filesystem (initramfs), which finds the \
-first 'init' program more efficiently. core-image-tiny-initramfs doesn't \
+first 'init' program more efficiently. core-image-tiny-initramfs doesn't \
actually generate an image but rather generates boot and rootfs artifacts \
-into a common location that can subsequently be picked up by external image \
-generation tools such as wic."
+that can subsequently be picked up by external image generation tools such as wic."
PACKAGE_INSTALL = "initramfs-live-boot packagegroup-core-boot dropbear ${VIRTUAL-RUNTIME_base-utils} udev base-passwd ${ROOTFS_BOOTSTRAP_INSTALL}"
@@ -17,7 +16,7 @@ IMAGE_LINGUAS = ""
LICENSE = "MIT"
# don't actually generate an image, just the artifacts needed for one
-IMAGE_FSTYPES = "${INITRAMFS_FSTYPES} wic"
+IMAGE_FSTYPES = "${INITRAMFS_FSTYPES}"
inherit core-image