aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2017-09-05 16:08:00 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-09-21 09:24:00 +0100
commit060088f256f8134ad68a7b5e493ddfa78a0382ea (patch)
treebb8ad4da5c2ad2627a0edee0b4c01bcad74a15d5 /meta
parent39e78c7615cdaaa8ad61a67d5c5bf7ff877167df (diff)
downloadopenembedded-core-060088f256f8134ad68a7b5e493ddfa78a0382ea.tar.gz
systemd-serialgetty: remove systemd from RDEPENDS
By setting systemd-serialgetty to rdepend on systemd, we are making configuration files have runtime dependency on the main utility that uses those configuration files. Applied with the same logic, we should make any package that provides service files under /etc/init.d/ to have runtime dependency on sysvinit. And this is not right. So we should remove systemd from RDEPENDS of systemd-serialgetty. Besides, as we have changed systemd to have systemd-serialgetty in its RDEPENDS by default, we should avoid circular dependency issue. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/systemd/systemd-serialgetty.bb2
1 files changed, 0 insertions, 2 deletions
diff --git a/meta/recipes-core/systemd/systemd-serialgetty.bb b/meta/recipes-core/systemd/systemd-serialgetty.bb
index 60891e432c..74b5986730 100644
--- a/meta/recipes-core/systemd/systemd-serialgetty.bb
+++ b/meta/recipes-core/systemd/systemd-serialgetty.bb
@@ -39,8 +39,6 @@ do_install() {
fi
}
-RDEPENDS_${PN} = "systemd"
-
# This is a machine specific file
FILES_${PN} = "${systemd_unitdir}/system/*.service ${sysconfdir}"
PACKAGE_ARCH = "${MACHINE_ARCH}"