aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2017-11-16 11:48:48 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-12-04 17:14:36 +0000
commit01fe3d3cf0bde71b566f3734941db60ffc9dd9b7 (patch)
treefe4a26157a1200db33bd41874544f78a02a54f67 /meta
parentb1806a257c0af1c69a81b3f855f6d165162257ae (diff)
downloadopenembedded-core-01fe3d3cf0bde71b566f3734941db60ffc9dd9b7.tar.gz
grub-efi_2.02.bb: improve reproducibility
Remove several build host references from modinfo.sh files. Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com> (cherry picked from commit 6e4182b7c540e22f25ea8bfd16b0e2b2c8eb9f82) Signed-off-by: Armin Kuster <akuster808@gmail.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-bsp/grub/grub-efi_2.02.bb10
1 files changed, 10 insertions, 0 deletions
diff --git a/meta/recipes-bsp/grub/grub-efi_2.02.bb b/meta/recipes-bsp/grub/grub-efi_2.02.bb
index b949bebced..44e32a88f1 100644
--- a/meta/recipes-bsp/grub/grub-efi_2.02.bb
+++ b/meta/recipes-bsp/grub/grub-efi_2.02.bb
@@ -41,6 +41,16 @@ do_install_class-native() {
install -m 755 grub-mkimage ${D}${bindir}
}
+do_install_append_class-target() {
+ # Remove build host references...
+ find "${D}" -name modinfo.sh -type f -exec \
+ sed -i \
+ -e 's,--sysroot=${STAGING_DIR_TARGET},,g' \
+ -e 's|${DEBUG_PREFIX_MAP}||g' \
+ -e 's:${RECIPE_SYSROOT_NATIVE}::g' \
+ {} +
+}
+
GRUB_BUILDIN ?= "boot linux ext2 fat serial part_msdos part_gpt normal efi_gop iso9660 search"
do_deploy() {