aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-07-01 11:51:15 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-01 23:07:56 +0100
commita67e0c0e01a22718a617a82f54575b77928249ee (patch)
treeb58905c2702108d8cfe007963c8745062a2607c4 /meta
parentc4eb1e7659a7f9f2791f1fdd5b0b22e7a5e423b0 (diff)
downloadopenembedded-core-a67e0c0e01a22718a617a82f54575b77928249ee.tar.gz
perl: Fix package qa rpath warnings.
Fix these kinds of Package QA warnings before they are converted into fetal errors: WARNING: QA Issue: package perl-module-compress contains bad RPATH /build_disk/poky_build/build0/tmp/sysroots/qemux86/usr/lib in file /build_disk/poky_build/build0/tmp/work/i586-poky-linux/perl-5.12.3-r1/packages-split/perl-module-compress/usr/lib/perl/5.12.3/auto/Compress/Raw/Zlib/Zlib.so This fixes this warning for perl recipe as well as libxml-parser-perl recipe. It is a fix to MakeMaker within perl, so all such perl recipes will get fixed with this perl fix. Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/perl/perl-5.12.3/fix_bad_rpath.patch25
-rw-r--r--meta/recipes-devtools/perl/perl_5.12.3.bb6
2 files changed, 29 insertions, 2 deletions
diff --git a/meta/recipes-devtools/perl/perl-5.12.3/fix_bad_rpath.patch b/meta/recipes-devtools/perl/perl-5.12.3/fix_bad_rpath.patch
new file mode 100644
index 0000000000..7b99857c17
--- /dev/null
+++ b/meta/recipes-devtools/perl/perl-5.12.3/fix_bad_rpath.patch
@@ -0,0 +1,25 @@
+Upstream-Status:Inappropriate [embedded specific]
+Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
+2011/07/01
+
+Fix these Package QA warnings before they are converted into fetal errors:
+
+WARNING: QA Issue: package perl-module-compress contains bad RPATH /build_disk/poky_build/build0/tmp/sysroots/qemux86/usr/lib in file /build_disk/poky_build/build0/tmp/work/i586-poky-linux/perl-5.12.3-r1/packages-split/perl-module-compress/usr/lib/perl/5.12.3/auto/Compress/Raw/Zlib/Zlib.so
+
+This fixes this warning for perl recipe as well as libxml-parser-perl recipe.
+It is a fix to MakeMaker within perl, so all such perl recipes will get
+fixed with this perl fix.
+
+Index: perl-5.12.3/cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist/Kid.pm
+===================================================================
+--- perl-5.12.3.orig/cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist/Kid.pm
++++ perl-5.12.3/cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist/Kid.pm
+@@ -54,7 +54,7 @@ sub _unix_os2_ext {
+ my($found) = 0;
+
+ # Debian-specific: don't use LD_RUN_PATH for standard dirs
+- $ld_run_path_seen{$_}++ for qw(/lib /usr/lib /usr/X11R6/lib);
++ $ld_run_path_seen{$_}++ for qw(/lib /usr/lib /usr/X11R6/lib SYSROOTLIB);
+
+ foreach my $thislib (split ' ', $potential_libs) {
+
diff --git a/meta/recipes-devtools/perl/perl_5.12.3.bb b/meta/recipes-devtools/perl/perl_5.12.3.bb
index b0534825b4..850eef21c2 100644
--- a/meta/recipes-devtools/perl/perl_5.12.3.bb
+++ b/meta/recipes-devtools/perl/perl_5.12.3.bb
@@ -8,7 +8,7 @@ PRIORITY = "optional"
# We need gnugrep (for -I)
DEPENDS = "virtual/db grep-native"
DEPENDS += "gdbm zlib"
-PR = "r1"
+PR = "r2"
# 5.10.1 has Module::Build built-in
PROVIDES += "libmodule-build-perl"
@@ -68,6 +68,7 @@ SRC_URI = "http://www.cpan.org/src/5.0/perl-${PV}.tar.gz \
file://native-perlinc.patch \
file://perl-enable-gdbm.patch \
file://cross-generate_uudmap.patch \
+ file://fix_bad_rpath.patch \
\
file://config.sh \
file://config.sh-32 \
@@ -178,7 +179,8 @@ do_configure() {
do_compile() {
sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' ext/Errno/Errno_pm.PL
sed -i -e 's|/usr/include|${STAGING_INCDIR}|g' cpan/Compress-Raw-Zlib/config.in
- sed -i -e 's|/usr/lib|${STAGING_LIBDIR}|g' cpan/Compress-Raw-Zlib/config.in
+ sed -i -e 's|/usr/lib|""|g' cpan/Compress-Raw-Zlib/config.in
+ sed -i -e 's|SYSROOTLIB|${STAGING_LIBDIR}|g' cpan/ExtUtils-MakeMaker/lib/ExtUtils/Liblist/Kid.pm
cd Cross
oe_runmake perl LD="${CCLD}"