aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2013-03-01 14:32:00 +0000
committerRoss Burton <ross.burton@intel.com>2013-03-01 14:32:00 +0000
commitd8204a21becac6f7eb54096c6af22d6de64eb932 (patch)
tree2ddd4ec8ac5d38e5f6850d0f83d9ec3ac4cb96e5 /meta
parent7912f3a721529302596a032560cffe96297b3113 (diff)
downloadopenembedded-core-d8204a21becac6f7eb54096c6af22d6de64eb932.tar.gz
alsa-tools: fix compilation error
Backport a fix from master to fix cross-compilation issues related to automake. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-multimedia/alsa/alsa-tools_1.0.25.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-multimedia/alsa/alsa-tools_1.0.25.bb b/meta/recipes-multimedia/alsa/alsa-tools_1.0.25.bb
index 7d96b853b9..3ee6e0daa9 100644
--- a/meta/recipes-multimedia/alsa/alsa-tools_1.0.25.bb
+++ b/meta/recipes-multimedia/alsa/alsa-tools_1.0.25.bb
@@ -20,6 +20,11 @@ SRC_URI[sha256sum] = "a974d0f3e837796f67d04df88c783aebcf4ac3c5f9ac31e2b65c10e8cb
inherit autotools
-EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST} --prefix=${prefix}' ACLOCAL_FLAGS='-I ${STAGING_DATADIR}/aclocal'"
+EXTRA_OEMAKE += "GITCOMPILE_ARGS='--host=${HOST_SYS} --build=${BUILD_SYS} --target=${TARGET_SYS} --with-libtool-sysroot=${STAGING_DIR_HOST} --prefix=${prefix} --libdir=${libdir}' ACLOCAL_FLAGS='-I ${STAGING_DATADIR}/aclocal'"
+
+do_compile_prepend () {
+ #Automake dir is not correctly detected in cross compilation case
+ export AUTOMAKE_DIR=${STAGING_DATADIR_NATIVE}/$(ls ${STAGING_DATADIR_NATIVE} | grep automake)
+}
FILES_${PN} += "${datadir}/ld10k1"