aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorTom Zanussi <tom.zanussi@linux.intel.com>2013-03-01 11:34:57 -0600
committerRoss Burton <ross.burton@intel.com>2013-04-23 10:22:12 +0100
commitc16882f69aa7ec2e74ba411925a184e5a6105b1d (patch)
treeb111e366b3a7368e85229559246ac0b3d70ac1cd /meta
parent93688b659bdf8067be2469ae91af10d68f5703eb (diff)
downloadopenembedded-core-c16882f69aa7ec2e74ba411925a184e5a6105b1d.tar.gz
systemtap: add python and bash dependencies
There are a number of scripts in the systemtap installation that use python and bash, so we need to add run-time dependencies for them. If not, we can generate build errors like "no package provides /usr/bin/python". Fixes [YOCTO #3951]. Signed-off-by: Tom Zanussi <tom.zanussi@linux.intel.com> Signed-off-by: Saul Wold <sgw@linux.intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-kernel/systemtap/systemtap_git.bb6
1 files changed, 5 insertions, 1 deletions
diff --git a/meta/recipes-kernel/systemtap/systemtap_git.bb b/meta/recipes-kernel/systemtap/systemtap_git.bb
index 3f94e981ae..90f7053632 100644
--- a/meta/recipes-kernel/systemtap/systemtap_git.bb
+++ b/meta/recipes-kernel/systemtap/systemtap_git.bb
@@ -6,12 +6,16 @@ DEPENDS = "elfutils sqlite3 systemtap-native"
DEPENDS_virtclass-native = "elfutils-native sqlite3-native gettext-native"
DEPENDS_virtclass-nativesdk = "nativesdk-elfutils nativesdk-sqlite3 nativesdk-gettext"
-PR = "r0"
+PR = "r1"
export CC_FOR_BUILD = "${BUILD_CC}"
export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
export LDFLAGS_FOR_BUILD = "${BUILD_LDFLAGS}"
+RDEPENDS_${PN} += "python bash"
+RDEPENDS_${PN}_class-native += "python-native"
+RDEPENDS_${PN}_class-nativesdk += "python-native"
+
EXTRA_OECONF += "--with-libelf=${STAGING_DIR_TARGET} --without-rpm \
--without-nss --without-avahi \
--disable-server --disable-grapher "