aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorHongxu Jia <hongxu.jia@windriver.com>2013-02-21 14:22:16 +0800
committerRoss Burton <ross.burton@intel.com>2013-03-01 11:12:31 +0000
commit7912f3a721529302596a032560cffe96297b3113 (patch)
treedc7aab062195fdc0b8e08b053da13fabb5b18452 /meta
parent77fed2c773d7d98f88d6e8a2f4a8617b9e8b8a62 (diff)
downloadopenembedded-core-7912f3a721529302596a032560cffe96297b3113.tar.gz
base-passwd.preinst:fix creating passwd and group error
Create files `passwd' and `group' in `$D${sysconfdir}', if `$D${sysconfdir}' does not exist, there is an error: ... cannot create $D${sysconfdir}/passwd: Directory nonexistent cannot create $D${sysconfdir}/group: Directory nonexistent ... Attampt to create dir before file creation. [YOCTO #3917] Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com> Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-core/base-passwd/base-passwd_3.5.26.bb3
1 files changed, 2 insertions, 1 deletions
diff --git a/meta/recipes-core/base-passwd/base-passwd_3.5.26.bb b/meta/recipes-core/base-passwd/base-passwd_3.5.26.bb
index 2073b3fa4a..ec7b6757c3 100644
--- a/meta/recipes-core/base-passwd/base-passwd_3.5.26.bb
+++ b/meta/recipes-core/base-passwd/base-passwd_3.5.26.bb
@@ -1,7 +1,7 @@
SUMMARY = "Base system master password/group files."
DESCRIPTION = "The master copies of the user database files (/etc/passwd and /etc/group). The update-passwd tool is also provided to keep the system databases synchronized with these master files."
SECTION = "base"
-PR = "r0"
+PR = "r1"
LICENSE = "GPLv2+"
LIC_FILES_CHKSUM = "file://COPYING;md5=eb723b61539feef013de476e68b5c50a"
@@ -64,6 +64,7 @@ python populate_packages_prepend() {
f.close()
preinst = """#!/bin/sh
+mkdir -p $D${sysconfdir}
if [ ! -e $D${sysconfdir}/passwd ]; then
\tcat << EOF > $D${sysconfdir}/passwd
""" + passwd + """EOF