aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorNitin A Kamble <nitin.a.kamble@intel.com>2011-05-10 22:24:47 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-05-11 16:55:13 +0100
commitfcc7800834fda37df5a5c2bbd1da712ec8ff12b9 (patch)
treefbd41eb8781332e8797d587b32536bc741f9204b /meta
parent67d76c3bc6918957e1993368f45b1fb9cfd5cf63 (diff)
downloadopenembedded-core-fcc7800834fda37df5a5c2bbd1da712ec8ff12b9.tar.gz
zaurusd: fix a typo in Makefile
Signed-off-by: Nitin A Kamble <nitin.a.kamble@intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-bsp/zaurusd/zaurusd/fix_makefile.patch19
-rw-r--r--meta/recipes-bsp/zaurusd/zaurusd_svn.bb5
2 files changed, 22 insertions, 2 deletions
diff --git a/meta/recipes-bsp/zaurusd/zaurusd/fix_makefile.patch b/meta/recipes-bsp/zaurusd/zaurusd/fix_makefile.patch
new file mode 100644
index 0000000000..9b28202521
--- /dev/null
+++ b/meta/recipes-bsp/zaurusd/zaurusd/fix_makefile.patch
@@ -0,0 +1,19 @@
+Upstream-Status: Pending
+
+Nitin A Kamble <nitin.a.kamble@intel.com> 2011/05/10
+Fix following build error:
+
+| Makefile:716: *** missing separator (did you mean TAB instead of 8 spaces?). Stop.
+| ERROR: oe_runmake failed
+
+Index: zaurusd/Makefile.am
+===================================================================
+--- zaurusd.orig/Makefile.am
++++ zaurusd/Makefile.am
+@@ -4,5 +4,5 @@ SUBDIRS = apps config scripts
+ MAINTAINERCLEANFILES = aclocal.m4 compile config.guess config.sub configure depcomp install-sh ltmain.sh Makefile.in missing
+
+ snapshot:
+- $(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
++ $(MAKE) dist distdir=$(PACKAGE)-snap`date +"%Y%m%d"`
+
diff --git a/meta/recipes-bsp/zaurusd/zaurusd_svn.bb b/meta/recipes-bsp/zaurusd/zaurusd_svn.bb
index 7313560e90..6f9ed033fb 100644
--- a/meta/recipes-bsp/zaurusd/zaurusd_svn.bb
+++ b/meta/recipes-bsp/zaurusd/zaurusd_svn.bb
@@ -6,9 +6,10 @@ DEPENDS = "tslib"
RDEPENDS_${PN} = "xrandr"
SRCREV = "426"
PV = "0.0+svnr${SRCPV}"
-PR = "r2"
+PR = "r3"
-SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=zaurusd;proto=http"
+SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=zaurusd;proto=http \
+ file://fix_makefile.patch"
S = "${WORKDIR}/${PN}"