aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-04 15:37:18 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2011-07-05 11:16:35 +0100
commitb8d72e3af93ff9e2808fef4fe7b9d00b68bf9715 (patch)
tree53972d874d34f89490faa147cb5c0a1ad47e3432 /meta
parent8e156563c962e20a1d7618280ed81cee3c696167 (diff)
downloadopenembedded-core-b8d72e3af93ff9e2808fef4fe7b9d00b68bf9715.tar.gz
gcc: Fix removal of libiberty.a
The changes in commit 553a92c442bc3a35d1520a22e640a3a0e377b8f7 were not applying correctly due to the error: "find: paths must precede expression" This patch corrects the find syntax. [YOCTO #1199] Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/gcc/gcc-4.6.inc2
-rw-r--r--meta/recipes-devtools/gcc/gcc-cross-intermediate.inc4
-rw-r--r--meta/recipes-devtools/gcc/gcc-package-cross.inc4
-rw-r--r--meta/recipes-devtools/gcc/gcc-package-target.inc4
-rw-r--r--meta/recipes-devtools/gcc/gcc_4.5.1.bb2
5 files changed, 8 insertions, 8 deletions
diff --git a/meta/recipes-devtools/gcc/gcc-4.6.inc b/meta/recipes-devtools/gcc/gcc-4.6.inc
index a0120492ae..68449954af 100644
--- a/meta/recipes-devtools/gcc/gcc-4.6.inc
+++ b/meta/recipes-devtools/gcc/gcc-4.6.inc
@@ -1,6 +1,6 @@
require gcc-common.inc
-PR = "r4"
+PR = "r5"
# Third digit in PV should be incremented after a minor release
# happens from this branch on gcc e.g. currently its 4.6.0
diff --git a/meta/recipes-devtools/gcc/gcc-cross-intermediate.inc b/meta/recipes-devtools/gcc/gcc-cross-intermediate.inc
index 05b5dbc089..df5958ac77 100644
--- a/meta/recipes-devtools/gcc/gcc-cross-intermediate.inc
+++ b/meta/recipes-devtools/gcc/gcc-cross-intermediate.inc
@@ -40,8 +40,8 @@ do_install () {
rm -rf ${D}${datadir}/
# We use libiberty from binutils
- find -name libiberty.a ${D}${exec_prefix}/lib | xargs rm -f
- find -name libiberty.h ${D}${exec_prefix}/lib | xargs rm -f
+ find ${D}${exec_prefix}/lib -name libiberty.a | xargs rm -f
+ find ${D}${exec_prefix}/lib -name libiberty.h | xargs rm -f
# Insert symlinks into libexec so when tools without a prefix are searched for, the correct ones are
# found. These need to be relative paths so they work in different locations.
diff --git a/meta/recipes-devtools/gcc/gcc-package-cross.inc b/meta/recipes-devtools/gcc/gcc-package-cross.inc
index b51336bf2d..3d27788c56 100644
--- a/meta/recipes-devtools/gcc/gcc-package-cross.inc
+++ b/meta/recipes-devtools/gcc/gcc-package-cross.inc
@@ -29,8 +29,8 @@ do_install () {
done
# We use libiberty from binutils
- find -name libiberty.a ${D}${exec_prefix}/lib | xargs rm -f
- find -name libiberty.h ${D}${exec_prefix}/lib | xargs rm -f
+ find ${D}${exec_prefix}/lib -name libiberty.a | xargs rm -f
+ find ${D}${exec_prefix}/lib -name libiberty.h | xargs rm -f
# gcc-runtime installs libgcc into a special location in staging since it breaks doing a standalone build
if [ "${PN}" == "gcc-cross" -o "${PN}" == "gcc-crosssdk" ]; then
diff --git a/meta/recipes-devtools/gcc/gcc-package-target.inc b/meta/recipes-devtools/gcc/gcc-package-target.inc
index 43e2bd5dba..6cc308c6dc 100644
--- a/meta/recipes-devtools/gcc/gcc-package-target.inc
+++ b/meta/recipes-devtools/gcc/gcc-package-target.inc
@@ -88,8 +88,8 @@ do_install () {
rm -f *gcc-?.?*
# We use libiberty from binutils
- find -name libiberty.a ${D}${exec_prefix}/lib | xargs rm -f
- find -name libiberty.h ${D}${exec_prefix}/lib | xargs rm -f
+ find ${D}${exec_prefix}/lib -name libiberty.a | xargs rm -f
+ find ${D}${exec_prefix}/lib -name libiberty.h | xargs rm -f
# Symlinks so we can use these trivially on the target
ln -sf ${TARGET_PREFIX}g77 g77 || true
diff --git a/meta/recipes-devtools/gcc/gcc_4.5.1.bb b/meta/recipes-devtools/gcc/gcc_4.5.1.bb
index e04f443b4d..785d719ac8 100644
--- a/meta/recipes-devtools/gcc/gcc_4.5.1.bb
+++ b/meta/recipes-devtools/gcc/gcc_4.5.1.bb
@@ -1,4 +1,4 @@
-PR = "r5"
+PR = "r6"
require gcc-${PV}.inc
require gcc-configure-target.inc
require gcc-package-target.inc