aboutsummaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-21 10:53:01 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2013-01-21 18:55:19 +0000
commit1b66c30eb6085aedce118ce086efbd2e562d0d6c (patch)
tree9e9a57e1b97fa6fe996b513133b9486a6cd4ce67 /meta
parentcaf6aa1c996a949ca85f4beaf40d2a19433d18c8 (diff)
downloadopenembedded-core-1b66c30eb6085aedce118ce086efbd2e562d0d6c.tar.gz
perl: Fix errors if configure is reattempted
If configure of perl is reattempted it currently fails as it tries to edit files outside ${S}. Chaging from ${WORKDIR} to ${S} avoids this issue and allows rebuilds to work. Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-devtools/perl/perl_5.14.2.bb2
1 files changed, 1 insertions, 1 deletions
diff --git a/meta/recipes-devtools/perl/perl_5.14.2.bb b/meta/recipes-devtools/perl/perl_5.14.2.bb
index f924ebd6d0..e875c1f574 100644
--- a/meta/recipes-devtools/perl/perl_5.14.2.bb
+++ b/meta/recipes-devtools/perl/perl_5.14.2.bb
@@ -168,7 +168,7 @@ do_configure() {
;;
esac
# These are strewn all over the source tree
- for foo in `grep -I --exclude="*.patch" --exclude="*.diff" --exclude="*.pod" --exclude="README*" -m1 "/usr/include/.*\.h" ${WORKDIR}/* -r -l` ${S}/utils/h2xs.PL ; do
+ for foo in `grep -I --exclude="*.patch" --exclude="*.diff" --exclude="*.pod" --exclude="README*" -m1 "/usr/include/.*\.h" ${S}/* -r -l` ${S}/utils/h2xs.PL ; do
echo Fixing: $foo
sed -e 's|\([ "^'\''I]\+\)/usr/include/|\1${STAGING_INCDIR}/|g' -i $foo
done