summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2011-12-28 15:41:08 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-03 12:10:46 +0000
commit169e55d802883df763dbff4a4737e05e96358fa3 (patch)
tree11dc30582c18fc4a8a199adda7f5d46d2312695f /meta
parent9aca7e651ce829e8a730dd187f54a5bba4253d06 (diff)
downloadopenembedded-core-169e55d802883df763dbff4a4737e05e96358fa3.tar.gz
openembedded-core-169e55d802883df763dbff4a4737e05e96358fa3.tar.bz2
openembedded-core-169e55d802883df763dbff4a4737e05e96358fa3.zip
Add Upstream-Status to patches
Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta')
-rw-r--r--meta/recipes-bsp/libacpi/files/use_correct_strip_in_cross_environment.patch2
-rw-r--r--meta/recipes-connectivity/connman/connman/disable_alg-test.patch2
-rw-r--r--meta/recipes-connectivity/connman/connman/ethernet_default.patch2
-rw-r--r--meta/recipes-devtools/automake/automake/prefer-cpio-over-pax-for-ustar-archives.patch2
-rw-r--r--meta/recipes-devtools/dosfstools/dosfstools/fix_populated_dosfs_creation.patch2
-rw-r--r--meta/recipes-devtools/dosfstools/dosfstools/nofat32_autoselect.patch2
-rw-r--r--meta/recipes-devtools/installer/files/wget_cache.patch2
-rw-r--r--meta/recipes-devtools/intltool/intltool-0.40.6/remove-xml-check.patch3
-rw-r--r--meta/recipes-devtools/opkg-utils/opkg-utils/arfile_header_split.patch2
-rw-r--r--meta/recipes-devtools/pseudo/pseudo/static_sqlite.patch2
-rw-r--r--meta/recipes-devtools/python/python-native/multilib.patch3
-rw-r--r--meta/recipes-devtools/python/python/multilib.patch3
-rw-r--r--meta/recipes-devtools/rpm/rpm/header-include-fix.patch2
-rw-r--r--meta/recipes-devtools/rpm/rpm/remove-compiled-tests.patch3
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-autoconf.patch2
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-autogen.patch2
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-canonarch.patch2
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-fileclass.patch2
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-libsql-fix.patch2
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-log-auto-rm.patch3
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-no-loopmsg.patch2
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-nofsync.patch2
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-platform.patch2
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-showrc.patch2
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-solvedb.patch2
-rw-r--r--meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch2
-rw-r--r--meta/recipes-devtools/strace/strace-4.5.20/sigmask.patch1
-rw-r--r--meta/recipes-gnome/gnome/gobject-introspection/use-usr-bin-env-for-python.patch2
-rw-r--r--meta/recipes-gnome/libglade/libglade-2.6.4/python_environment.patch2
-rw-r--r--meta/recipes-kernel/blktrace/blktrace/blktrace-makefile.patch2
-rw-r--r--meta/recipes-kernel/dtc/dtc/make_install.patch2
-rw-r--r--meta/recipes-kernel/linux/linux-yocto/tools-perf-no-scripting.patch3
-rw-r--r--meta/recipes-kernel/sysprof/files/rmb-arm.patch3
-rw-r--r--meta/recipes-kernel/sysprof/files/rmb-mips.patch2
-rw-r--r--meta/recipes-multimedia/musicbrainz/libmusicbrainz-3.0.3/allow-libdir-override.patch2
-rw-r--r--meta/recipes-support/gmp/gmp/gmp_bugfix.patch2
36 files changed, 69 insertions, 9 deletions
diff --git a/meta/recipes-bsp/libacpi/files/use_correct_strip_in_cross_environment.patch b/meta/recipes-bsp/libacpi/files/use_correct_strip_in_cross_environment.patch
index c9ad668fcd..bca75fb472 100644
--- a/meta/recipes-bsp/libacpi/files/use_correct_strip_in_cross_environment.patch
+++ b/meta/recipes-bsp/libacpi/files/use_correct_strip_in_cross_environment.patch
@@ -1,4 +1,4 @@
-UpstreamStatus: Pending
+Upstream-Status: Pending
Used the cross strip instead of host strip to avoid this build error:
diff --git a/meta/recipes-connectivity/connman/connman/disable_alg-test.patch b/meta/recipes-connectivity/connman/connman/disable_alg-test.patch
index c231d75c4f..44ad768cec 100644
--- a/meta/recipes-connectivity/connman/connman/disable_alg-test.patch
+++ b/meta/recipes-connectivity/connman/connman/disable_alg-test.patch
@@ -6,7 +6,7 @@ Subject: [PATCH] Disable building of alg-test
alg-test utility depends on linux/if_alg.h header that is only
available on kernels >= 2.6.39.
-Upstream Status: Inappropriate [configuration]
+Upstream-Status: Inappropriate [configuration]
Signed-off-by: Otavio Salvador <otavio@ossystems.com.br>
---
diff --git a/meta/recipes-connectivity/connman/connman/ethernet_default.patch b/meta/recipes-connectivity/connman/connman/ethernet_default.patch
index d0c05d72ff..6dae2aa0c8 100644
--- a/meta/recipes-connectivity/connman/connman/ethernet_default.patch
+++ b/meta/recipes-connectivity/connman/connman/ethernet_default.patch
@@ -3,7 +3,7 @@ will shut down all the networking when it starts without any configuration
which is usualy not what the users expects. This is particularly
problematic with our qemu images and runtime testing using qemu.
-Upstream Status: Inappropriate [Configuration]
+Upstream-Status: Inappropriate [Configuration]
RP 2011/12/12
diff --git a/meta/recipes-devtools/automake/automake/prefer-cpio-over-pax-for-ustar-archives.patch b/meta/recipes-devtools/automake/automake/prefer-cpio-over-pax-for-ustar-archives.patch
index 083547a35b..7bc8caf4f1 100644
--- a/meta/recipes-devtools/automake/automake/prefer-cpio-over-pax-for-ustar-archives.patch
+++ b/meta/recipes-devtools/automake/automake/prefer-cpio-over-pax-for-ustar-archives.patch
@@ -11,6 +11,8 @@ CDPATH="${ZSH_VERSION+.}:" && cd . && perllibdir="automake-1.11.1/lib:./lib" "au
/bin/sh: automake-1.11.1/aclocal: No such file or directory
make: *** [aclocal.m4] Error 127
+Upstream-Status: Pending
+
Signed-off-by: Tom Rini <tom_rini@mentor.com>
Index: automake-1.11.1/m4/tar.m4
diff --git a/meta/recipes-devtools/dosfstools/dosfstools/fix_populated_dosfs_creation.patch b/meta/recipes-devtools/dosfstools/dosfstools/fix_populated_dosfs_creation.patch
index 510f12e3ed..9d7f7321ac 100644
--- a/meta/recipes-devtools/dosfstools/dosfstools/fix_populated_dosfs_creation.patch
+++ b/meta/recipes-devtools/dosfstools/dosfstools/fix_populated_dosfs_creation.patch
@@ -1,4 +1,4 @@
-UpstreamStatus: Inappropriate
+Upstream-Status: Inappropriate
This patch fixes populated dosfs image creation with directory
structures. Earlier it was causing segfault; and only image
diff --git a/meta/recipes-devtools/dosfstools/dosfstools/nofat32_autoselect.patch b/meta/recipes-devtools/dosfstools/dosfstools/nofat32_autoselect.patch
index 21ebc1052c..6ee3f7f771 100644
--- a/meta/recipes-devtools/dosfstools/dosfstools/nofat32_autoselect.patch
+++ b/meta/recipes-devtools/dosfstools/dosfstools/nofat32_autoselect.patch
@@ -4,7 +4,7 @@ broken images with the -d option. It can still be enabled on the commandline
at the users own risk. This changes us back to the 2.10 version's behaviour
which was known to work well even with large images.
-Upstream Status: Inapprioriate [depends on other patches we apply]
+Upstream-Status: Inapproriate [depends on other patches we apply]
RP 2011/12/13
diff --git a/meta/recipes-devtools/installer/files/wget_cache.patch b/meta/recipes-devtools/installer/files/wget_cache.patch
index 6fd38e5fc4..1281d12a3b 100644
--- a/meta/recipes-devtools/installer/files/wget_cache.patch
+++ b/meta/recipes-devtools/installer/files/wget_cache.patch
@@ -1,3 +1,5 @@
+Upstream-Status: Inappropriate [configuration]
+
--- trunk/libopkg/opkg_download.c 2011-03-10 16:41:29.000000000 +0800
+++ trunk/libopkg/opkg_download.c 2011-03-10 16:42:33.000000000 +0800
@@ -162,6 +162,7 @@
diff --git a/meta/recipes-devtools/intltool/intltool-0.40.6/remove-xml-check.patch b/meta/recipes-devtools/intltool/intltool-0.40.6/remove-xml-check.patch
index 476d0913d4..2eb9abd06b 100644
--- a/meta/recipes-devtools/intltool/intltool-0.40.6/remove-xml-check.patch
+++ b/meta/recipes-devtools/intltool/intltool-0.40.6/remove-xml-check.patch
@@ -1,3 +1,6 @@
+
+Upstream-Status: Inappropriate [configuration]
+
Index: intltool-0.40.6/intltool.m4
===================================================================
--- intltool-0.40.6.orig/intltool.m4 2009-02-14 14:12:28.000000000 -0800
diff --git a/meta/recipes-devtools/opkg-utils/opkg-utils/arfile_header_split.patch b/meta/recipes-devtools/opkg-utils/opkg-utils/arfile_header_split.patch
index 435e74e863..b679f8b970 100644
--- a/meta/recipes-devtools/opkg-utils/opkg-utils/arfile_header_split.patch
+++ b/meta/recipes-devtools/opkg-utils/opkg-utils/arfile_header_split.patch
@@ -6,7 +6,7 @@ Subject: ipkg-utils: Make arfile.py handle six digit UIDs
as a single field. This makes things better than before as it now honors
the fixed field widths.
-Upsteam-status: Pending (there is no upstream after openmoko imploded)
+Upstream-Status: Pending (there is no upstream after openmoko imploded)
--- ipkg-utils/arfile.py.orig 2010-09-29 13:38:15.000000000 -0700
+++ ipkg-utils/arfile.py 2010-10-01 16:06:00.000000000 -0700
diff --git a/meta/recipes-devtools/pseudo/pseudo/static_sqlite.patch b/meta/recipes-devtools/pseudo/pseudo/static_sqlite.patch
index 6faa7a2a44..f9223a86ae 100644
--- a/meta/recipes-devtools/pseudo/pseudo/static_sqlite.patch
+++ b/meta/recipes-devtools/pseudo/pseudo/static_sqlite.patch
@@ -1,6 +1,8 @@
Due to disabling the LD_LIBRARY_PATH handling, we need to use a static
libsqlite.
+Upstream-Status: Inappropriate [configuration]
+
diff -ur git.orig/Makefile.in git/Makefile.in
--- git.orig/Makefile.in
+++ git/Makefile.in
diff --git a/meta/recipes-devtools/python/python-native/multilib.patch b/meta/recipes-devtools/python/python-native/multilib.patch
index f8d7aee84b..0526031ada 100644
--- a/meta/recipes-devtools/python/python-native/multilib.patch
+++ b/meta/recipes-devtools/python/python-native/multilib.patch
@@ -16,6 +16,9 @@ The python recipe building was failing because python-native
could not handle sys.lib var. sys.lib var is defined in the
multilib patch hence added this multilib.patch for python-native
recipe.
+
+Upstream-Status: Inappropriate [oe-specific]
+
Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
Index: Python-2.7.2/Include/pythonrun.h
diff --git a/meta/recipes-devtools/python/python/multilib.patch b/meta/recipes-devtools/python/python/multilib.patch
index babff1280e..df470f7c09 100644
--- a/meta/recipes-devtools/python/python/multilib.patch
+++ b/meta/recipes-devtools/python/python/multilib.patch
@@ -12,6 +12,9 @@ Date: Tue Jun 28 21:21:29 2011 +0800
2011/09/29
Rebased for python 2.7.2
+
+Upstream-Status: Inappropriate [configuration]
+
Signed-Off-By: Nitin A Kamble <nitin.a.kamble@intel.com>
Index: Python-2.7.2/Include/pythonrun.h
diff --git a/meta/recipes-devtools/rpm/rpm/header-include-fix.patch b/meta/recipes-devtools/rpm/rpm/header-include-fix.patch
index 92c534e582..6aa072d7c8 100644
--- a/meta/recipes-devtools/rpm/rpm/header-include-fix.patch
+++ b/meta/recipes-devtools/rpm/rpm/header-include-fix.patch
@@ -1,3 +1,5 @@
+Upstream-Status: Pending
+
diff --git a/rpmdb/rpmdb.h b/rpmdb/rpmdb.h
index 0e1bdd7..8b522bb 100644
--- a/rpmdb/rpmdb.h
diff --git a/meta/recipes-devtools/rpm/rpm/remove-compiled-tests.patch b/meta/recipes-devtools/rpm/rpm/remove-compiled-tests.patch
index 69b7130b9b..3663692d2d 100644
--- a/meta/recipes-devtools/rpm/rpm/remove-compiled-tests.patch
+++ b/meta/recipes-devtools/rpm/rpm/remove-compiled-tests.patch
@@ -1,3 +1,6 @@
+
+Upstream-Status: Inappropriate [configuration]
+
Index: rpm-5.1.9/configure.ac
===================================================================
--- rpm-5.1.9.orig/configure.ac 2009-04-18 17:47:02.000000000 +0100
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-autoconf.patch b/meta/recipes-devtools/rpm/rpm/rpm-autoconf.patch
index 30c5f7b183..5e93517ad1 100644
--- a/meta/recipes-devtools/rpm/rpm/rpm-autoconf.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpm-autoconf.patch
@@ -4,6 +4,8 @@ configure.ac:11: error: m4_divert_push: cannot change diversion to `GROW' inside
without this patch.
+Upstream-Status: Pending
+
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
diff -ur rpm-5.1.10.orig/configure.ac rpm-5.1.10/configure.ac
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-autogen.patch b/meta/recipes-devtools/rpm/rpm/rpm-autogen.patch
index 323bb7151e..5fe6ded811 100644
--- a/meta/recipes-devtools/rpm/rpm/rpm-autogen.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpm-autogen.patch
@@ -2,6 +2,8 @@ Remove the sanity checking from the rpm autogen.sh. This is required because
we may have slightly different, but yet compatible versions. If we do end
up breaking things, we'll deal with it at that time.
+Upstream-Status: Pending
+
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
diff -ur rpm-5.4.0.orig/autogen.sh rpm-5.4.0/autogen.sh
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-canonarch.patch b/meta/recipes-devtools/rpm/rpm/rpm-canonarch.patch
index 36190585ca..3aac1164d6 100644
--- a/meta/recipes-devtools/rpm/rpm/rpm-canonarch.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpm-canonarch.patch
@@ -14,6 +14,8 @@ This patch changes the list of supported items to:
<arch>-<vendor>-<os>
<arch>-<vendor>-<os>-<extension>
+Upstream-Status: Pending
+
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
Index: rpm-5.4.0/lib/rpmrc.c
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-fileclass.patch b/meta/recipes-devtools/rpm/rpm/rpm-fileclass.patch
index d1e4bf695c..1f948cd65a 100644
--- a/meta/recipes-devtools/rpm/rpm/rpm-fileclass.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpm-fileclass.patch
@@ -7,6 +7,8 @@ Note: this is a temporary workaround. Eventually we will want to have a way
to seed per-file dependency and other information in order to generate a
package from previously determined information.
+Upstream-Status: Pending
+
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
diff --git a/lib/rpmfc.c b/lib/rpmfc.c
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-libsql-fix.patch b/meta/recipes-devtools/rpm/rpm/rpm-libsql-fix.patch
index 829399c95e..b5ff2637c2 100644
--- a/meta/recipes-devtools/rpm/rpm/rpm-libsql-fix.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpm-libsql-fix.patch
@@ -2,6 +2,8 @@ During installation, the libtool relink attempts to link to -lrpm...
The problem is that it hasn't been installed yet! So small change causes
the libtool to instead use the build version.
+Upstream-Status: Pending
+
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
--- rpm-5.4.0/lib/Makefile.am.orig
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-log-auto-rm.patch b/meta/recipes-devtools/rpm/rpm/rpm-log-auto-rm.patch
index aafa416881..babafb3d72 100644
--- a/meta/recipes-devtools/rpm/rpm/rpm-log-auto-rm.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpm-log-auto-rm.patch
@@ -1,3 +1,6 @@
+
+Upstream-Status: Inappropriate [configuration]
+
diff --git a/rpmdb/DB_CONFIG.in b/rpmdb/DB_CONFIG.in
index 8b94c94..e0b4689 100644
--- a/rpmdb/DB_CONFIG.in
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-no-loopmsg.patch b/meta/recipes-devtools/rpm/rpm/rpm-no-loopmsg.patch
index 4aded7518e..d81e25ac4e 100644
--- a/meta/recipes-devtools/rpm/rpm/rpm-no-loopmsg.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpm-no-loopmsg.patch
@@ -1,5 +1,7 @@
lib/order.c: Make the dependency loop messages into debug msgs
+Upstream-Status: Pending
+
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
diff -urN rpm-5.4.0.orig/lib/order.c rpm-5.4.0/lib/order.c
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-nofsync.patch b/meta/recipes-devtools/rpm/rpm/rpm-nofsync.patch
index 33039ad990..f6e58283be 100644
--- a/meta/recipes-devtools/rpm/rpm/rpm-nofsync.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpm-nofsync.patch
@@ -1,5 +1,7 @@
Backport from RPM 5.4.1 CVS, disabled fsync.
+Upstream-Status: Backport
+
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
diff -ur rpm-5.4.0.orig/CHANGES rpm-5.4.0/CHANGES
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-platform.patch b/meta/recipes-devtools/rpm/rpm/rpm-platform.patch
index 09a1c13048..7b81857837 100644
--- a/meta/recipes-devtools/rpm/rpm/rpm-platform.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpm-platform.patch
@@ -1,5 +1,7 @@
Fix up platform and related sysinfo file loading.
+Upstream-Status: Pending
+
This ensures that RPM knows the compatible set of package types at all times.
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-showrc.patch b/meta/recipes-devtools/rpm/rpm/rpm-showrc.patch
index 5051ce604b..b38b34d9db 100644
--- a/meta/recipes-devtools/rpm/rpm/rpm-showrc.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpm-showrc.patch
@@ -1,5 +1,7 @@
Workaround for a memory leak in --showrc.
+Upstream-Status: Pending
+
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
diff -ur rpm-5.4.0.orig/lib/rpmrc.c rpm-5.4.0/lib/rpmrc.c
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-solvedb.patch b/meta/recipes-devtools/rpm/rpm/rpm-solvedb.patch
index 5c1819c367..d6f43a2c06 100644
--- a/meta/recipes-devtools/rpm/rpm/rpm-solvedb.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpm-solvedb.patch
@@ -4,6 +4,8 @@ Previously the max was set to 5, up this to 20... this should be more
then enough for now.. also add an RPM_ERROR message in case we exceed the
new maximum.
+Upstream-Status: Pending
+
Signed-off-by: Mark Hatle <mark.hatle@windriver.com>
diff -urN rpm-5.4.0.orig/rpmio/rpmbag.c rpm-5.4.0/rpmio/rpmbag.c
diff --git a/meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch b/meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch
index 9e7bba0475..dd8d8bd5de 100644
--- a/meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch
+++ b/meta/recipes-devtools/rpm/rpm/rpm-tools-mtree-LDFLAGS.patch
@@ -1,5 +1,5 @@
Source: None
-Status: Needs to go Upstream
+Upstream-Status: Pending
Author: Khem Raj <raj.khem@gmail.com>
Date: 2011-03-03
Description:
diff --git a/meta/recipes-devtools/strace/strace-4.5.20/sigmask.patch b/meta/recipes-devtools/strace/strace-4.5.20/sigmask.patch
index 9bca52832a..99962af48a 100644
--- a/meta/recipes-devtools/strace/strace-4.5.20/sigmask.patch
+++ b/meta/recipes-devtools/strace/strace-4.5.20/sigmask.patch
@@ -2,6 +2,7 @@ sigmask is a macro which is dropped if BSD compatibility is
not enabled. So we check if the macro does not exist then
we define it to __sigmask
+Upstream-Status: Inappropriate [configuration]
Signed-off-by: Khem Raj <raj.khem@gmail.com>
Index: strace-4.5.20/signal.c
diff --git a/meta/recipes-gnome/gnome/gobject-introspection/use-usr-bin-env-for-python.patch b/meta/recipes-gnome/gnome/gobject-introspection/use-usr-bin-env-for-python.patch
index 67b85470d3..ea00157d46 100644
--- a/meta/recipes-gnome/gnome/gobject-introspection/use-usr-bin-env-for-python.patch
+++ b/meta/recipes-gnome/gnome/gobject-introspection/use-usr-bin-env-for-python.patch
@@ -1,3 +1,5 @@
+Upstream-Status: Inappropriate [configuration]
+
Index: gobject-introspection-0.9.10/tools/g-ir-annotation-tool.in
===================================================================
--- gobject-introspection-0.9.10.orig/tools/g-ir-annotation-tool.in
diff --git a/meta/recipes-gnome/libglade/libglade-2.6.4/python_environment.patch b/meta/recipes-gnome/libglade/libglade-2.6.4/python_environment.patch
index b4ca49de25..b5b2ec4534 100644
--- a/meta/recipes-gnome/libglade/libglade-2.6.4/python_environment.patch
+++ b/meta/recipes-gnome/libglade/libglade-2.6.4/python_environment.patch
@@ -1,7 +1,7 @@
Using @PYTHON@ for this path would result in the build system python being
referred to. Instead we want to locate python from the environment.
-Upstream Status: Inappropriate [configuration]
+Upstream-Status: Inappropriate [configuration]
diff -ruN libglade-2.6.4-orig//libglade-convert.in libglade-2.6.4/libglade-convert.in
--- libglade-2.6.4-orig//libglade-convert.in 2011-09-22 10:18:28.991164003 +0800
diff --git a/meta/recipes-kernel/blktrace/blktrace/blktrace-makefile.patch b/meta/recipes-kernel/blktrace/blktrace/blktrace-makefile.patch
index c6a06ed349..c0f5fb0b3e 100644
--- a/meta/recipes-kernel/blktrace/blktrace/blktrace-makefile.patch
+++ b/meta/recipes-kernel/blktrace/blktrace/blktrace-makefile.patch
@@ -1,3 +1,5 @@
+Upstream-Status: Inappropriate [configuration]
+
Index: git/Makefile
===================================================================
--- git.orig/Makefile 2010-11-22 11:20:14.303472770 -0600
diff --git a/meta/recipes-kernel/dtc/dtc/make_install.patch b/meta/recipes-kernel/dtc/dtc/make_install.patch
index 2f7d8091ce..1120617e7b 100644
--- a/meta/recipes-kernel/dtc/dtc/make_install.patch
+++ b/meta/recipes-kernel/dtc/dtc/make_install.patch
@@ -1,3 +1,5 @@
+Upstream-Status: Inappropriate [configuration]
+
Index: git/Makefile
===================================================================
--- git.orig/Makefile 2011-11-02 14:52:17.243104779 -0700
diff --git a/meta/recipes-kernel/linux/linux-yocto/tools-perf-no-scripting.patch b/meta/recipes-kernel/linux/linux-yocto/tools-perf-no-scripting.patch
index e0ad9997f7..d07335a5f7 100644
--- a/meta/recipes-kernel/linux/linux-yocto/tools-perf-no-scripting.patch
+++ b/meta/recipes-kernel/linux/linux-yocto/tools-perf-no-scripting.patch
@@ -1,3 +1,6 @@
+
+Upstream-Status: Inappropriate [configuration]
+
Index: tools/perf/Makefile
===================================================================
--- a/tools/perf/Makefile 2011-01-14 14:17:33.127008554 -0600
diff --git a/meta/recipes-kernel/sysprof/files/rmb-arm.patch b/meta/recipes-kernel/sysprof/files/rmb-arm.patch
index 60e7f707a3..c53ac6427c 100644
--- a/meta/recipes-kernel/sysprof/files/rmb-arm.patch
+++ b/meta/recipes-kernel/sysprof/files/rmb-arm.patch
@@ -1,3 +1,6 @@
+
+Upstream-Status: Pending
+
Index: git/util.h
===================================================================
--- git.orig/util.h 2010-12-07 22:41:57.156243001 -0600
diff --git a/meta/recipes-kernel/sysprof/files/rmb-mips.patch b/meta/recipes-kernel/sysprof/files/rmb-mips.patch
index 84f968ef00..e055b8ad8b 100644
--- a/meta/recipes-kernel/sysprof/files/rmb-mips.patch
+++ b/meta/recipes-kernel/sysprof/files/rmb-mips.patch
@@ -1,3 +1,5 @@
+Upstream-Status: Pending
+
Index: git/util.h
===================================================================
--- git.orig/util.h 2010-12-08 01:22:44.486243001 -0600
diff --git a/meta/recipes-multimedia/musicbrainz/libmusicbrainz-3.0.3/allow-libdir-override.patch b/meta/recipes-multimedia/musicbrainz/libmusicbrainz-3.0.3/allow-libdir-override.patch
index 88f414ae05..d59d12e69b 100644
--- a/meta/recipes-multimedia/musicbrainz/libmusicbrainz-3.0.3/allow-libdir-override.patch
+++ b/meta/recipes-multimedia/musicbrainz/libmusicbrainz-3.0.3/allow-libdir-override.patch
@@ -2,6 +2,8 @@ Allow LIB_INSTALL_DIR to be set by the the cmake configure invocation. We dont
easily have a way of determining something that patches ${LIB_SUFFIX} so we'll
set LIB_INSTALL_DIR.
+Upstream-Status: Inappropriate [configuration]
+
Signed-off-by: Kumar Gala <galak@kernel.crashing.org>
Index: libmusicbrainz-3.0.3/CMakeLists.txt
diff --git a/meta/recipes-support/gmp/gmp/gmp_bugfix.patch b/meta/recipes-support/gmp/gmp/gmp_bugfix.patch
index a96136fcc3..329c8804a6 100644
--- a/meta/recipes-support/gmp/gmp/gmp_bugfix.patch
+++ b/meta/recipes-support/gmp/gmp/gmp_bugfix.patch
@@ -1,4 +1,4 @@
-UpstreamStatus: Pending
+Upstream-Status: Pending
When LONG_MIN is passed to val, -val is undefined. This patch fixes
it. See for details: http://gcc.gnu.org/bugzilla/show_bug.cgi?id=50066