summaryrefslogtreecommitdiffstats
path: root/meta
diff options
context:
space:
mode:
authorRichard Purdie <richard.purdie@linuxfoundation.org>2011-11-16 22:01:46 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-01-30 16:39:06 +0000
commitc90b1faa34e908c7f63e1a64027873858e6d7e8a (patch)
tree1b126fe1a8806f8cc36c744ed8d455c6345918a4 /meta
parent018442ed2cd251f85212dfa1d03c0b24a0750bfa (diff)
downloadopenembedded-core-c90b1faa34e908c7f63e1a64027873858e6d7e8a.tar.gz
update-alternatives: Various fixes
dpkg-native's update-alternatives is broken for offline work so don't install it. Also list update-alternatives in the multiprovider whitelist to avoid unwanted multiple provider warnings when multiple package backends are enabled. (From OE-Core rev: 300336fc4a310ed16a14ad041744708d54aae189) Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta')
-rw-r--r--meta/conf/bitbake.conf2
-rw-r--r--meta/recipes-devtools/dpkg/dpkg.inc12
-rw-r--r--meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb2
-rw-r--r--meta/recipes-devtools/opkg/opkg_svn.bb2
4 files changed, 13 insertions, 5 deletions
diff --git a/meta/conf/bitbake.conf b/meta/conf/bitbake.conf
index 99d80d840e..08079d1965 100644
--- a/meta/conf/bitbake.conf
+++ b/meta/conf/bitbake.conf
@@ -243,7 +243,7 @@ PROVIDES = ""
PROVIDES_prepend = "${P} ${PF} ${PN} "
RPROVIDES = ""
-MULTI_PROVIDER_WHITELIST = "virtual/libintl virtual/libintl-native virtual/libintl-nativesdk virtual/xserver"
+MULTI_PROVIDER_WHITELIST = "virtual/libintl virtual/libintl-native virtual/libintl-nativesdk virtual/xserver virtual/update-alternatives-native virtual/update-alternatives"
SOLIBS = ".so.*"
SOLIBS_darwin = ".*.dylib"
diff --git a/meta/recipes-devtools/dpkg/dpkg.inc b/meta/recipes-devtools/dpkg/dpkg.inc
index 9929b3a734..041737b1d2 100644
--- a/meta/recipes-devtools/dpkg/dpkg.inc
+++ b/meta/recipes-devtools/dpkg/dpkg.inc
@@ -48,10 +48,18 @@ rm -f ${sysconfdir}/rcS.d/S${DPKG_INIT_POSITION}configure
}
do_install_append () {
- mv ${D}${bindir}/update-alternatives ${D}${sbindir}
+ if [ "${PN}" = "dpkg-native" ]; then
+ # update-alternatives doesn't have an offline mode
+ rm ${D}${bindir}/update-alternatives
+ else
+ mv ${D}${bindir}/update-alternatives ${D}${sbindir}
+ fi
}
-PROVIDES += "virtual/update-alternatives"
+PROV = "virtual/update-alternatives"
+PROV_virtclass-native = ""
+
+PROVIDES += "${PROV}"
PACKAGES =+ "update-alternatives-dpkg"
FILES_update-alternatives-dpkg = "${sbindir}/update-alternatives ${localstatedir}/lib/dpkg/alternatives ${sysconfdir}/alternatives"
diff --git a/meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb b/meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb
index 8b45a00a6a..f1a0eebcd5 100644
--- a/meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb
+++ b/meta/recipes-devtools/dpkg/dpkg_1.15.8.7.bb
@@ -9,5 +9,5 @@ SRC_URI += "file://noman.patch \
SRC_URI[md5sum] = "d1731d4147c1ea3b537a4d094519a6dc"
SRC_URI[sha256sum] = "1ec1376471b04717a4497e5d7a27cd545248c92116898ce0c53ced8ea94267b5"
-PR = "${INC_PR}.0"
+PR = "${INC_PR}.1"
diff --git a/meta/recipes-devtools/opkg/opkg_svn.bb b/meta/recipes-devtools/opkg/opkg_svn.bb
index 8f50f677bd..acb21f2cb9 100644
--- a/meta/recipes-devtools/opkg/opkg_svn.bb
+++ b/meta/recipes-devtools/opkg/opkg_svn.bb
@@ -18,7 +18,7 @@ S = "${WORKDIR}/trunk"
SRCREV = "625"
PV = "0.1.8+svnr${SRCPV}"
-PR = "r3"
+PR = "r4"
PACKAGES =+ "libopkg${PKGSUFFIX}-dev libopkg${PKGSUFFIX} update-alternatives-cworth${PKGSUFFIX}"