summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorJuro Bystricky <juro.bystricky@intel.com>2017-10-13 12:24:03 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-05 13:44:57 +0000
commitf12d493418417c8529a97c7a768e4af58ea5c91b (patch)
tree7946438fc356f8e1513377eab66ed52e93a76db5 /meta/recipes-support
parent3e6bbb81d143919e37cea1549220d27df22080fe (diff)
downloadopenembedded-core-f12d493418417c8529a97c7a768e4af58ea5c91b.tar.gz
nettle-ptest: fix a failing test
This patch changes the result of the nettle dlopen-test from FAIL to PASS. The test used to fail because the test could not find and load libnettle.so. This patch fixes this by using absolute path instead of relative. This was the only test out of 88 that used to fail. Signed-off-by: Juro Bystricky <juro.bystricky@intel.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/nettle/nettle-3.3/dlopen-test.patch20
-rw-r--r--meta/recipes-support/nettle/nettle_3.3.bb4
2 files changed, 24 insertions, 0 deletions
diff --git a/meta/recipes-support/nettle/nettle-3.3/dlopen-test.patch b/meta/recipes-support/nettle/nettle-3.3/dlopen-test.patch
new file mode 100644
index 0000000000..c4f0b7ea1c
--- /dev/null
+++ b/meta/recipes-support/nettle/nettle-3.3/dlopen-test.patch
@@ -0,0 +1,20 @@
+Replace relative path of libnettle.so with absolute path so the test
+program can find it.
+Relative paths are not suitable, as the folder strucure for ptest
+is different from the one expected by the nettle testsuite.
+
+Upstream-Status: Inappropriate [embedded specific]
+
+Signed-off-by: Juro Bystricky <juro.bystricky@intel.com>
+
+--- a/testsuite/dlopen-test.c 2016-10-01 00:28:38.000000000 -0700
++++ b/testsuite/dlopen-test.c 2017-10-13 11:08:57.227572860 -0700
+@@ -9,7 +9,7 @@
+ main (int argc UNUSED, char **argv UNUSED)
+ {
+ #if HAVE_LIBDL
+- void *handle = dlopen ("../libnettle.so", RTLD_NOW);
++ void *handle = dlopen ("/usr/lib/libnettle.so", RTLD_NOW);
+ int (*get_version)(void);
+ if (!handle)
+ {
diff --git a/meta/recipes-support/nettle/nettle_3.3.bb b/meta/recipes-support/nettle/nettle_3.3.bb
index b76babfe2d..39516781bc 100644
--- a/meta/recipes-support/nettle/nettle_3.3.bb
+++ b/meta/recipes-support/nettle/nettle_3.3.bb
@@ -11,5 +11,9 @@ SRC_URI += "\
file://check-header-files-of-openssl-only-if-enable_.patch \
"
+SRC_URI_append_class-target = "\
+ file://dlopen-test.patch \
+ "
+
SRC_URI[md5sum] = "10f969f78a463704ae73529978148dbe"
SRC_URI[sha256sum] = "46942627d5d0ca11720fec18d81fc38f7ef837ea4197c1f630e71ce0d470b11e"