summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorChen Qi <Qi.Chen@windriver.com>2020-06-05 10:09:45 +0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-06-05 07:46:55 +0100
commitb5ffdb296f211403f987b5d5a724a94ee91dc80c (patch)
treec70eb918b291ea6cc2d1f116803270dfd2f98e15 /meta/recipes-support
parentd908ca51b72f4ba417e7573ae3d953535f53286c (diff)
downloadopenembedded-core-b5ffdb296f211403f987b5d5a724a94ee91dc80c.tar.gz
db: do not install db_verify if 'verify' is not enabled
On target, when running `db_verify /var/lib/rpm/Packages', we get the following error. db_verify: BDB0571 library build did not include support for database verification This is because db_verify is installed but 'verify' PACKAGECONFIG is not enabled. So fix it by not installing do_verify in such case. Signed-off-by: Chen Qi <Qi.Chen@windriver.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/db/db_5.3.28.bb3
1 files changed, 3 insertions, 0 deletions
diff --git a/meta/recipes-support/db/db_5.3.28.bb b/meta/recipes-support/db/db_5.3.28.bb
index 3a0923ae36..318efcb61d 100644
--- a/meta/recipes-support/db/db_5.3.28.bb
+++ b/meta/recipes-support/db/db_5.3.28.bb
@@ -109,6 +109,9 @@ do_install_append() {
fi
chown -R root:root ${D}
+ if ${@bb.utils.contains('PACKAGECONFIG', 'verify', 'false', 'true', d)}; then
+ rm -f ${D}${bindir}/db_verify
+ fi
}
INSANE_SKIP_${PN} = "dev-so"