summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorRoss Burton <ross.burton@intel.com>2018-03-06 14:57:13 +0000
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-03-07 06:33:59 -0800
commit9c367c92df0ca8afe0a75b066fdc9e21560d57ff (patch)
tree2d1f0cfb898a2b15b44b531a71eb1e83ab23e3b0 /meta/recipes-support
parentcdeb3d530af6cec1959c986aff3d6906939c8918 (diff)
downloadopenembedded-core-9c367c92df0ca8afe0a75b066fdc9e21560d57ff.tar.gz
libfm: fix dependencies
libfm uses glib-gettextize so explicitly depend on glib-2.0-native. Instead of depending on gettext-native, inherit gettext. Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/libfm/libfm-extra_1.2.5.bb4
-rw-r--r--meta/recipes-support/libfm/libfm_1.2.5.bb4
2 files changed, 4 insertions, 4 deletions
diff --git a/meta/recipes-support/libfm/libfm-extra_1.2.5.bb b/meta/recipes-support/libfm/libfm-extra_1.2.5.bb
index 0134572f1f..c0fd83ef34 100644
--- a/meta/recipes-support/libfm/libfm-extra_1.2.5.bb
+++ b/meta/recipes-support/libfm/libfm-extra_1.2.5.bb
@@ -5,7 +5,7 @@ LICENSE = "LGPLv2+"
LIC_FILES_CHKSUM = "file://src/fm-extra.h;beginline=8;endline=21;md5=ef1f84da64b3c01cca447212f7ef6007"
SECTION = "x11/libs"
-DEPENDS = "glib-2.0 intltool-native gettext-native"
+DEPENDS = "glib-2.0-native glib-2.0 intltool-native"
SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/libfm-${PV}.tar.xz \
file://0001-nls.m4-Take-it-from-gettext-0.15.patch \
@@ -18,6 +18,6 @@ S = "${WORKDIR}/libfm-${PV}"
EXTRA_OECONF = "--with-extra-only --with-gtk=no"
-inherit autotools pkgconfig gtk-doc
+inherit autotools pkgconfig gtk-doc gettext
do_configure[dirs] =+ "${S}/m4"
diff --git a/meta/recipes-support/libfm/libfm_1.2.5.bb b/meta/recipes-support/libfm/libfm_1.2.5.bb
index c1deea6853..596408353f 100644
--- a/meta/recipes-support/libfm/libfm_1.2.5.bb
+++ b/meta/recipes-support/libfm/libfm_1.2.5.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=4641e94ec96f98fabc56ff9cc48be14b \
SECTION = "x11/libs"
-DEPENDS = "glib-2.0 pango gtk+3 menu-cache intltool-native libexif libfm-extra gettext-native"
+DEPENDS = "glib-2.0 glib-2.0-native pango gtk+3 menu-cache intltool-native libexif libfm-extra"
SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/libfm-${PV}.tar.xz \
file://0001-Correctly-check-the-stamp-file-that-indicates-if-we-.patch \
@@ -19,7 +19,7 @@ SRC_URI = "${SOURCEFORGE_MIRROR}/pcmanfm/libfm-${PV}.tar.xz \
SRC_URI[md5sum] = "a1ba9ae5e920f38b647dd511edd6c807"
SRC_URI[sha256sum] = "c706bb1020cf5f2d6f5a9226f692ce1985947134dcf2bde64278bd0420779b5a"
-inherit autotools pkgconfig gtk-doc distro_features_check
+inherit autotools pkgconfig gtk-doc gettext distro_features_check
ANY_OF_DISTRO_FEATURES = "${GTK3DISTROFEATURES}"
EXTRA_OECONF = "--with-gtk=3"