summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorArmin Kuster <akuster808@gmail.com>2018-05-18 19:13:51 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2018-05-29 11:25:07 +0100
commit9755699275e6290950145685c186082dfcd28a9e (patch)
tree59bb06b86866bc86127894ef80b4dde0ccd48214 /meta/recipes-support
parentdcd7ce8c3c8b5e9f86886bab5fcc18aed209c26e (diff)
downloadopenembedded-core-9755699275e6290950145685c186082dfcd28a9e.tar.gz
nss: update to 3.36.1
removed patches included in update: 0001-Bug-1437734-Use-snprintf-in-sign.c-r-ttaubert.patch nss-build-hacl-poly1305-aarch64.patch Signed-off-by: Armin Kuster <akuster808@gmail.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/nss/nss/0001-Bug-1437734-Use-snprintf-in-sign.c-r-ttaubert.patch119
-rw-r--r--meta/recipes-support/nss/nss/nss-build-hacl-poly1305-aarch64.patch30
-rw-r--r--meta/recipes-support/nss/nss_3.36.1.bb (renamed from meta/recipes-support/nss/nss_3.35.bb)6
3 files changed, 2 insertions, 153 deletions
diff --git a/meta/recipes-support/nss/nss/0001-Bug-1437734-Use-snprintf-in-sign.c-r-ttaubert.patch b/meta/recipes-support/nss/nss/0001-Bug-1437734-Use-snprintf-in-sign.c-r-ttaubert.patch
deleted file mode 100644
index bc10f3385d..0000000000
--- a/meta/recipes-support/nss/nss/0001-Bug-1437734-Use-snprintf-in-sign.c-r-ttaubert.patch
+++ /dev/null
@@ -1,119 +0,0 @@
-From 6f7d7be9997ba6727a5ad7c3800df9051160dc12 Mon Sep 17 00:00:00 2001
-From: Martin Thomson <martin.thomson@gmail.com>
-Date: Tue, 13 Feb 2018 12:30:58 +1100
-Subject: [PATCH] Bug 1437734 - Use snprintf in sign.c, r=ttaubert
-
---HG--
-extra : rebase_source : 97921ece71ff86b18d32b891591608290eed4d83
----
-Signed-off-by: Khem Raj <raj.khem@gmail.com>
-Upstream-Status: Backport [https://github.com/nss-dev/nss/commit/0a9078b3cde97add7c825c9d13467a8401ad0c88#diff-b42512151dc137537091f823f7701804.patch]
-
- nss/cmd/signtool/sign.c | 58 ++++++++++++++++++++++++++++++++++++++++---------
- 1 file changed, 48 insertions(+), 10 deletions(-)
-
-diff --git a/nss/cmd/signtool/sign.c b/nss/cmd/signtool/sign.c
-index 6e776069a..6f8e43946 100644
---- a/nss/cmd/signtool/sign.c
-+++ b/nss/cmd/signtool/sign.c
-@@ -43,6 +43,7 @@ SignArchive(char *tree, char *keyName, char *zip_file, int javascript,
- int status;
- char tempfn[FNSIZE], fullfn[FNSIZE];
- int keyType = rsaKey;
-+ int count;
-
- metafile = meta_file;
- optimize = _optimize;
-@@ -81,9 +82,18 @@ SignArchive(char *tree, char *keyName, char *zip_file, int javascript,
- }
-
- /* rsa/dsa to zip */
-- sprintf(tempfn, "META-INF/%s.%s", base, (keyType == dsaKey ? "dsa"
-- : "rsa"));
-- sprintf(fullfn, "%s/%s", tree, tempfn);
-+ count = snprintf(tempfn, sizeof(tempfn), "META-INF/%s.%s", base, (keyType == dsaKey ? "dsa" : "rsa"));
-+ if (count >= sizeof(tempfn)) {
-+ PR_fprintf(errorFD, "unable to write key metadata\n");
-+ errorCount++;
-+ exit(ERRX);
-+ }
-+ count = snprintf(fullfn, sizeof(fullfn), "%s/%s", tree, tempfn);
-+ if (count >= sizeof(fullfn)) {
-+ PR_fprintf(errorFD, "unable to write key metadata\n");
-+ errorCount++;
-+ exit(ERRX);
-+ }
- JzipAdd(fullfn, tempfn, zipfile, compression_level);
-
- /* Loop through all files & subdirectories, add to archive */
-@@ -93,20 +103,44 @@ SignArchive(char *tree, char *keyName, char *zip_file, int javascript,
- }
- /* mf to zip */
- strcpy(tempfn, "META-INF/manifest.mf");
-- sprintf(fullfn, "%s/%s", tree, tempfn);
-+ count = snprintf(fullfn, sizeof(fullfn), "%s/%s", tree, tempfn);
-+ if (count >= sizeof(fullfn)) {
-+ PR_fprintf(errorFD, "unable to write manifest\n");
-+ errorCount++;
-+ exit(ERRX);
-+ }
- JzipAdd(fullfn, tempfn, zipfile, compression_level);
-
- /* sf to zip */
-- sprintf(tempfn, "META-INF/%s.sf", base);
-- sprintf(fullfn, "%s/%s", tree, tempfn);
-+ count = snprintf(tempfn, sizeof(tempfn), "META-INF/%s.sf", base);
-+ if (count >= sizeof(tempfn)) {
-+ PR_fprintf(errorFD, "unable to write sf metadata\n");
-+ errorCount++;
-+ exit(ERRX);
-+ }
-+ count = snprintf(fullfn, sizeof(fullfn), "%s/%s", tree, tempfn);
-+ if (count >= sizeof(fullfn)) {
-+ PR_fprintf(errorFD, "unable to write sf metadata\n");
-+ errorCount++;
-+ exit(ERRX);
-+ }
- JzipAdd(fullfn, tempfn, zipfile, compression_level);
-
- /* Add the rsa/dsa file to the zip archive normally */
- if (!xpi_arc) {
- /* rsa/dsa to zip */
-- sprintf(tempfn, "META-INF/%s.%s", base, (keyType == dsaKey ? "dsa"
-- : "rsa"));
-- sprintf(fullfn, "%s/%s", tree, tempfn);
-+ count = snprintf(tempfn, sizeof(tempfn), "META-INF/%s.%s", base, (keyType == dsaKey ? "dsa" : "rsa"));
-+ if (count >= sizeof(tempfn)) {
-+ PR_fprintf(errorFD, "unable to write key metadata\n");
-+ errorCount++;
-+ exit(ERRX);
-+ }
-+ count = snprintf(fullfn, sizeof(fullfn), "%s/%s", tree, tempfn);
-+ if (count >= sizeof(fullfn)) {
-+ PR_fprintf(errorFD, "unable to write key metadata\n");
-+ errorCount++;
-+ exit(ERRX);
-+ }
- JzipAdd(fullfn, tempfn, zipfile, compression_level);
- }
-
-@@ -408,6 +442,7 @@ static int
- manifesto_xpi_fn(char *relpath, char *basedir, char *reldir, char *filename, void *arg)
- {
- char fullname[FNSIZE];
-+ int count;
-
- if (verbosity >= 0) {
- PR_fprintf(outputFD, "--> %s\n", relpath);
-@@ -421,7 +456,10 @@ manifesto_xpi_fn(char *relpath, char *basedir, char *reldir, char *filename, voi
- if (!PL_HashTableLookup(extensions, ext))
- return 0;
- }
-- sprintf(fullname, "%s/%s", basedir, relpath);
-+ count = snprintf(fullname, sizeof(fullname), "%s/%s", basedir, relpath);
-+ if (count >= sizeof(fullname)) {
-+ return 1;
-+ }
- JzipAdd(fullname, relpath, zipfile, compression_level);
-
- return 0;
diff --git a/meta/recipes-support/nss/nss/nss-build-hacl-poly1305-aarch64.patch b/meta/recipes-support/nss/nss/nss-build-hacl-poly1305-aarch64.patch
deleted file mode 100644
index 8276f89e8b..0000000000
--- a/meta/recipes-support/nss/nss/nss-build-hacl-poly1305-aarch64.patch
+++ /dev/null
@@ -1,30 +0,0 @@
-# HG changeset patch
-# User Daiki Ueno <dueno@redhat.com>
-# Date 1516710574 -3600
-# Tue Jan 23 13:29:34 2018 +0100
-# Node ID 27f27ce21c2c6ff5a47fa9e17c438b000366c9c9
-# Parent be1dca5ac80541d3b81a8da9d42854d8b1cceefb
-Build Hacl_Poly1305_64.o on aarch64 even with make
-
-Upstream-Status: Backport
-https://bug1432455.bmoattachments.org/attachment.cgi?id=8944691
-Signed-off-by: Armin Kuster <akuster@mvista.com>
-
-Index: nss-3.35/nss/lib/freebl/Makefile
-===================================================================
---- nss-3.35.orig/nss/lib/freebl/Makefile
-+++ nss-3.35/nss/lib/freebl/Makefile
-@@ -533,7 +533,12 @@ ifndef NSS_DISABLE_CHACHAPOLY
- EXTRA_SRCS += chacha20_vec.c
- endif
- else
-- EXTRA_SRCS += poly1305.c
-+ ifeq ($(CPU_ARCH),aarch64)
-+ EXTRA_SRCS += Hacl_Poly1305_64.c
-+ else
-+ EXTRA_SRCS += poly1305.c
-+ endif
-+
- EXTRA_SRCS += chacha20.c
- VERIFIED_SRCS += Hacl_Chacha20.c
- endif # x86_64
diff --git a/meta/recipes-support/nss/nss_3.35.bb b/meta/recipes-support/nss/nss_3.36.1.bb
index 84f1916f30..f8555389ff 100644
--- a/meta/recipes-support/nss/nss_3.35.bb
+++ b/meta/recipes-support/nss/nss_3.36.1.bb
@@ -26,12 +26,10 @@ SRC_URI = "http://ftp.mozilla.org/pub/mozilla.org/security/nss/releases/${VERSIO
file://disable-Wvarargs-with-clang.patch \
file://pqg.c-ULL_addend.patch \
file://Fix-compilation-for-X32.patch \
- file://nss-build-hacl-poly1305-aarch64.patch \
- file://0001-Bug-1437734-Use-snprintf-in-sign.c-r-ttaubert.patch \
"
-SRC_URI[md5sum] = "9467ec9e65c5aeb3254a50250490f5f7"
-SRC_URI[sha256sum] = "f4127de09bede39f5fd0f789d33c3504c5d261e69ea03022d46b319b3e32f6fa"
+SRC_URI[md5sum] = "814d8fe3ec89006cf62078e2a56cf2f9"
+SRC_URI[sha256sum] = "6025441d528ff6a7f1a4b673b6ee7d3540731ada3f78d5acd5c3b3736b222bff"
UPSTREAM_CHECK_URI = "https://developer.mozilla.org/en-US/docs/Mozilla/Projects/NSS/NSS_Releases"
UPSTREAM_CHECK_REGEX = "NSS_(?P<pver>.+)_release_notes"