summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorJoe Slater <jslater@windriver.com>2017-11-15 10:54:09 -0800
committerRichard Purdie <richard.purdie@linuxfoundation.org>2017-11-29 23:41:36 +0000
commit95b65eefe7eb001752a37d1015bbf9be63bfd6bb (patch)
treeba1b5cc6d19c2c2a91d05e08551d904a1be2fe83 /meta/recipes-support
parentcf77a7be0209e2121747ba2fbf1622d164fe4c67 (diff)
downloadopenembedded-core-95b65eefe7eb001752a37d1015bbf9be63bfd6bb.tar.gz
nss: pay attention to CFLAGS
nss ignores CFLAGS so we suggest them via CC. Signed-off-by: Joe Slater <jslater@windriver.com> Signed-off-by: Ross Burton <ross.burton@intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/nss/nss_3.33.bb7
1 files changed, 6 insertions, 1 deletions
diff --git a/meta/recipes-support/nss/nss_3.33.bb b/meta/recipes-support/nss/nss_3.33.bb
index e3d4f96946..06d81ce05d 100644
--- a/meta/recipes-support/nss/nss_3.33.bb
+++ b/meta/recipes-support/nss/nss_3.33.bb
@@ -104,7 +104,12 @@ do_compile() {
# We can modify CC in the environment, but if we set it via an
# argument to make, nsinstall, a host program, will also build with it!
#
- export CC="${CC} -g"
+ # nss pretty much does its own thing with CFLAGS, so we put them into CC.
+ # Optimization will get clobbered, but most of the stuff will survive.
+ # The motivation for this is to point to the correct place for debug
+ # source files and CFLAGS does that. Nothing uses CCC.
+ #
+ export CC="${CC} ${CFLAGS}"
make -C ./nss CCC="${CXX} -g" \
OS_TEST=${OS_TEST} \
RPATH="${RPATH}"