summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorSaul Wold <sgw@linux.intel.com>2012-06-12 22:18:29 -0700
committerRichard Purdie <richard.purdie@linuxfoundation.org>2012-06-15 15:09:18 +0100
commit93aa773c4c03c21a70d7d53cf93e43416e17007c (patch)
treee9298ad200770ab374ac647c4b981cb86c493b89 /meta/recipes-support
parent86e3b90d1963fa6982869e005d7858222a8527d5 (diff)
downloadopenembedded-core-93aa773c4c03c21a70d7d53cf93e43416e17007c.tar.gz
beecrypt: add patch for build issue on Fedora 17
../../x86_64-linux-libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I../.. -I../../include -isystem/intel/poky/builds/f17/tmp/sysroots/x86_64-linux/usr/include -isystem/intel/poky/builds/f17/tmp/sysroots/x86_64-linux/usr/include -O2 -pipe -Wa,--noexecstack -c -o Properties.lo Properties.cxx x86_64-linux-libtool: compile: g++ -DHAVE_CONFIG_H -I. -I../.. -I../../include -isystem/intel/poky/builds/f17/tmp/sysroots/x86_64-linux/usr/include -isystem/intel/poky/builds/f17/tmp/sysroots/x86_64-linux/usr/include -O2 -pipe -Wa,--noexecstack -c Properties.cxx -fPIC -DPIC -o .libs/Properties.o In file included from ../../include/beecrypt/c++/util/Hashtable.h:42:0, from ../../include/beecrypt/c++/util/Properties.h:36, from Properties.cxx:25: ../../include/beecrypt/c++/util/AbstractSet.h: In instantiation of 'bool beecrypt::util::AbstractSet<E>::equals(const beecrypt::lang::Object*) const [with E = beecrypt::util::Map<beecrypt::lang::Object, beecrypt::lang::Object>::Entry]': Properties.cxx:228:1: required from here ../../include/beecrypt/c++/util/AbstractSet.h:59:27: error: 'containsAll' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive] ../../include/beecrypt/c++/util/AbstractSet.h:59:27: note: declarations in dependent base 'beecrypt::util::AbstractCollection<beecrypt::util::Map<beecrypt::lang::Object, beecrypt::lang::Object>::Entry>' are not found by unqualified lookup ../../include/beecrypt/c++/util/AbstractSet.h:59:27: note: use 'this->containsAll' instead ../../include/beecrypt/c++/util/AbstractSet.h: In instantiation of 'bool beecrypt::util::AbstractSet<E>::equals(const beecrypt::lang::Object*) const [with E = beecrypt::lang::Object]': Properties.cxx:228:1: required from here ../../include/beecrypt/c++/util/AbstractSet.h:59:27: error: 'containsAll' was not declared in this scope, and no declarations were found by argument-dependent lookup at the point of instantiation [-fpermissive] ../../include/beecrypt/c++/util/AbstractSet.h:59:27: note: declarations in dependent base 'beecrypt::util::AbstractCollection<beecrypt::lang::Object>' are not found by unqualified lookup ../../include/beecrypt/c++/util/AbstractSet.h:59:27: note: use 'this->containsAll' instead [YOCTO #2593] Signed-off-by: Saul Wold <sgw@linux.intel.com>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/beecrypt/beecrypt/fix-for-gcc-4.7.patch39
-rw-r--r--meta/recipes-support/beecrypt/beecrypt_4.2.1.bb5
2 files changed, 42 insertions, 2 deletions
diff --git a/meta/recipes-support/beecrypt/beecrypt/fix-for-gcc-4.7.patch b/meta/recipes-support/beecrypt/beecrypt/fix-for-gcc-4.7.patch
new file mode 100644
index 0000000000..8144e39be0
--- /dev/null
+++ b/meta/recipes-support/beecrypt/beecrypt/fix-for-gcc-4.7.patch
@@ -0,0 +1,39 @@
+
+gcc-4.7 seems to be stricter about some things, so follow
+the suggestion from the error/note information.
+
+ ../../x86_64-linux-libtool --tag=CXX --mode=compile g++ -DHAVE_CONFIG_H -I. -I../..
+ x86_64-linux-libtool: compile: g++ -DHAVE_CONFIG_H -I. -I../.. -I../../include -isyst
+ In file included from ../../include/beecrypt/c++/util/Hashtable.h:42:0,
+ from ../../include/beecrypt/c++/util/Properties.h:36,
+ from Properties.cxx:25:
+ ../../include/beecrypt/c++/util/AbstractSet.h: In instantiation of 'bool beecrypt::uti
+ Properties.cxx:228:1: required from here
+ ../../include/beecrypt/c++/util/AbstractSet.h:59:27: error: 'containsAll' was not decl
+ ../../include/beecrypt/c++/util/AbstractSet.h:59:27: note: declarations in dependent b
+ ../../include/beecrypt/c++/util/AbstractSet.h:59:27: note: use 'this->containsAll' ins
+ ../../include/beecrypt/c++/util/AbstractSet.h: In instantiation of 'bool beecrypt::uti
+ Properties.cxx:228:1: required from here
+ ../../include/beecrypt/c++/util/AbstractSet.h:59:27: error: 'containsAll' was not decl
+ ../../include/beecrypt/c++/util/AbstractSet.h:59:27: note: declarations in dependent b
+ ../../include/beecrypt/c++/util/AbstractSet.h:59:27: note: use 'this->containsAll' ins
+
+
+Upstream-Status: Pending
+
+Signed-off-by: Saul Wold <sgw@linux.intel.com>
+
+
+Index: beecrypt-4.2.1/include/beecrypt/c++/util/AbstractSet.h
+===================================================================
+--- beecrypt-4.2.1.orig/include/beecrypt/c++/util/AbstractSet.h
++++ beecrypt-4.2.1/include/beecrypt/c++/util/AbstractSet.h
+@@ -56,7 +56,7 @@ namespace beecrypt {
+ if (c->size() != size())
+ return false;
+
+- return containsAll(*c);
++ return this->containsAll(*c);
+ }
+ return false;
+ }
diff --git a/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb b/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb
index 2b2b3486df..7baf92e788 100644
--- a/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb
+++ b/meta/recipes-support/beecrypt/beecrypt_4.2.1.bb
@@ -6,7 +6,8 @@ DESCRIPTION="Beecrypt is a general-purpose cryptography library."
HOMEPAGE="http://sourceforge.net/projects/beecrypt"
SRC_URI="${SOURCEFORGE_MIRROR}/beecrypt/beecrypt-${PV}.tar.gz \
file://disable-icu-check.patch \
- file://fix-security.patch"
+ file://fix-security.patch \
+ file://fix-for-gcc-4.7.patch"
SRC_URI[md5sum] = "8441c014170823f2dff97e33df55af1e"
SRC_URI[sha256sum] = "286f1f56080d1a6b1d024003a5fa2158f4ff82cae0c6829d3c476a4b5898c55d"
@@ -17,7 +18,7 @@ LIC_FILES_CHKSUM = "file://COPYING;md5=9894370afd5dfe7d02b8d14319e729a1 \
DEPENDS = "icu"
-PR = "r2"
+PR = "r3"
inherit autotools multilib_header
acpaths=""