summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-03 14:37:24 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-09 12:15:17 +0000
commit7e44275f4d286f005b2f19e3dcc9c6d390b98f30 (patch)
tree6f17cacd168a7217aac9dd821b392bafaaa9f1a1 /meta/recipes-support
parentfc4c82773d50756394108d2af474041b5113dbcc (diff)
downloadopenembedded-core-7e44275f4d286f005b2f19e3dcc9c6d390b98f30.tar.gz
serf: do not install the static library
scons is using host ar to create it, which may or may not be built with reproducible option by default. Rather than patch scons for the benefit of a single recipe, let's just not install the .a, which is unused anyway. Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/serf/serf_1.3.9.bb5
1 files changed, 5 insertions, 0 deletions
diff --git a/meta/recipes-support/serf/serf_1.3.9.bb b/meta/recipes-support/serf/serf_1.3.9.bb
index 6a27f12102..2fbf96f997 100644
--- a/meta/recipes-support/serf/serf_1.3.9.bb
+++ b/meta/recipes-support/serf/serf_1.3.9.bb
@@ -30,4 +30,9 @@ EXTRA_OESCONS = " \
OPENSSL="${STAGING_EXECPREFIXDIR}" \
"
+# scons creates non-reproducible archives
+do_install_append() {
+ rm ${D}/${libdir}/*.a
+}
+
BBCLASSEXTEND = "native nativesdk"