summaryrefslogtreecommitdiffstats
path: root/meta/recipes-support
diff options
context:
space:
mode:
authorAlexander Kanavin <alex.kanavin@gmail.com>2020-12-28 21:04:20 +0100
committerRichard Purdie <richard.purdie@linuxfoundation.org>2020-12-31 11:53:21 +0000
commit6c4b2dcf82378419efca587f033ecac08fbc3b00 (patch)
treee69e651a032e751e84c9ed9d023cf94e98ba373c /meta/recipes-support
parent4de7470c17aff5fe66f3baf96af88577c091b4c7 (diff)
downloadopenembedded-core-6c4b2dcf82378419efca587f033ecac08fbc3b00.tar.gz
gnutls: update 3.6.15 -> 3.7.0
Signed-off-by: Alexander Kanavin <alex.kanavin@gmail.com> Signed-off-by: Richard Purdie <richard.purdie@linuxfoundation.org>
Diffstat (limited to 'meta/recipes-support')
-rw-r--r--meta/recipes-support/gnutls/gnutls/arm_eabi.patch15
-rw-r--r--meta/recipes-support/gnutls/gnutls_3.7.0.bb (renamed from meta/recipes-support/gnutls/gnutls_3.6.15.bb)2
2 files changed, 14 insertions, 3 deletions
diff --git a/meta/recipes-support/gnutls/gnutls/arm_eabi.patch b/meta/recipes-support/gnutls/gnutls/arm_eabi.patch
index 34c8985c19..6eb1edbdb1 100644
--- a/meta/recipes-support/gnutls/gnutls/arm_eabi.patch
+++ b/meta/recipes-support/gnutls/gnutls/arm_eabi.patch
@@ -1,3 +1,8 @@
+From 8a5c96057cf305bbeac0d6e0e59ee24fbb9497fe Mon Sep 17 00:00:00 2001
+From: Joe Slater <jslater@windriver.com>
+Date: Wed, 25 Jan 2017 13:52:59 -0800
+Subject: [PATCH] gnutls: account for ARM_EABI
+
Certain syscall's are not availabe for arm-eabi, so we eliminate
reference to them.
@@ -5,12 +10,18 @@ Upstream-Status: Pending
Signed-off-by: Joe Slater <jslater@windriver.com>
+---
+ tests/seccomp.c | 2 ++
+ 1 file changed, 2 insertions(+)
+
+diff --git a/tests/seccomp.c b/tests/seccomp.c
+index ed14d00..3c5b726 100644
--- a/tests/seccomp.c
+++ b/tests/seccomp.c
-@@ -49,7 +49,9 @@ int disable_system_calls(void)
- }
+@@ -53,7 +53,9 @@ int disable_system_calls(void)
ADD_SYSCALL(nanosleep, 0);
+ ADD_SYSCALL(clock_nanosleep, 0);
+#if ! defined(__ARM_EABI__)
ADD_SYSCALL(time, 0);
+#endif
diff --git a/meta/recipes-support/gnutls/gnutls_3.6.15.bb b/meta/recipes-support/gnutls/gnutls_3.7.0.bb
index b936db50d1..e3ca86b933 100644
--- a/meta/recipes-support/gnutls/gnutls_3.6.15.bb
+++ b/meta/recipes-support/gnutls/gnutls_3.7.0.bb
@@ -21,7 +21,7 @@ SRC_URI = "https://www.gnupg.org/ftp/gcrypt/gnutls/v${SHRT_VER}/gnutls-${PV}.tar
file://arm_eabi.patch \
"
-SRC_URI[sha256sum] = "0ea8c3283de8d8335d7ae338ef27c53a916f15f382753b174c18b45ffd481558"
+SRC_URI[sha256sum] = "49e2a22691d252c9f24a9829b293a8f359095bc5a818351f05f1c0a5188a1df8"
inherit autotools texinfo pkgconfig gettext lib_package gtk-doc